]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- Changed comments about the lcd patch.
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_without  lcd             # use own LCD filtering instead of freetype's
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.4.14
13 Release:        2
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  e8c442ff821c0719a69508fecba9038f
18 Patch0:         %{name}-link.patch
19 # Updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
20 # The lcd patch is being maintained at
21 # http://bugs.freedesktop.org/show_bug.cgi?id=10301
22 # It is not applied upstream for political reasons (patents) and its fate has
23 # not been decided yet AFAIK. -- Qrczak
24 Patch1:         %{name}-1.2.4-lcd-filter-1.patch
25 URL:            http://cairographics.org/
26 BuildRequires:  autoconf >= 2.54
27 BuildRequires:  automake >= 1:1.7
28 BuildRequires:  fontconfig-devel
29 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
30 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
31 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
32 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
33 BuildRequires:  libpng-devel
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig
36 %if %{with xcb}
37 BuildRequires:  libxcb-devel >= 0.9.92
38 BuildRequires:  xcb-util-devel >= 0.2
39 %endif
40 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
41 BuildRequires:  zlib-devel
42 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
43 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
44 %{?with_glitz:Requires: glitz >= 0.5.1}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Cairo provides anti-aliased vector-based rendering for X. Paths
49 consist of line segments and cubic splines and can be rendered at any
50 width with various join and cap styles. All colors may be specified
51 with optional translucence (opacity/alpha) and combined using the
52 extended Porter/Duff compositing algebra as found in the X Render
53 Extension.
54
55 Cairo exports a stateful rendering API similar in spirit to the path
56 construction, text, and painting operators of PostScript, (with the
57 significant addition of translucence in the imaging model). When
58 complete, the API is intended to support the complete imaging model of
59 PDF 1.4.
60
61 %description -l pl.UTF-8
62 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
63 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
64 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
65 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
66 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
67 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
68 można znaleźć w rozszerzeniu X Render.
69
70 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
71 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
72 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
73 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
74
75 %package devel
76 Summary:        Development files for Cairo library
77 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       fontconfig-devel
81 Requires:       freetype-devel >= 1:2.1.10
82 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
83 Requires:       libpng-devel
84 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
85 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
86 Requires:       xorg-lib-libXrender-devel >= 0.6
87
88 %description devel
89 Development files for Cairo library.
90
91 %description devel -l pl.UTF-8
92 Pliki programistyczne biblioteki Cairo.
93
94 %package static
95 Summary:        Static Cairo library
96 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static Cairo library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka Cairo.
105
106 %package apidocs
107 Summary:        Cairo API documentation
108 Summary(pl.UTF-8):      Dokumentacja API Cairo
109 Group:          Documentation
110 Requires:       gtk-doc-common
111
112 %description apidocs
113 Cairo API documentation.
114
115 %description apidocs -l pl.UTF-8
116 Dokumentacja API Cairo.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %{?with_lcd:%patch1 -p1}
122
123 %build
124 %{?with_apidocs:%{__gtkdocize}}
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoheader}
128 %{__autoconf}
129 %{__automake}
130 %configure \
131         %{?with_apidocs:--enable-gtk-doc} \
132         %{?with_xcb:--enable-xcb} \
133         %{?with_glitz:--enable-glitz} \
134         --enable-ps \
135         --enable-pdf \
136         --with-html-dir=%{_gtkdocdir}
137 %{__make}
138 %{?with_tests:%{__make} check}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 # COPYING contains only notes, not LGPL/MPL texts
157 %doc AUTHORS COPYING ChangeLog NEWS README TODO
158 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libcairo.so
164 %{_libdir}/libcairo.la
165 %{_includedir}/cairo
166 %{_pkgconfigdir}/cairo.pc
167 %{_pkgconfigdir}/cairo-ft.pc
168 %{_pkgconfigdir}/cairo-pdf.pc
169 %{_pkgconfigdir}/cairo-png.pc
170 %{_pkgconfigdir}/cairo-ps.pc
171 %{_pkgconfigdir}/cairo-svg.pc
172 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
173 %{_pkgconfigdir}/cairo-xlib.pc
174 %{_pkgconfigdir}/cairo-xlib-xrender.pc
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libcairo.a
179
180 %if %{with apidocs}
181 %files apidocs
182 %defattr(644,root,root,755)
183 %{_gtkdocdir}/cairo
184 %endif
This page took 0.08277 seconds and 4 git commands to generate.