]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- rel 2; enable xcb backend for th
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_without  lcd             # use own LCD filtering instead of freetype's
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.4.0
13 Release:        2
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  b0882df4621bcf5b69f024b9475f8d4e
18 Patch0:         %{name}-link.patch
19 Patch1:         http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
20 URL:            http://cairographics.org/
21 BuildRequires:  autoconf >= 2.54
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  fontconfig-devel
24 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
25 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
26 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
28 BuildRequires:  libpng-devel
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 %if %{with xcb}
32 BuildRequires:  libxcb-devel
33 BuildRequires:  xcb-util-devel
34 %endif
35 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
36 BuildRequires:  zlib-devel
37 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
38 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
39 %{?with_glitz:Requires: glitz >= 0.5.1}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Cairo provides anti-aliased vector-based rendering for X. Paths
44 consist of line segments and cubic splines and can be rendered at any
45 width with various join and cap styles. All colors may be specified
46 with optional translucence (opacity/alpha) and combined using the
47 extended Porter/Duff compositing algebra as found in the X Render
48 Extension.
49
50 Cairo exports a stateful rendering API similar in spirit to the path
51 construction, text, and painting operators of PostScript, (with the
52 significant addition of translucence in the imaging model). When
53 complete, the API is intended to support the complete imaging model of
54 PDF 1.4.
55
56 %description -l pl.UTF-8
57 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
58 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
59 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
60 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
61 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
62 przy użyciu rozszerzonego algorytmu mieszania Portera-Duffa, który
63 można znaleźć w rozszerzeniu X Render.
64
65 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
66 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
67 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
68 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
69
70 %package devel
71 Summary:        Development files for Cairo library
72 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       fontconfig-devel
76 Requires:       freetype-devel >= 1:2.1.10
77 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
78 Requires:       libpng-devel
79 %{?with_xcb:Requires:   libxcb-devel}
80 Requires:       xorg-lib-libXrender-devel >= 0.6
81
82 %description devel
83 Development files for Cairo library.
84
85 %description devel -l pl.UTF-8
86 Pliki programistyczne biblioteki Cairo.
87
88 %package static
89 Summary:        Static Cairo library
90 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Static Cairo library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka Cairo.
99
100 %package apidocs
101 Summary:        Cairo API documentation
102 Summary(pl.UTF-8):      Dokumentacja API Cairo
103 Group:          Documentation
104 Requires:       gtk-doc-common
105
106 %description apidocs
107 Cairo API documentation.
108
109 %description apidocs -l pl.UTF-8
110 Dokumentacja API Cairo. 
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %{?with_lcd:%patch1 -p1}
116
117 %build
118 %{?with_apidocs:%{__gtkdocize}}
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoheader}
122 %{__autoconf}
123 %{__automake}
124 %configure \
125         %{?with_apidocs:--enable-gtk-doc} \
126         %{?with_xcb:--enable-xcb} \
127         %{?with_glitz:--enable-glitz} \
128         --enable-ps \
129         --enable-pdf \
130         --with-html-dir=%{_gtkdocdir}
131 %{__make}
132 %{?with_tests:%{__make} check}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 # COPYING contains only notes, not LGPL/MPL texts
149 %doc AUTHORS COPYING ChangeLog NEWS README TODO
150 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_libdir}/lib*.la
156 %{_includedir}/*
157 %{_pkgconfigdir}/*.pc
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/lib*.a
162
163 %files apidocs
164 %defattr(644,root,root,755)
165 %{_gtkdocdir}/cairo
This page took 0.034825 seconds and 3 git commands to generate.