]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- gcc41 fix, testsuite bconded, TODO added.
[packages/cairo.git] / cairo.spec
1 #
2 # TODO:
3 #               testsuite failures:
4 #               https://bugs.freedesktop.org/show_bug.cgi?id=5076
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # disable gtk-doc
8 %bcond_with     xcb             # enable XCB backend (XCB not released yet)
9 %bcond_with     tests           # perform tests (can fail due to out of memory)
10 #
11 Summary:        Cairo - multi-platform 2D graphics library
12 Summary(pl):    Cairo - wieloplatformowa biblioteka graficzna 2D
13 Name:           cairo
14 Version:        1.0.2
15 Release:        2.1
16 License:        LGPL v2.1 or MPL v1.1
17 Group:          Libraries
18 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
19 # Source0-md5:  d0b7111a14f90ec3afa777ec40c44984
20 Patch0:         %{name}-gcc4.patch
21 URL:            http://cairographics.org/
22 BuildRequires:  autoconf >= 2.54
23 BuildRequires:  automake >= 1.7
24 BuildRequires:  fontconfig-devel
25 BuildRequires:  freetype-devel >= 2.1.10
26 BuildRequires:  glitz-devel >= 0.4.4
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
28 BuildRequires:  libpng-devel
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 %{?with_xcb:BuildRequires:      xcb-devel}
32 BuildRequires:  xrender-devel >= 0.6
33 BuildRequires:  zlib-devel
34 Requires:       freetype >= 2.1.10
35 Requires:       glitz >= 0.4.4
36 Requires:       xrender >= 0.6
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Cairo provides anti-aliased vector-based rendering for X. Paths
41 consist of line segments and cubic splines and can be rendered at any
42 width with various join and cap styles. All colors may be specified
43 with optional translucence (opacity/alpha) and combined using the
44 extended Porter/Duff compositing algebra as found in the X Render
45 Extension.
46
47 Cairo exports a stateful rendering API similar in spirit to the path
48 construction, text, and painting operators of PostScript, (with the
49 significant addition of translucence in the imaging model). When
50 complete, the API is intended to support the complete imaging model of
51 PDF 1.4.
52
53 Cairo relies on the Xc library for backend rendering. Xc provides an
54 abstract interface for rendering to multiple target types. As of this
55 writing, Xc allows Cairo to target X drawables as well as generic
56 image buffers. Future backends such as PostScript, PDF, and perhaps
57 OpenGL are currently being planned.
58
59 %description -l pl
60 Cairo obs³uguje oparty na wektorach rendering z antyaliasingiem dla X.
61 ¦cie¿ki sk³adaj± siê z odcinków i splajnów kubicznych, a renderowane
62 mog± byæ z dowoln± grubo¶ci± i ró¿nymi stylami po³±czeñ i zakoñczeñ.
63 Wszystkie kolory mog± byæ podane z opcjonaln± pó³przezroczysto¶ci±
64 (podan± przez wspó³czynnik nieprzezroczysto¶ci lub alpha) i ³±czone
65 przy u¿yciu rozszerzonego algorytmu mieszania Portera-Duffa, który
66 mo¿na znale¼æ w rozszerzeniu X Render.
67
68 Cairo eksportuje stanowe API renderuj±ce w duchu podobne do operatorów
69 konstruowania ¶cie¿ek, tekstu i rysowania z PostScriptu (ze znacznym
70 dodatkiem pó³przezroczysto¶ci w modelu obrazu). Kiedy API zostanie
71 ukoñczone, ma obs³ugiwaæ pe³ny model obrazu z PDF w wersji 1.4.
72
73 Cairo do backendowego renderowania wykorzystuje bibliotekê Xc. Xc
74 dostarcza abstrakcyjny interfejs do renderowania na wiele rodzajów
75 wyj¶æ. Aktualnie Xc pozwala Cairo tworzyæ obiekty X, a tak¿e ogólne
76 bufory obrazu. W przysz³o¶ci planowane s± takie backendy jak
77 PostScript, PDF i byæ mo¿e OpenGL.
78
79 %package devel
80 Summary:        Development files for Cairo library
81 Summary(pl):    Pliki programistyczne biblioteki Cairo
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       fontconfig-devel
85 Requires:       freetype-devel >= 2.1.10
86 Requires:       glitz-devel >= 0.4.4
87 Requires:       libpng-devel
88 %{?with_xcb:Requires:   xcb-devel}
89 Requires:       xrender-devel >= 0.6
90
91 %description devel
92 Development files for Cairo library.
93
94 %description devel -l pl
95 Pliki programistyczne biblioteki Cairo.
96
97 %package static
98 Summary:        Static Cairo library
99 Summary(pl):    Statyczna biblioteka Cairo
100 Group:          Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102
103 %description static
104 Static Cairo library.
105
106 %description static -l pl
107 Statyczna biblioteka Cairo.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoheader}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         %{?with_apidocs:--enable-gtk-doc} \
121         %{?with_xcb:--enable-xcb} \
122         --enable-glitz \
123         --enable-ps \
124         --enable-pdf \
125         --with-html-dir=%{_gtkdocdir}
126 %{__make}
127 %{?with_tests:%{__make} check}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 # COPYING contains only notes, not LGPL/MPL texts
144 %doc AUTHORS COPYING ChangeLog NEWS README TODO
145 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %{_libdir}/lib*.la
151 %{_includedir}/*
152 %{_pkgconfigdir}/*.pc
153 %{_gtkdocdir}/cairo
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
This page took 0.068244 seconds and 3 git commands to generate.