]> git.pld-linux.org Git - packages/byobu.git/blob - byobu.spec
8bffa4823bd6a2132f355c2023d91e57ad021cf7
[packages/byobu.git] / byobu.spec
1 Summary:        A set of useful profiles and a profile-switcher for GNU screen
2 Summary(hu.UTF-8):      Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
3 Summary(pl.UTF-8):      Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
4 Name:           byobu
5 Version:        5.133
6 Release:        1
7 License:        GPL v3
8 Group:          Applications/System
9 Source0:        https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
10 # Source0-md5:  0ff03f3795cc08aae50c1ab117c03261
11 Patch0:         desktop.patch
12 Patch1:         pld-logo.patch
13 URL:            https://launchpad.net/byobu
14 BuildRequires:  gettext-tools
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.596
17 Requires:       desktop-file-utils
18 Requires:       python >= 1:2.5
19 Requires:       python-snack
20 Suggests:       screen
21 Suggests:       tmux >= 1.5
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _noautocompressdoc '*.txt'
26
27 %define         _libexecdir     %{_prefix}/lib
28
29 %description
30 Byobu is an elegant enhancement of the otherwise functional, plain,
31 practical GNU Screen. Byobu includes an enhanced profile and
32 configuration utilities for the GNU screen window manager, such as
33 toggle-able system status notifications.
34
35 %description -l hu.UTF-8
36 Byobu egy elegáns kiterjesztése az amúgy használható, egyszerű,
37 praktikus GNU screen-nek. A Byobu tartalmaz egy kiterjesztett profilt
38 és konfigurációs eszközöket a GNU screen ablakkezelőhöz, pl. a
39 ki/bekapcsolható rendszer státusz jelentéseket.
40
41 %description -l pl.UTF-8
42 Byobu to eleganckie rozszerzenie dla funkcjonalnego, zwykłego,
43 praktycznego GNU screena. Byobu zawiera rozszerzony profil oraz
44 narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
45 - takie jak przełączane powiadomienia o stanie systemu.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50 %patch1 -p1
51
52 %{__sed} -i -e '
53         s#/share/doc/byobu#/share/doc/%{name}-%{version}#
54 ' usr/share/byobu/keybindings/*
55
56 %{__sed} -i -e '1s,^#!.*python3,#!%{__python3},' usr/lib/byobu/include/*.py{,.in}
57
58 # cleanup backups after patching
59 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
60
61 %build
62 %configure
63 %{__make}
64
65 for po in po/*.po; do
66         lang=${po#po/}
67         lang=${lang%.po}
68         mkdir -p locale/${lang}/LC_MESSAGES/
69         msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
70 done
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install \
75         INSTALL="install -p" \
76         CP="cp -p" \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 # some debian hackery, just use the "current" one for pld
80 install -d $RPM_BUILD_ROOT%{_desktopdir}
81 mv $RPM_BUILD_ROOT{%{_datadir}/%{name}/desktop,%{_desktopdir}}/%{name}.desktop
82
83 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
84
85 install -d $RPM_BUILD_ROOT%{_localedir}
86 cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
87
88 %find_lang %{name}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 %update_desktop_database
95
96 %postun
97 %update_desktop_database
98
99 %files -f %{name}.lang
100 %defattr(644,root,root,755)
101 %doc README.md
102 %doc usr/share/doc/byobu/*.txt
103 %dir %{_sysconfdir}/%{name}
104 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
105 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
106 %attr(755,root,root) %{_bindir}/byobu
107 %attr(755,root,root) %{_bindir}/byobu-config
108 %attr(755,root,root) %{_bindir}/byobu-ctrl-a
109 %attr(755,root,root) %{_bindir}/byobu-disable
110 %attr(755,root,root) %{_bindir}/byobu-disable-prompt
111 %attr(755,root,root) %{_bindir}/byobu-enable
112 %attr(755,root,root) %{_bindir}/byobu-enable-prompt
113 %attr(755,root,root) %{_bindir}/byobu-export
114 %attr(755,root,root) %{_bindir}/byobu-janitor
115 %attr(755,root,root) %{_bindir}/byobu-keybindings
116 %attr(755,root,root) %{_bindir}/byobu-launch
117 %attr(755,root,root) %{_bindir}/byobu-launcher
118 %attr(755,root,root) %{_bindir}/byobu-launcher-install
119 %attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
120 %attr(755,root,root) %{_bindir}/byobu-layout
121 %attr(755,root,root) %{_bindir}/byobu-prompt
122 %attr(755,root,root) %{_bindir}/byobu-quiet
123 %attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
124 %attr(755,root,root) %{_bindir}/byobu-screen
125 %attr(755,root,root) %{_bindir}/byobu-select-backend
126 %attr(755,root,root) %{_bindir}/byobu-select-profile
127 %attr(755,root,root) %{_bindir}/byobu-select-session
128 %attr(755,root,root) %{_bindir}/byobu-shell
129 %attr(755,root,root) %{_bindir}/byobu-silent
130 %attr(755,root,root) %{_bindir}/byobu-status
131 %attr(755,root,root) %{_bindir}/byobu-status-detail
132 %attr(755,root,root) %{_bindir}/byobu-tmux
133 %attr(755,root,root) %{_bindir}/byobu-ugraph
134 %attr(755,root,root) %{_bindir}/byobu-ulevel
135 %attr(755,root,root) %{_bindir}/col1
136 %attr(755,root,root) %{_bindir}/ctail
137 %attr(755,root,root) %{_bindir}/manifest
138 %attr(755,root,root) %{_bindir}/purge-old-kernels
139 %attr(755,root,root) %{_bindir}/vigpg
140 %attr(755,root,root) %{_bindir}/wifi-status
141 %{_mandir}/man1/*.1*
142 /etc/profile.d/Z97-byobu.sh
143 %{_datadir}/dbus-1/services/us.kirkland.terminals.byobu.service
144 %{_desktopdir}/%{name}.desktop
145 # preserve +x bits where needed
146 %defattr(-,root,root,-)
147 %{_libexecdir}/%{name}
148 %{_datadir}/%{name}
This page took 0.0541 seconds and 2 git commands to generate.