]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- rel 2; inetd, tar_z, tr, trylink upstream fixes
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 %bcond_with     dietlibc        # build dietlibc-based initrd version
26 %bcond_with     glibc           # build glibc-based initrd version
27 #
28 %ifnarch %{ix86} %{x8664} ppc sparc64
29 %define with_glibc 1
30 %endif
31 Summary:        Set of common unix utils for embeded systems
32 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
33 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
34 Name:           busybox
35 Version:        1.8.1
36 Release:        2
37 License:        GPL
38 Group:          Applications
39 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
40 # Source0-md5:  c54554851d989328654a3eeab915a04f
41 Source1:        %{name}.config
42 Source2:        %{name}-initrd.config
43 %{?with_altconfig:Source3:      %{cfgfile}}
44 Patch1:         %{name}-logconsole.patch
45 Patch2:         %{name}-printf-gettext.patch
46 Patch3:         %{name}-loadfont.patch
47 Patch4:         %{name}-ash_exec.patch
48 Patch5:         %{name}-kernel_headers.patch
49 Patch6:         %{name}-insmod-morearchs.patch
50 Patch7:         %{name}-dhcp.patch
51 Patch8:         %{name}-fix_64_archs.patch
52 Patch9:         %{name}-1.8.1-inetd.patch
53 Patch10:        %{name}-1.8.1-tar_z.patch
54 Patch11:        %{name}-1.8.1-tr.patch
55 Patch12:        %{name}-1.8.1-trylink.patch
56 URL:            http://www.busybox.net/
57 BuildRequires:  gcc >= 3.2
58 BuildRequires:  perl-tools-pod
59 BuildRequires:  rpmbuild(macros) >= 1.333
60 %{?with_static:BuildRequires:   glibc-static}
61 %if %{with initrd}
62         %if %{with dietlibc}
63 BuildRequires:  dietlibc-static
64         %else
65                 %if %{with glibc}
66 BuildRequires:  glibc-static
67                 %else
68 %if "%{_target_base_arch}" != "%{_arch}"
69 BuildRequires:  cross%{_target_base_arch}-uClibc-static
70 %else
71         %ifarch ppc %{x8664}
72 BuildRequires:  uClibc-static >= 2:0.9.29
73         %else
74 BuildRequires:  uClibc-static >= 2:0.9.21
75         %endif
76 %endif
77                 %endif
78         %endif
79 %endif
80 %{?with_fileutl_prov:Provides:  fileutils}
81 %{?with_grep_prov:Provides:     grep}
82 %{?with_sh_prov:Provides:       /bin/sh}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _bindir         /bin
86 %define         _initrd_bindir  /bin
87
88 %if "%{_target_base_arch}" != "%{_arch}"
89         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
90 %else
91         %define CrossOpts %{nil}
92 %endif
93
94 %description
95 BusyBox combines tiny versions of many common UNIX utilities into a
96 single small executable. It provides minimalist replacements for most
97 of the utilities you usually find in fileutils, shellutils, findutils,
98 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
99 POSIX environment for any small or embedded system. The utilities in
100 BusyBox generally have fewer options than their full-featured GNU
101 cousins; however, the options that are included provide the expected
102 functionality and behave very much like their GNU counterparts.
103
104 BusyBox has been written with size-optimization and limited resources
105 in mind. It is also extremely modular so you can easily include or
106 exclude commands (or features) at compile time. This makes it easy to
107 customize your embedded systems. To create a working system, just add
108 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
109 ae).
110
111 %description -l pl.UTF-8
112 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
113 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
114 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
115 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
116 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
117 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
118 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
119 (np. elvis-tiny albo ae).
120
121 %description -l pt_BR.UTF-8
122 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
123 executável, fornecendo substitutos minimalistas para muitos dos
124 executáveis encontrados em pacotes como fileutils, shellutils,
125 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
126 em geral têm menos opções que os utilitários GNU, mas as opções
127 implementadas comportam-se de maneira similar aos equivalentes GNU.
128
129 %package static
130 Summary:        Static busybox
131 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
132 Group:          Applications
133
134 %description static
135 Static busybox.
136
137 %description static -l pl.UTF-8
138 Statycznie skonsolidowany busybox.
139
140 %package initrd
141 Summary:        Static busybox for initrd
142 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
143 Group:          Applications
144 Conflicts:      geninitrd < 3075
145
146 %description initrd
147 Static busybox for initrd.
148
149 %description initrd -l pl.UTF-8
150 Statycznie skonsolidowany busybox dla initrd.
151
152 %prep
153 %setup -q
154 %patch1 -p1
155 %patch2 -p1
156 %patch3 -p1
157 %patch4 -p1
158 %patch5 -p1
159 %patch6 -p1
160 %patch7 -p1
161 %patch8 -p1
162 %patch9 -p1
163 %patch10 -p1
164 %patch11 -p1
165 %patch12 -p1
166
167 %build
168 install -d built
169 %if %{with initrd}
170 install %{SOURCE2} .config
171 %{__make} oldconfig
172 %{__make} \
173         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
174         LDFLAGS="%{ld_rpmldflags} -static" \
175 %if %{with dietlibc}
176         LIBRARIES="-lrpc" \
177         CC="diet gcc"
178 %else
179 %if %{with glibc}
180         %{CrossOpts} \
181         CC="%{__cc}"
182 %else
183     %if "%{_target_base_arch}" != "%{_arch}"
184         CROSS="%{_target_cpu}-uclibc-" \
185     %endif
186         CC="%{_target_cpu}-uclibc-gcc"
187 %endif
188 %endif
189
190 mv -f busybox built/busybox.initrd
191 %{__make} clean
192 %endif
193
194
195 %if %{with altconfig}
196 install %{SOURCE3} .config
197 %else
198 install %{SOURCE1} .config
199 %endif
200
201 %if %{with static}
202 %{__make} oldconfig
203 %{__make} \
204         %{CrossOpts} \
205         CFLAGS_EXTRA="%{rpmcflags}" \
206         LDFLAGS="%{ld_rpmldflags} -static" \
207         CC="%{__cc}"
208 mv -f busybox built/busybox.static
209 %{__make} clean
210 %endif
211
212 %{__make} oldconfig
213 %{__make} \
214         %{CrossOpts} \
215         CFLAGS_EXTRA="%{rpmcflags}" \
216         LDFLAGS="%{ld_rpmldflags}" \
217         CC="%{__cc}"
218 %{__make} busybox.links docs/BusyBox.1
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
223
224 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
225 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
226
227 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
228 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
229 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
230
231 # install links to busybox binary, when linkfl is defined
232 %if %{with linkfl}
233 %{__make} install \
234         PREFIX=$RPM_BUILD_ROOT
235 %else
236 install busybox $RPM_BUILD_ROOT%{_bindir}
237 %endif
238
239 %clean
240 rm -rf $RPM_BUILD_ROOT
241
242 %files
243 %defattr(644,root,root,755)
244 %doc AUTHORS README .config
245
246 %if %{with linkfl}
247 %attr(755,root,root) /bin/*
248 %attr(755,root,root) /sbin/*
249 %attr(755,root,root) %{_bindir}/*
250 %attr(755,root,root) %{_sbindir}/*
251 %else
252 %attr(755,root,root) %{_bindir}/busybox
253 %endif
254
255 %{_libdir}/busybox
256 %{_mandir}/man1/*
257
258 %if %{with static}
259 %files static
260 %defattr(644,root,root,755)
261 %attr(755,root,root) %{_bindir}/busybox.static
262 %endif
263
264 %if %{with initrd}
265 %files initrd
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
268 %endif
This page took 0.040423 seconds and 3 git commands to generate.