]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
4b611de3b28f58d3a8bb7fc4b304073dbfea0cfd
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 #%%bcond_with   dietlibc        # build dietlibc-based initrd version
26 %bcond_with     glibc           # build glibc-based initrd version
27 #
28 %ifnarch %{ix86} %{x8664} ppc sparc64
29 %define with_glibc 1
30 %endif
31 %ifarch ppc
32 %undefine       with_dietlibc
33 %endif
34 Summary:        Set of common unix utils for embeded systems
35 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 Version:        1.3.1
39 Release:        1
40 License:        GPL
41 Group:          Applications
42 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
43 # Source0-md5:  571531cfa83726947ccb566de017ad4f
44 Source1:        %{name}.config
45 Source2:        %{name}-initrd.config
46 %{?with_altconfig:Source3:      %{cfgfile}}
47 Patch1:         %{name}-logconsole.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-ash_exec.patch
51 Patch5:         %{name}-kernel_headers.patch
52 Patch6:         %{name}-insmod-morearchs.patch
53 Patch7:         %{name}-dhcp.patch
54 Patch8:         %{name}-fix_64_archs.patch
55 Patch9:         %{name}-LFS.patch
56 Patch10:        %{name}-noshadow.patch
57 URL:            http://www.busybox.net/
58 BuildRequires:  gcc >= 3.2
59 BuildRequires:  perl-tools-pod
60 BuildRequires:  rpmbuild(macros) >= 1.333
61 %{?with_static:BuildRequires:   glibc-static}
62 %if %{with initrd}
63         %if %{with dietlibc}
64 BuildRequires:  dietlibc-static
65         %else
66                 %if %{with glibc}
67 BuildRequires:  glibc-static
68                 %else
69 %if "%{_target_base_arch}" != "%{_arch}"
70 BuildRequires:  cross%{_target_base_arch}-uClibc-static
71 %else
72         %ifarch ppc %{x8664}
73 BuildRequires:  uClibc-static >= 2:0.9.29
74         %else
75 BuildRequires:  uClibc-static >= 2:0.9.21
76         %endif
77 %endif
78                 %endif
79         %endif
80 %endif
81 %{?with_fileutl_prov:Provides:  fileutils}
82 %{?with_grep_prov:Provides:     grep}
83 %{?with_sh_prov:Provides:       /bin/sh}
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _bindir         /bin
87 %define         _initrd_bindir  /bin
88
89 %if "%{_target_base_arch}" != "%{_arch}"
90         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
91 %else
92         %define CrossOpts %{nil}
93 %endif
94
95 %description
96 BusyBox combines tiny versions of many common UNIX utilities into a
97 single small executable. It provides minimalist replacements for most
98 of the utilities you usually find in fileutils, shellutils, findutils,
99 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
100 POSIX environment for any small or embedded system. The utilities in
101 BusyBox generally have fewer options than their full-featured GNU
102 cousins; however, the options that are included provide the expected
103 functionality and behave very much like their GNU counterparts.
104
105 BusyBox has been written with size-optimization and limited resources
106 in mind. It is also extremely modular so you can easily include or
107 exclude commands (or features) at compile time. This makes it easy to
108 customize your embedded systems. To create a working system, just add
109 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
110 ae).
111
112 %description -l pl
113 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
114 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
115 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
116 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
117 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
118 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
119 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
120 (np. elvis-tiny albo ae).
121
122 %description -l pt_BR
123 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
124 executável, fornecendo substitutos minimalistas para muitos dos
125 executáveis encontrados em pacotes como fileutils, shellutils,
126 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
127 em geral têm menos opções que os utilitários GNU, mas as opções
128 implementadas comportam-se de maneira similar aos equivalentes GNU.
129
130 %package static
131 Summary:        Static busybox
132 Summary(pl):    Statycznie skonsolidowany busybox
133 Group:          Applications
134
135 %description static
136 Static busybox.
137
138 %description static -l pl
139 Statycznie skonsolidowany busybox.
140
141 %package initrd
142 Summary:        Static busybox for initrd
143 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
144 Group:          Applications
145 Conflicts:      geninitrd < 3075
146
147 %description initrd
148 Static busybox for initrd.
149
150 %description initrd -l pl
151 Statycznie skonsolidowany busybox dla initrd.
152
153 %prep
154 %setup -q
155 %patch1 -p1
156 %patch2 -p1
157 %patch3 -p1
158 %patch4 -p1
159 %patch5 -p1
160 %patch6 -p1
161 %patch7 -p1
162 %patch8 -p1
163 %patch9 -p1
164 %patch10 -p1
165
166 %build
167 install -d built
168 %if %{with initrd}
169 install %{SOURCE2} .config
170 %{__make} oldconfig
171 %{__make} \
172         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
173         LDFLAGS="%{ld_rpmldflags} -static" \
174 %if %{with dietlibc}
175         LIBRARIES="-lrpc" \
176         CC="diet gcc"
177 %else
178 %if %{with glibc}
179         %{CrossOpts} \
180         CC="%{__cc}"
181 %else
182     %if "%{_target_base_arch}" != "%{_arch}"
183         CROSS="%{_target_cpu}-uclibc-" \
184     %endif
185         CC="%{_target_cpu}-uclibc-gcc"
186 %endif
187 %endif
188
189 mv -f busybox built/busybox.initrd
190 %{__make} clean
191 %endif
192
193
194 %if %{with altconfig}
195 install %{SOURCE3} .config
196 %else
197 install %{SOURCE1} .config
198 %endif
199
200 %if %{with static}
201 %{__make} oldconfig
202 %{__make} \
203         %{CrossOpts} \
204         CFLAGS_EXTRA="%{rpmcflags}" \
205         LDFLAGS="%{ld_rpmldflags} -static" \
206         CC="%{__cc}"
207 mv -f busybox built/busybox.static
208 %{__make} clean
209 %endif
210
211 %{__make} oldconfig
212 %{__make} \
213         %{CrossOpts} \
214         CFLAGS_EXTRA="%{rpmcflags}" \
215         LDFLAGS="%{ld_rpmldflags}" \
216         CC="%{__cc}"
217 %{__make} busybox.links docs/BusyBox.1
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
222
223 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
224 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
225
226 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
227 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
228 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
229
230 # install links to busybox binary, when linkfl is defined
231 %if %{with linkfl}
232 %{__make} install \
233         PREFIX=$RPM_BUILD_ROOT
234 %else
235 install busybox $RPM_BUILD_ROOT%{_bindir}
236 %endif
237
238 %clean
239 rm -rf $RPM_BUILD_ROOT
240
241 %files
242 %defattr(644,root,root,755)
243 %doc AUTHORS README .config
244
245 %if %{with linkfl}
246 %attr(755,root,root) /bin/*
247 %attr(755,root,root) /sbin/*
248 %attr(755,root,root) %{_bindir}/*
249 %attr(755,root,root) %{_sbindir}/*
250 %else
251 %attr(755,root,root) %{_bindir}/busybox
252 %endif
253
254 %{_libdir}/busybox
255 %{_mandir}/man1/*
256
257 %if %{with static}
258 %files static
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_bindir}/busybox.static
261 %endif
262
263 %if %{with initrd}
264 %files initrd
265 %defattr(644,root,root,755)
266 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
267 %endif
This page took 0.034395 seconds and 2 git commands to generate.