]> git.pld-linux.org Git - packages/buildbot.git/blob - buildbot.spec
- BR: python-modules, rpm-pythonprov
[packages/buildbot.git] / buildbot.spec
1 Summary:        BuildBot build automation system
2 Name:           buildbot
3 Version:        0.7.12
4 Release:        1
5 License:        GPL v2
6 Group:          Development/Building
7 Source0:        http://dl.sourceforge.net/buildbot/%{name}-%{version}.tar.gz
8 # Source0-md5:  5ba9559e2ef0d4e34a26815d95fc2d68
9 URL:            http://www.buildbot.net/
10 BuildRequires:  python-devel
11 BuildRequires:  python-modules
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  rpmbuild(macros) >= 1.219
14 %pyrequires_eq  python-modules
15 Requires:       python-TwistedConch
16 Requires:       python-TwistedCore
17 Requires:       python-TwistedMail
18 Requires:       python-TwistedWeb
19 Requires:       python-TwistedWords
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The BuildBot is a system to automate the compile/test cycle required
25 by most software projects to validate code changes. By automatically
26 rebuilding and testing the tree each time something has changed, build
27 problems are pinpointed quickly, before other developers are
28 inconvenienced by the failure. The guilty developer can be identified
29 and harassed without human intervention. By running the builds on a
30 variety of platforms, developers who do not have the facilities to
31 test their changes everywhere before checkin will at least know
32 shortly afterwards whether they have broken the build or not. Warning
33 counts, lint checks, image size, compile time, and other build
34 parameters can be tracked over time, are more visible, and are
35 therefore easier to improve.
36
37 %prep
38 %setup -q
39
40 %build
41 %{__python} setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__python} setup.py install \
46         --root=$RPM_BUILD_ROOT \
47         --optimize=2
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc CREDITS NEWS README docs/*.html docs/examples docs/images
56 %doc contrib
57 %attr(755,root,root) %{_bindir}/buildbot
58 %{py_sitescriptdir}/buildbot
59 %{py_sitescriptdir}/buildbot*.egg-info
This page took 0.07077 seconds and 4 git commands to generate.