]> git.pld-linux.org Git - SPECS.git/blob - bugzilla.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / bugzilla.spec
1 # TODO
2 # - Split DB packages for mysql/pgsql
3 # - fill brr and add autodeps bcond
4 Summary:        Bug tracking system
5 Summary(pl.UTF-8):      System śledzenia błędów
6 Name:           bugzilla
7 Version:        3.3.3
8 Release:        0.1
9 License:        GPL
10 Group:          Applications/WWW
11 Source0:        http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
12 # Source0-md5:  893273266255f15e5b253719e8abcb50
13 Source1:        %{name}-skins.tar.bz2
14 # Source1-md5:  4e6e8c2b65cab635975eff5ab318057b
15 Source2:        %{name}.conf
16 Source3:        %{name}-localconfig.pl
17 Source4:        %{name}.cron
18 Patch0:         %{name}-pld.patch
19 URL:            http://www.bugzilla.org/
20 # http://www.bugzilla.org/security/3.2.2/
21 BuildRequires:  security(3.2.2)
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.268
24 BuildRequires:  sed >= 4.0
25 Requires:       perl(Email::MIME::Modifier)
26 Requires:       perl(Email::Send) >= 2.00
27 Requires:       perl-DBD-mysql
28 Requires:       perl-DBI >= 1.41
29 Requires:       perl-MailTools >= 1.67
30 Requires:       smtpdaemon
31 Requires:       webapps
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _webapps        /etc/webapps
36 %define         _webapp         %{name}
37 %define         _sysconfdir     %{_webapps}/%{_webapp}
38 %define         _appdir         %{_datadir}/%{_webapp}
39 # Don't enforce DBD driver and exclude optional packages according to release notes
40 %define         _noautoreq              'perl(DBD::.*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
41
42 #D perl-Apache-DBI-1.01-1, perl-AppConfig-1.56-2, perl-BSD-Resource-1.28-1, perl-Class-Inspector-1.16-1,
43 #D perl-DBD-Pg-1.49-1, perl-Data-Flow-0.09-2, perl-Email-Abstract-2.13-1, perl-Email-Address-1.86-1,
44 #D perl-Email-MIME-1.85-1, perl-Email-MIME-Attachment-Stripper-1.3-1, perl-Email-MIME-ContentType-1.0-1,
45 #D perl-Email-MIME-Creator-1.45-1, perl-Email-MIME-Encodings-1.3-2, perl-Email-MIME-Modifier-1.43-1,
46 #D perl-Email-MessageID-1.35-1, perl-Email-Reply-1.1-1, perl-Email-Send-1.46-1, perl-Email-Simple-1.96-1,
47 #D perl-Email-Simple-Creator-1.41-1, perl-IO-All-0.33-2, perl-IO-String-1.08-1, perl-Module-Pluggable-3.1-4,
48 #D perl-Return-Value-1.28-1, perl-Spiffy-0.30-1, perl-Template-Toolkit-2.15-1, perl-mixin-0.04-1, perl-mod_perl-2.0.3-2
49
50
51 %description
52 Bugzilla is the Bug-Tracking System from the Mozilla project.
53
54 %description -l pl.UTF-8
55 System śledzenia błędów.
56
57 %prep
58 %setup -q %{?_rc:-n %{name}-%{version}%{_rc}} -a1
59 %patch0 -p1
60
61 sed -i -e '
62 s,use lib ".",use lib "%{_appdir}",
63 s,use lib qw(.),use lib "%{_appdir}",
64 ' *.cgi
65
66 find -name CVS -type d | xargs rm -rf
67 find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
68
69 # won't package tests
70 rm -f runtests.pl
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/htdocs,/var/lib/%{name}/{data,graphs}} \
75         $RPM_BUILD_ROOT%{perl_vendorlib}
76
77 install *.pl $RPM_BUILD_ROOT%{_appdir}
78 cp -a template $RPM_BUILD_ROOT%{_appdir}
79 cp -a Bugzilla{,.pm} $RPM_BUILD_ROOT%{perl_vendorlib}
80
81 install *.{cgi,txt,dtd} js/*.js $RPM_BUILD_ROOT%{_appdir}/htdocs
82 cp -a images js skins $RPM_BUILD_ROOT%{_appdir}/htdocs
83
84 ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}/htdocs
85
86 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
87 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
88 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/localconfig.pl
89 install -D %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.daily/bugzilla
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 if [ "$1" = 1 ]; then
96 # shamelessly stolen from gentoo
97 %banner -e %{name} <<'EOF'
98 0. Bugzilla has been installed into %{_appdir}
99
100 1. To finish the installation, please read
101    http://www.bugzilla.org/docs/%{version}/html/installation.html
102    You will need to run %{_appdir}/checksetup.pl
103
104    IMPORTANT: If you have customized the values in your
105    Status/Resolution field, you must edit checksetup.pl BEFORE YOU RUN
106    IT. Please see the Release Notes for more details.
107
108 2. Please read the Release Notes, especially if you are upgrading:
109    http://www.bugzilla.org/releases/%{version}/release-notes.html
110 EOF
111 fi
112
113 %triggerin -- apache1 < 1.3.37-3, apache1-base
114 %webapp_register apache %{_webapp}
115
116 %triggerun -- apache1 < 1.3.37-3, apache1-base
117 %webapp_unregister apache %{_webapp}
118
119 %triggerin -- apache < 2.2.0, apache-base
120 %webapp_register httpd %{_webapp}
121
122 %triggerun -- apache < 2.2.0, apache-base
123 %webapp_unregister httpd %{_webapp}
124
125 %files
126 %defattr(644,root,root,755)
127 %doc QUICKSTART README UPGRADING* docs/en/rel_notes.txt docs/en/txt/Bugzilla-Guide.txt
128 %doc contrib docs/en/html
129 %dir %attr(750,root,http) %{_sysconfdir}
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
132 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
133
134 %attr(755,root,root) /etc/cron.daily/bugzilla
135
136 %{perl_vendorlib}/Bugzilla
137 %{perl_vendorlib}/Bugzilla.pm
138
139 %dir %{_appdir}
140 %{_appdir}/template
141 %attr(700,root,root) %{_appdir}/checksetup.pl
142 %attr(755,root,root) %{_appdir}/collectstats.pl
143 %attr(755,root,root) %{_appdir}/email_in.pl
144 %attr(755,root,root) %{_appdir}/importxml.pl
145 %attr(755,root,root) %{_appdir}/install-module.pl
146 %attr(755,root,root) %{_appdir}/jobqueue.pl
147 %attr(755,root,root) %{_appdir}/mod_perl.pl
148 %attr(755,root,root) %{_appdir}/sanitycheck.pl
149 %attr(755,root,root) %{_appdir}/testserver.pl
150 %attr(755,root,root) %{_appdir}/whine.pl
151 %attr(755,root,root) %{_appdir}/whineatnews.pl
152
153 %dir %{_appdir}/htdocs
154 %attr(755,root,root) %{_appdir}/htdocs/*.cgi
155 %{_appdir}/htdocs/*.dtd
156 %{_appdir}/htdocs/*.js
157 %{_appdir}/htdocs/*.txt
158 %{_appdir}/htdocs/graphs
159 %{_appdir}/htdocs/images
160 %{_appdir}/htdocs/js
161 %dir %{_appdir}/htdocs/skins
162 %dir %{_appdir}/htdocs/skins/contrib
163 %dir %{_appdir}/htdocs/skins/contrib/Dusk
164 %dir %{_appdir}/htdocs/skins/custom
165 %{_appdir}/htdocs/skins/standard
166 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/custom/*.css
167 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/contrib/Dusk/*.css
168
169 %dir /var/lib/%{name}
170 %attr(770,root,http) /var/lib/%{name}/data
171 %attr(770,root,http) /var/lib/%{name}/graphs
This page took 0.350592 seconds and 3 git commands to generate.