]> git.pld-linux.org Git - packages/bootsplash.git/blob - bootsplash.spec
- rel 2
[packages/bootsplash.git] / bootsplash.spec
1 # TODO:
2 # - place somewhere info that distkernel support only 16bit splashes (thnx Tomasz Grobelny)
3 #
4 Summary:        Bootsplash - graphical boot process for Linux
5 Summary(de):    Bootsplash - graphischer System Start
6 Summary(pl):    Bootsplash - graficzny proces startu systemu dla Linuksa
7 Name:           bootsplash
8 Version:        3.2
9 Release:        2
10 License:        GPL v2
11 Group:          Applications/System
12 Source0:        http://www.bootsplash.de/files/splashutils/%{name}-%{version}.tar.bz2
13 # Source0-md5:  b74c104372fd182d0442b3ed63210e29
14 Source1:        %{name}.script
15 Source2:        %{name}-bootanim.script
16 Source3:        %{name}.sysconfig
17 Source4:        %{name}.init
18 Patch0:         %{name}-3.2_makefile_libmng.patch
19 URL:            http://www.bootsplash.org/
20 BuildRequires:  freetype-devel >= 2.1
21 BuildRequires:  libmng-devel
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 Requires(post,preun):   /sbin/chkconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _bindir /bin
27
28 %description
29 When you have a kernel with bootsplash capability you can use the
30 bootsplash and control its behaviour with this set of userspace
31 utilities.
32
33 %description -l de
34 Wenn du einen Kernel mit der bootsplash Option hast, kannst du diese
35 mit diesen Programmen steuern.
36
37 %description -l pl
38 Maj±c j±dro z opcj± bootsplash mo¿na uzyskaæ graficzny ekran podczas
39 startu systemu i sterowaæ jego zachowaniem przy u¿yciu tego zbioru
40 narzêdzi przestrzeni u¿ytkownika.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45 rm -f Utilities/splash.o
46
47 %build
48 %{__make} -C Utilities \
49         CC="%{__cc}" \
50         CFLAGS="%{rpmcflags} -Wall -I/usr/include/freetype2 -DDEFAULT_FONTNAME=\\\"%{_datadir}/%{name}/luxisri.ttf\\\"" \
51         STRIP=true
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_sysconfdir}/bootsplash/themes} \
56          $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
57
58 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/splash
59 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/bootanim
60 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/bootsplash
61 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootsplash
62 install Scripts/* $RPM_BUILD_ROOT%{_datadir}/%{name}
63 install Utilities/splash $RPM_BUILD_ROOT%{_bindir}/splash.bin
64 install Utilities/{fbmngplay,fbresolution,fbtruetype} $RPM_BUILD_ROOT%{_bindir}
65 install Utilities/*.ttf $RPM_BUILD_ROOT%{_datadir}/%{name}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 /sbin/chkconfig --add bootsplash
72
73 %preun
74 if [ "$1" = "0" ]; then
75         %service bootsplash stop
76         /sbin/chkconfig --del bootsplash
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc {Documentation,Utilities}/README.*
82 %attr(755,root,root) %{_bindir}/*
83 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bootsplash
84 %attr(754,root,root) /etc/rc.d/init.d/bootsplash
85 %{_datadir}/%{name}
86 %dir %{_sysconfdir}/bootsplash
87 %dir %{_sysconfdir}/bootsplash/themes
This page took 0.030959 seconds and 4 git commands to generate.