]> git.pld-linux.org Git - packages/bootsplash.git/blob - bootsplash.spec
17e9be3cf197a4a93e4d5af22305fd20426a2300
[packages/bootsplash.git] / bootsplash.spec
1 #
2 # TODO:
3 # - place somewhere info that distkernel support only 16bit splashes (thnx Tomasz Grobelny)
4 #
5 Summary:        Bootsplash - graphical boot process for Linux
6 Summary(de):    Bootsplash - graphischer System Start
7 Summary(pl):    Bootsplash - graficzny proces startu systemu dla Linuksa
8 Name:           bootsplash
9 Version:        3.2
10 Release:        1
11 License:        GPL v2
12 Group:          Applications/System
13 Source0:        http://www.bootsplash.de/files/splashutils/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b74c104372fd182d0442b3ed63210e29
15 Source1:        %{name}.script
16 Source2:        %{name}-bootanim.script
17 Source3:        %{name}.sysconfig
18 Source4:        %{name}.init
19 Patch0:         %{name}-3.2_makefile_libmng.patch
20 URL:            http://www.bootsplash.org/
21 BuildRequires:  freetype-devel >= 2.1
22 BuildRequires:  libmng-devel
23 Requires(post,preun):   /sbin/chkconfig
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _bindir /bin
27
28 %description
29 When you have a kernel with bootsplash capability you can use the
30 bootsplash and control its behaviour with this set of userspace
31 utilities.
32
33 %description -l de
34 Wenn du einen Kernel mit der bootsplash Option hast, kannst du diese
35 mit diesen Programmen steuern.
36
37 %description -l pl
38 Maj±c j±dro z opcj± bootsplash mo¿na uzyskaæ graficzny ekran podczas
39 startu systemu i sterowaæ jego zachowaniem przy u¿yciu tego zbioru
40 narzêdzi przestrzeni u¿ytkownika.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 %build
47 %{__make} -C Utilities \
48         CC="%{__cc}" \
49         CFLAGS="%{rpmcflags} -Wall -I/usr/include/freetype2 -DDEFAULT_FONTNAME=\\\"%{_datadir}/%{name}/luxisri.ttf\\\"" \
50         STRIP=true
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_sysconfdir}/bootsplash/themes} \
55          $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
56
57 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/splash
58 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/bootanim
59 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/bootsplash
60 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootsplash
61 install Scripts/* $RPM_BUILD_ROOT%{_datadir}/%{name}
62 install Utilities/splash $RPM_BUILD_ROOT%{_bindir}/splash.bin
63 install Utilities/{fbmngplay,fbresolution,fbtruetype} $RPM_BUILD_ROOT%{_bindir}
64 install Utilities/*.ttf $RPM_BUILD_ROOT%{_datadir}/%{name}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 /sbin/chkconfig --add bootsplash
71
72 %preun
73 if [ "$1" = "0" ]; then
74         %service bootsplash stop
75         /sbin/chkconfig --del bootsplash
76 fi
77
78 %files
79 %defattr(644,root,root,755)
80 %doc {Documentation,Utilities}/README.*
81 %attr(755,root,root) %{_bindir}/*
82 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bootsplash
83 %attr(754,root,root) /etc/rc.d/init.d/bootsplash
84 %{_datadir}/%{name}
85 %dir %{_sysconfdir}/bootsplash
86 %dir %{_sysconfdir}/bootsplash/themes
This page took 0.079262 seconds and 3 git commands to generate.