]> git.pld-linux.org Git - packages/boomerang.git/blob - boomerang.spec
- looks like they are not using classic flex++
[packages/boomerang.git] / boomerang.spec
1 Summary:        An attempt at a general, open source, retargetable decompiler of native executable files
2 Name:           boomerang
3 Version:        0.0.0.20040707
4 Release:        0.1
5 License:        GPL
6 Group:          Development/Languages
7 Source0:        %{name}.tar.gz
8 # Source0-md5:  97d2b1825b3e2d5bcd85df48eb15a45e
9 URL:            http://boomerang.sourceforge.net/
10 BuildRequires:  bison++
11 BuildRequires:  flex
12 BuildRequires:  gc-devel
13 BuildRequires:  cppunit-devel
14 BuildRequires:  expat-devel
15 BuildRequires:  libstdc++-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 An attempt to develop a real decompiler through the open source
20 community. A decompiler takes as input an executable file, and
21 attempts to create a high level, compilable, even maintainable source
22 file that does the same thing. It is therefore the opposite of a
23 compiler, which of course takes a source file and makes an executable.
24 It won't of course recreate the original source file; probably nothing
25 like it. It does not matter if the executable file has symbols or not,
26 or was compiled from any particular language. (However, languages like
27 ML that are usually interpreted are not considered.)
28
29 The intent is to create a retargetable decompiler (i.e. one that can
30 work with different types of input executable files with modest
31 effort, e.g. X86-windows, sparc-solaris, etc). It will be highly
32 modular, so that different parts of the decompiler can be replaced
33 with experimental modules. It is intended to eventually become
34 interactive, a la IDA Pro, because some things (not just variable
35 names and comments, though these are obviously very important) require
36 expert intervention.
37
38 %prep
39 %setup -q -n %{name}
40
41 %build
42 ln -s %{_includedir}/cppunit include/cppunit
43 %configure
44
45 %{__make} \
46         C="%{__cc} %{rpmcflags} -I%{_includedir}/gc" \
47         CC="%{__cxx} %{rpmcflags} -I%{_includedir}/gc"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_libdir}/emacs/site-lisp
52
53 %{__make} install \
54         DESTDIR="$RPM_BUILD_ROOT"
55
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
This page took 0.079232 seconds and 4 git commands to generate.