]> git.pld-linux.org Git - packages/bogl.git/blob - bogl.spec
- pl, partial cleanup, updated URL
[packages/bogl.git] / bogl.spec
1 Summary:        A terminal program for displaying Unicode on the console
2 Summary(pl):    Program terminalowy do wy¶wietlania Unikodu na konsoli
3 Name:           bogl
4 Version:        0.1.18
5 Release:        1
6 Epoch:          0
7 License:        GPL
8 Group:          Libraries
9 Source0:        %{name}_%{version}-1.tar.gz
10 # Source0-md5:  9658700ed196eb1789c12aca0a095cb5
11 Source1:        wlite-0.8.1.tar.gz
12 # Source1-md5:  03a2faa33978e88ea2b9ff4679b8f2df
13 Source2:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts.tar.gz
14 # Source2-md5:  cca6a3cb6cfbde5f3ebb24278a9022a4
15 Source3:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts-asian.tar.gz
16 # Source3-md5:  d3184f182c6eebfcf156d08a65696496
17 Source4:        14x14cjk.bdf.gz
18 # Source4-md5:  c08ab351a43a91632127f509aadc6797
19 Patch0:         bogl-0.1.18-rh.patch
20 Patch1:         bogl-0.1.9-fpic.patch
21 Patch3:         bogl-0.1.9-2.6fbdev.patch
22 Patch4:         bogl-0.1.18-gcc.patch
23 Patch5:         bogl-0.1.18-noexecstack.patch
24 URL:            http://www.stanford.edu/~blp/projects.html
25 BuildRequires:  gd-devel
26 BuildRequires:  libpng-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 BOGL stands for Ben's Own Graphics Library. It is a small graphics
31 library for Linux kernel framebuffers. It supports only very simple
32 graphics.
33
34 %description -l pl
35 BOGL oznacza Ben's Own Graphics Library (bibliotekê graficzn± Bena).
36 Jest to ma³a biblioteka dla framebufferów j±dra Linuksa. Obs³uguje
37 tylko bardzo prost± grafikê.
38
39 %package devel
40 Summary:        Development files required to build BOGL applications
41 Summary(pl):    Pliki programistyczne potrzebne do budowania aplikacji BOGL
42 Group:          Development/Libraries
43 Requires:       %{name} = %{epoch}:%{version}-%{release}
44
45 %description devel
46 The bogl-devel package contains the header files for writing BOGL
47 applications.
48
49 %description devel -l pl
50 Ten pakiet zawiera pliki nag³ówkowe do pisania aplikacji BOGL.
51
52 %package static
53 Summary:        Static BOGL libraries
54 Summary(pl):    Statyczne biblioteki BOGL
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
57
58 %description static
59 Static BOGL libraries.
60
61 %description static -l pl
62 Statyczne biblioteki BOGL.
63
64 %package bterm
65 Summary:        A Unicode capable terminal program for the Linux framebuffer
66 Summary(pl):    Obs³uguj±cy Unikod program terminalowy dla linuksowego framebuffera
67 Group:          Applications/System
68 Requires:       %{name} = %{epoch}:%{version}-%{release}
69
70 %description bterm
71 The bterm application is a terminal emulator that displays to a Linux
72 framebuffer. It is able to display Unicode text on the console.
73
74 %description bterm -l pl
75 Aplikacja bterm to emulator terminala wy¶wietlaj±cy obraz na
76 linuksowym framebufferze. Potrafi wy¶wietlaæ tekst unikodowy na
77 konsoli.
78
79 %prep
80 %setup -q -n %{name} -a 1
81 %patch0 -p1
82 %patch1 -p1
83 %patch3 -p1
84 %patch4 -p1
85 %patch5 -p1
86
87 mkdir -p fonts
88 cd fonts
89 tar zxf %{SOURCE2}
90 tar zxf %{SOURCE3}
91
92 %build
93 %{__make} \
94         CFLAGS="%{rpmcflags}"
95 #./mergebdf fonts/9x18.bdf fonts/18x18ja.bdf > font.bdf
96 gunzip -c %{SOURCE4} > font.bdf
97 ./bdftobogl -b font.bdf > font.bgf
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT \
104         libdir=%{_libdir}
105
106 %{__make} -C wlite install \
107         prefix=$RPM_BUILD_ROOT%{_prefix} \
108         libdir=$RPM_BUILD_ROOT%{_libdir}
109
110 if [ -f wlite/libwlitediet.a ]; then
111         install -m 644 wlite/libwlitediet.a $RPM_BUILD_ROOT%{_libdir}
112 fi
113 install -d $RPM_BUILD_ROOT%{_libdir}/bogl
114 install font.bgf $RPM_BUILD_ROOT%{_libdir}/bogl
115 install font.bdf $RPM_BUILD_ROOT%{_libdir}/bogl
116 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bdf
117 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bgf
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc README
128 %attr(755,root,root) %{_libdir}/*.so.*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/bdftobogl
133 %attr(755,root,root) %{_bindir}/mergebdf
134 %attr(755,root,root) %{_bindir}/pngtobogl
135 %attr(755,root,root) %{_bindir}/reduce-font
136 %attr(755,root,root) %{_libdir}/*.so
137 %{_libdir}/*.a
138 %{_includedir}/bogl
139 %{_includedir}/wlite*
140
141 # static ??? or just static-only libwlitediet.a ?
142
143 %files bterm
144 %defattr(644,root,root,755)
145 %doc README.BOGL-bterm
146 %attr(755,root,root) %{_bindir}/bterm
147 # XXX: dup dir
148 %dir %{_datadir}/terminfo/b
149 %{_datadir}/terminfo/b/bterm
150 %{_libdir}/bogl
This page took 0.065094 seconds and 3 git commands to generate.