]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- added BR: OpenEXR-devel
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - enable OpenAL support
4 # - libsolid/libqhull/libode BR ?
5 # - package python scripts
6 Summary:        3D modeling, rendering, animation and game creation package
7 Summary(pl):    Pakiet do tworzenia animacji 3D oraz gier
8 Name:           blender
9 Version:        2.42
10 Release:        0.2
11 License:        GPL
12 Group:          X11/Applications/Graphics
13 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
14 # Source0-md5:  232d714a64c3a2208f0ea999fe4a2440
15 Source1:        %{name}.desktop
16 Source2:        %{name}.png
17 Source3:        %{name}-config.opts
18 Source4:        %{name}-wrapper
19 Source5:        %{name}.manpage
20 Patch0:         %{name}-po_and_locale_names.patch
21 Patch1:         %{name}-noxml-yafray.patch
22 Patch2:         %{name}-python-fix.patch
23 URL:            http://www.blender.org/
24 BuildRequires:  OpenEXR-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL-devel
27 BuildRequires:  freealut-devel
28 BuildRequires:  freetype-devel
29 BuildRequires:  ftgl-devel
30 BuildRequires:  gettext-devel
31 #BuildRequires: esound-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtiff-devel
36 BuildRequires:  libtool
37 BuildRequires:  libvorbis-devel
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  python-devel >= 1:2.3
40 BuildRequires:  scons
41 BuildRequires:  sed >= 4.0
42 #BuildRequires: smpeg-devel
43 BuildRequires:  zlib-devel
44 Requires:       OpenGL
45 Requires:       freetype
46 Requires:       python-modules
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
50
51 %description
52 Blender is a free and fully functional 3D modeling, rendering,
53 animation and game creation package for Unix, Windows and BeOS
54 systems.
55
56 %description -l pl
57 Blender to darmowy i w pe³ni funkcjonalny pakiet do tworzenia animacji
58 3D oraz gier, dostêpny dla systemów Unix, Windows i BeOS.
59
60 %prep
61 %setup -q -n %{name}%{version}
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65 mv -f po/pt_{br,BR}.po
66 install %{SOURCE3} config.opts
67
68 %build
69 rm -f missing
70
71 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
72 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
73
74 sed -i -e "s|^CCFLAGS =.*|CCFLAGS = [$RPMCFLAGS]|" \
75         -e "s|^CXXFLAGS =.*|CXXFLAGS = [$RPMCFLAGS]|" \
76         -e "s|^LDFLAGS =.*|LDFLAGS = [$RPMLDFLAGS]|" \
77         config.opts
78 sed -i -e "s|TARGET_CC =.*|TARGET_CC = '%{__cc}'|" \
79         -e "s|TARGET_CXX =.*|TARGET_CXX = '%{__cxx}'|" \
80         config.opts
81 sed -i 's/python2\.3/python%{py_ver}/' config.opts
82
83 cp config.opts user-config.py
84
85 scons
86 %{__make} -C po OCGDIR=..
87
88 install -d release/plugins/include
89 install source/blender/blenpluginapi/*.h release/plugins/include
90 chmod +x release/plugins/bmake
91 %{__make} -C release/plugins/
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}}
96
97 install blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
98 install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
99 install blenderplayer $RPM_BUILD_ROOT%{_bindir}
100 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
101 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
102 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
103 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
104 install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
105 install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
106 install -d $RPM_BUILD_ROOT%{_datadir}/blender
107 cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
108 install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
109 install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
110 install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
111 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}/blender
112 install -d $RPM_BUILD_ROOT%{_mandir}/man1
113 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
121 %doc release/text/{blender.html,release*.txt}
122 %attr(755,root,root) %{_bindir}/*
123 %attr(755,root,root) %{_datadir}/%{name}
124 %attr(755,root,root) %{_libdir}/%{name}
125 %{_desktopdir}/*.desktop
126 %{_pixmapsdir}/*.png
127 %{_mandir}/man1/*
This page took 0.073548 seconds and 4 git commands to generate.