]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- drop python23 bcond, autodetect python version
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - enable OpenAL support
4 # - libsolid/libqhull/libode BR ?
5 # - package python scripts
6
7 Summary:        3D modeling, rendering, animation and game creation package
8 Summary(pl):    Pakiet do tworzenia animacji 3D oraz gier
9 Name:           blender
10 Version:        2.36
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Graphics
14 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
15 # Source0-md5:  8e2237c86b12e6061935632495aec875
16 Source1:        %{name}.desktop
17 Source2:        %{name}.png
18 Source3:        %{name}-config.opts
19 Patch0:         %{name}-po_and_locale_names.patch
20 URL:            http://www.blender.org/
21 #BuildRequires: OpenAL-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel
24 #BuildRequires: autoconf
25 #BuildRequires: automake
26 #BuildRequires: esound-devel
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool
31 BuildRequires:  libvorbis-devel
32 BuildRequires:  openssl-devel >= 0.9.7d
33 BuildRequires:  python-devel >= 1:2.3
34 BuildRequires:  scons
35 #BuildRequires: smpeg-devel
36 BuildRequires:  zlib-devel
37 Requires:       OpenGL
38 Requires:       python-modules
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
42
43 %description
44 Blender is a free and fully functional 3D modeling, rendering,
45 animation and game creation package for Unix, Windows and BeOS
46 systems.
47
48 %description -l pl
49 Blender to darmowy i w pe³ni funkcjonalny pakiet do tworzenia animacji
50 3D oraz gier, dostêpny dla systemów Unix, Windows i BeOS.
51
52 %prep
53 %setup -q -n %{name}
54 %patch0 -p1
55
56 mv -f po/pt_{br,BR}.po
57 rm -rf bin/.blender/locale
58 install %{SOURCE3} config.opts
59
60 %build
61 rm -f missing
62
63 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
64 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
65
66 sed -i -e "s|^CCFLAGS =.*|CCFLAGS = [$RPMCFLAGS]|" \
67         -e "s|^CXXFLAGS =.*|CXXFLAGS = [$RPMCFLAGS]|" \
68         -e "s|^LDFLAGS =.*|LDFLAGS = [$RPMLDFLAGS]|" \
69         config.opts
70 sed -i -e "s|TARGET_CC =.*|TARGET_CC = '%{__cc}'|" \
71         -e "s|TARGET_CXX =.*|TARGET_CXX = '%{__cxx}'|" \
72         config.opts
73 sed -i 's/python2\.3/python%{py_ver}/' config.opts
74
75 scons
76 %{__make} -C po OCGDIR=..
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}}
81
82 install -m755 blender $RPM_BUILD_ROOT%{_bindir}
83 install -m755 blenderplayer $RPM_BUILD_ROOT%{_bindir}
84 install -c %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
85 install -c %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
86 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
87
88 %find_lang %{name} --all-name
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files -f %{name}.lang
94 %defattr(644,root,root,755)
95 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt 
96 %doc release/text/{blender.html,release*.txt}
97 %attr(755,root,root) %{_bindir}/*
98 %{_desktopdir}/*.desktop
99 %{_pixmapsdir}/*.png
This page took 0.030094 seconds and 4 git commands to generate.