]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- up to 2.49b
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        2.49b
8 Release:        1
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  718eef6a4ff377989e829b92a886cc5b
13 Source1:        %{name}.desktop
14 Source2:        %{name}.png
15 Source4:        %{name}-wrapper
16 Source5:        %{name}.manpage
17 Patch0:         %{name}-po_and_locale_names.patch
18 Patch1:         %{name}-noxml-yafray.patch
19 URL:            http://www.blender.org/
20 BuildRequires:  OpenAL-devel
21 BuildRequires:  OpenEXR-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel
24 #BuildRequires: esound-devel
25 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
26 BuildRequires:  freealut-devel
27 BuildRequires:  freetype-devel
28 BuildRequires:  ftgl-devel
29 BuildRequires:  gcc >= 5:3.4.0
30 BuildRequires:  gettext-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  libtool
36 BuildRequires:  libvorbis-devel
37 BuildRequires:  openssl-devel >= 0.9.7d
38 BuildRequires:  python-devel >= 1:2.3
39 BuildRequires:  rpmbuild(macros) >= 1.385
40 BuildRequires:  scons
41 BuildRequires:  sed >= 4.0
42 #BuildRequires: smpeg-devel
43 BuildRequires:  zlib-devel
44 Requires(post,postun):  desktop-file-utils
45 Requires:       OpenGL
46 Requires:       freetype
47 Requires:       python-modules
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
51
52 %description
53 Blender is a free and fully functional 3D modeling, rendering,
54 animation and game creation package for Unix, Windows and BeOS
55 systems.
56
57 %description -l pl.UTF-8
58 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
59 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65
66 rm -f missing
67 rm -f user-config.py
68 rm -rf bin/.blender/locale
69
70 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
71 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
72
73 cat > user-config.py <<END
74 CCFLAGS           = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
75 CXXFLAGS          = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
76 LDFLAGS           = [$RPMLDFLAGS]
77 TARGET_CC         = '%{__cc}'
78 TARGET_CXX        = '%{__cxx}'
79
80 BF_PYTHON_VERSION = '%{py_ver}'
81
82 BF_FFMPEG         = '%{_prefix}'
83 BF_FFMPEG_INC     = '%{_includedir}/ffmpeg'
84 BF_FFMPEG_LIBPATH = '%{_libdir}'
85 BF_FFMPEG_LIB     = 'avformat avcodec avdevice swscale avutil'
86
87 LCGDIR            = 'lib/linux2'
88 BF_BUILDDIR       = 'build/linux2'
89 BF_INSTALLDIR     = 'install/linux2'
90 END
91
92 %build
93 %scons BF_OPENGL_LIBPATH=%{_x_libraries}
94 %{__make} -C po \
95         OCGDIR=.. \
96         SRCHOME=$(pwd)/source \
97         NANBLENDERHOME=$(pwd)
98
99 install -d release/plugins/include
100 install source/blender/blenpluginapi/*.h release/plugins/include
101 chmod +x release/plugins/bmake
102 %{__make} -C release/plugins/
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
107         $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
108
109 install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
110 install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
111 #install blenderplayer $RPM_BUILD_ROOT%{_bindir}
112 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
114 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
115 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
116 install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
117 install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
118 install -d $RPM_BUILD_ROOT%{_datadir}/blender
119 cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
120 install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
121 install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
122 install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
123 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
124 install -d $RPM_BUILD_ROOT%{_mandir}/man1
125 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
126
127 %find_lang %{name}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 %update_desktop_database_post
134
135 %postun
136 %update_desktop_database_postun
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
141 %doc release/text/{blender.html,release*.txt}
142 %attr(755,root,root) %{_bindir}/*
143 %attr(755,root,root) %{_datadir}/%{name}
144 %attr(755,root,root) %{_libdir}/%{name}
145 %{_desktopdir}/*.desktop
146 %{_pixmapsdir}/*.png
147 %{_mandir}/man1/*
This page took 0.066117 seconds and 4 git commands to generate.