]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- release 3
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        2.46
8 Release:        3
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  e90543a5ca5db8b04498ab0abe7bbd2c
13 Source1:        %{name}.desktop
14 Source2:        %{name}.png
15 Source4:        %{name}-wrapper
16 Source5:        %{name}.manpage
17 Patch0:         %{name}-po_and_locale_names.patch
18 Patch1:         %{name}-noxml-yafray.patch
19 URL:            http://www.blender.org/
20 BuildRequires:  OpenEXR-devel
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  SDL-devel
23 BuildRequires:  gcc >= 5:3.4.0
24 BuildRequires:  ffmpeg-devel
25 BuildRequires:  freealut-devel
26 BuildRequires:  freetype-devel
27 BuildRequires:  ftgl-devel
28 BuildRequires:  gettext-devel
29 #BuildRequires: esound-devel
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtiff-devel
34 BuildRequires:  libtool
35 BuildRequires:  libvorbis-devel
36 BuildRequires:  openssl-devel >= 0.9.7d
37 BuildRequires:  python-devel >= 1:2.3
38 BuildRequires:  rpmbuild(macros) >= 1.385
39 BuildRequires:  scons
40 BuildRequires:  sed >= 4.0
41 #BuildRequires: smpeg-devel
42 BuildRequires:  zlib-devel
43 Requires(post,postun):  desktop-file-utils
44 Requires:       OpenGL
45 Requires:       freetype
46 Requires:       python-modules
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
50
51 %description
52 Blender is a free and fully functional 3D modeling, rendering,
53 animation and game creation package for Unix, Windows and BeOS
54 systems.
55
56 %description -l pl.UTF-8
57 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
58 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64
65 rm -f missing
66 rm -f user-config.py
67 rm -rf bin/.blender/locale
68
69 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
70 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
71
72 cat > user-config.py <<END
73 CCFLAGS           = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
74 CXXFLAGS          = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
75 LDFLAGS           = [$RPMLDFLAGS]
76 TARGET_CC         = '%{__cc}'
77 TARGET_CXX        = '%{__cxx}'
78
79 BF_PYTHON_VERSION = '%{py_ver}'
80
81 BF_FFMPEG         = '/usr'
82 BF_FFMPEG_INC     = '%{_includedir}/ffmpeg'
83 BF_FFMPEG_LIBPATH = '%{_libdir}'
84 BF_FFMPEG_LIB     = 'avformat avcodec swscale avutil'
85
86 LCGDIR            = 'lib/linux2'
87 BF_BUILDDIR       = 'build/linux2'
88 BF_INSTALLDIR     = 'install/linux2'
89 END
90
91 %build
92 %scons BF_OPENGL_LIBPATH=%{_x_libraries}
93 %{__make} -C po OCGDIR=..
94
95 install -d release/plugins/include
96 install source/blender/blenpluginapi/*.h release/plugins/include
97 chmod +x release/plugins/bmake
98 %{__make} -C release/plugins/
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
103         $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
104
105 install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
106 install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
107 #install blenderplayer $RPM_BUILD_ROOT%{_bindir}
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
109 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
110 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
111 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
112 install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
113 install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
114 install -d $RPM_BUILD_ROOT%{_datadir}/blender
115 cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
116 install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
117 install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
118 install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
119 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
120 install -d $RPM_BUILD_ROOT%{_mandir}/man1
121 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
122
123 %find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 %update_desktop_database_post
130
131 %postun
132 %update_desktop_database_postun
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
137 %doc release/text/{blender.html,release*.txt}
138 %attr(755,root,root) %{_bindir}/*
139 %attr(755,root,root) %{_datadir}/%{name}
140 %attr(755,root,root) %{_libdir}/%{name}
141 %{_desktopdir}/*.desktop
142 %{_pixmapsdir}/*.png
143 %{_mandir}/man1/*
This page took 0.098124 seconds and 4 git commands to generate.