]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- BR: rpm-pythonprov, xorg-lib-libXi-devel
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        2.49b
8 Release:        1
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  718eef6a4ff377989e829b92a886cc5b
13 Source1:        %{name}.desktop
14 Source2:        %{name}.png
15 Source4:        %{name}-wrapper
16 Source5:        %{name}.manpage
17 Patch0:         %{name}-po_and_locale_names.patch
18 Patch1:         %{name}-noxml-yafray.patch
19 URL:            http://www.blender.org/
20 BuildRequires:  OpenAL-devel
21 BuildRequires:  OpenEXR-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel
24 #BuildRequires: esound-devel
25 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
26 BuildRequires:  freealut-devel
27 BuildRequires:  freetype-devel
28 BuildRequires:  ftgl-devel
29 BuildRequires:  gcc >= 5:3.4.0
30 BuildRequires:  gettext-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  libtool
36 BuildRequires:  libvorbis-devel
37 BuildRequires:  openssl-devel >= 0.9.7d
38 BuildRequires:  python-devel >= 1:2.3
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.385
41 BuildRequires:  scons
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  xorg-lib-libXi-devel
44 #BuildRequires: smpeg-devel
45 BuildRequires:  zlib-devel
46 Requires(post,postun):  desktop-file-utils
47 Requires:       OpenGL
48 Requires:       freetype
49 Requires:       python-modules
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
53
54 %description
55 Blender is a free and fully functional 3D modeling, rendering,
56 animation and game creation package for Unix, Windows and BeOS
57 systems.
58
59 %description -l pl.UTF-8
60 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
61 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67
68 rm -f missing
69 rm -f user-config.py
70 rm -rf bin/.blender/locale
71
72 sed 's/\(BUILD_REV :=\).*/\1 unknown/' -i source/Makefile
73
74 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
75 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
76
77 cat > user-config.py <<END
78 CCFLAGS           = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
79 CXXFLAGS          = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
80 LDFLAGS           = [$RPMLDFLAGS]
81 TARGET_CC         = '%{__cc}'
82 TARGET_CXX        = '%{__cxx}'
83
84 BF_PYTHON_VERSION = '%{py_ver}'
85
86 BF_FFMPEG         = '%{_prefix}'
87 BF_FFMPEG_INC     = '%{_includedir}/ffmpeg'
88 BF_FFMPEG_LIBPATH = '%{_libdir}'
89 BF_FFMPEG_LIB     = 'avformat avcodec avdevice swscale avutil'
90
91 LCGDIR            = 'lib/linux2'
92 BF_BUILDDIR       = 'build/linux2'
93 BF_INSTALLDIR     = 'install/linux2'
94 END
95
96 %build
97 %scons BF_OPENGL_LIBPATH=%{_x_libraries}
98 %{__make} -C po \
99         OCGDIR=.. \
100         SRCHOME=$(pwd)/source \
101         NANBLENDERHOME=$(pwd)
102
103 install -d release/plugins/include
104 install source/blender/blenpluginapi/*.h release/plugins/include
105 chmod +x release/plugins/bmake
106 %{__make} -C release/plugins/
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
111         $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
112
113 install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
114 install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
115 #install blenderplayer $RPM_BUILD_ROOT%{_bindir}
116 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
117 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
118 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
119 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
120 install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
121 install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
122 install -d $RPM_BUILD_ROOT%{_datadir}/blender
123 cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
124 install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
125 install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
126 install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
127 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}
128 install -d $RPM_BUILD_ROOT%{_mandir}/man1
129 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
130
131 %find_lang %{name}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 %update_desktop_database_post
138
139 %postun
140 %update_desktop_database_postun
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
145 %doc release/text/{blender.html,release*.txt}
146 %attr(755,root,root) %{_bindir}/*
147 %attr(755,root,root) %{_datadir}/%{name}
148 %attr(755,root,root) %{_libdir}/%{name}
149 %{_desktopdir}/*.desktop
150 %{_pixmapsdir}/*.png
151 %{_mandir}/man1/*
This page took 0.036326 seconds and 4 git commands to generate.