]> git.pld-linux.org Git - packages/bison.git/blob - bison.spec
- unify ftp.gnu.org urls
[packages/bison.git] / bison.spec
1 Summary:        A GNU general-purpose parser generator
2 Summary(de.UTF-8):      GNU-Parser-Generator
3 Summary(es.UTF-8):      Generador de parser de la GNU
4 Summary(fr.UTF-8):      Générateur d'analyseur lexical de GNU
5 Summary(pl.UTF-8):      GNU generator składni
6 Summary(pt_BR.UTF-8):   Gerador de parser da GNU
7 Summary(ru.UTF-8):      Bison - генератор парсеров GNU
8 Summary(tr.UTF-8):      GNU ayrıştırıcı üreticisi
9 Summary(uk.UTF-8):      Bison - генератор парсерів GNU
10 Name:           bison
11 Version:        2.3
12 Release:        1
13 License:        GPL
14 Group:          Development/Tools
15 Source0:        http://ftp.gnu.org/gnu/bison/%{name}-%{version}.tar.bz2
16 # Source0-md5:  c18640c6ec31a169d351e3117ecce3ec
17 Source1:        %{name}.1.pl
18 Patch0:         %{name}-info.patch
19 Patch1:         %{name}-pl.po-update.patch
20 BuildRequires:  automake
21 BuildRequires:  flex
22 BuildRequires:  gettext-devel >= 0.12
23 BuildRequires:  m4 >= 1.4.3
24 BuildRequires:  texinfo >= 4.0
25 Requires:       %{name}-runtime = %{version}-%{release}
26 Requires:       m4 >= 1.4.3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         pkgdatadir      %{_datadir}/bison
30
31 %description
32 Bison is a general purpose parser generator which converts a grammar
33 description for an LALR context-free grammar into a C program to parse
34 that grammar. Bison can be used to develop a wide range of language
35 parsers, from ones used in simple desk calculators to complex
36 programming languages. Bison is upwardly compatible with Yacc, so any
37 correctly written Yacc grammar should work with Bison without any
38 changes. If you know Yacc, you shouldn't have any trouble using Bison
39 (but you do need to be very proficient in C programming to be able to
40 use Bison). Many programs use Bison as part of their build process.
41 Bison is only needed on systems that are used for development.
42
43 %description -l de.UTF-8
44 Dies ist der GNU-Parser-Generator, der größtenteils mit yacc
45 kompatibel ist. Viele Programme benutzen ihn als Teil des
46 Aufbauvorgangs. Bison wird nur auf Systemen benötigt, die zur
47 Entwicklung verwendet werden.
48
49 %description -l es.UTF-8
50 Este es el creador de análisis gramatical GNU más compatible con yacc.
51 Varios programas lo utilizan como parte del su proceso de
52 construcción. Bison solamente hace falta en sistemas que se usan para
53 desarrollo.
54
55 %description -l fr.UTF-8
56 Générateur d'analyseur lexical de GNU compatible avec yacc. De
57 nombreux programmes l'utilisent dans leur phase de construction. Bison
58 ne sert que sur les systèmes utilisés pour le développement.
59
60 %description -l pl.UTF-8
61 W pakiecie znajduje się implementacja GNU generatora analizatora
62 składni, który jest odpowiednikiem programu yacc. Wiele programów
63 podczas kompilacji potrzebuje tego programu aby proces budowy plików
64 binarnych przebiegał prawidłowo. Bison jest potrzebny tylko w
65 systemach, w których prowadzone są różnego rodzaju kompilacje.
66
67 %description -l pt_BR.UTF-8
68 Este é o gerador de análise gramatical GNU que é mais compatível com
69 yacc. Vários programas o utilizam como parte do seu processo de
70 construção. Bison é somente necessário em sistemas que são usados para
71 desenvolvimento.
72
73 %description -l ru.UTF-8
74 Bison - это парсер, в основном совместимый с yacc. Многие программы
75 используют его в процессе компилляции. Bison нужен только в системах,
76 которые используются для разработки программ.
77
78 %description -l tr.UTF-8
79 byacc bir yacc ayrıştırıcısıdır. Pek çok program tarafından, kurulum
80 süreci sırasında kullanılır. Geliştirme yapanlara gerekli olabilir.
81
82 %description -l uk.UTF-8
83 Bison - це парсер, здебільшого сумісний з yacc. Багато програм
84 використовують його в процесі компіляції. Bison потрібен тільки в
85 системах, які використовуються для розробки програм.
86
87 %package runtime
88 Summary:        Runtime library for programs containing bison-generated parsers
89 Summary(pl.UTF-8):      Biblioteka uruchomieniowa dla programów zawierajacych parsery bisonowe
90 Group:          Libraries
91
92 %description runtime
93 Runtime library for internationalized programs containing
94 bison-generated parsers.
95
96 %description runtime -l pl.UTF-8
97 Biblioteka uruchomieniowa dla umiędzynarodowionych programów
98 zawierajacych parsery wygenerowane przez bisona.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104
105 rm -f po/stamp-po
106
107 %build
108 cp -f /usr/share/automake/config.sub config
109 %configure
110 %{__make} \
111         pkgdatadir=%{pkgdatadir}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         pkgdatadir=%{pkgdatadir}
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/bison.1
122
123 %find_lang %{name}
124 %find_lang %{name}-runtime
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p      /sbin/postshell
130 -/usr/sbin/fix-info-dir -c %{_infodir}
131
132 %postun -p      /sbin/postshell
133 -/usr/sbin/fix-info-dir -c %{_infodir}
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README THANKS TODO
138 %attr(755,root,root) %{_bindir}/bison
139 # would conflict with byacc (but is not 100% compatible)
140 #%attr(755,root,root) %{_bindir}/yacc
141 %{pkgdatadir}
142 %{_libdir}/lib*.a
143 %{_aclocaldir}/bison-i18n.m4
144 %{_mandir}/man1/*
145 %lang(pl) %{_mandir}/pl/man1/*
146 %{_infodir}/*.info*
147
148 %files runtime -f %{name}-runtime.lang
149 %defattr(644,root,root,755)
This page took 0.039445 seconds and 4 git commands to generate.