]> git.pld-linux.org Git - packages/bird.git/blob - bird.spec
16c32db262135385c6cff504f58a8c55907c80eb
[packages/bird.git] / bird.spec
1 # TODO:
2 #       - trigger to clean up after old bird package (stop, chkconfig --del)
3 #
4 # Conditional build:
5 %bcond_without  ipv6    # disable IPv6 support (and building bird-ipv6 package)
6 %bcond_without  ipv4    # disable IPv4 support (and building bird-ipv4 package)
7 %bcond_with     alien   # enable possibility to import 'alien' routes import into bird's routing table
8 #
9 Summary:        The BIRD Internet Routing Daemon
10 Summary(pl.UTF-8):      Demon BIRD Internetowego Routingu Dynamicznego
11 Name:           bird
12 Version:        1.3.0
13 Release:        2
14 License:        GPL v2+
15 Group:          Networking/Daemons
16 Source0:        ftp://bird.network.cz/pub/bird/%{name}-%{version}.tar.gz
17 # Source0-md5:  4836e3b15fcbe03d5dfe467bd4ca98fb
18 Source1:        %{name}-ipv4.init
19 Source2:        %{name}-ipv4.sysconfig
20 Source3:        %{name}-ipv6.init
21 Source4:        %{name}-ipv6.sysconfig
22 Source5:        ftp://bird.network.cz/pub/bird/%{name}-doc-%{version}.tar.gz
23 # Source5-md5:  c99c927430a4ccb07d3317614520caf2
24 Patch0:         %{name}-tinfo.patch
25 Patch1:         %{name}-allowalien.patch
26 URL:            http://bird.network.cz/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  bison
30 BuildRequires:  flex
31 BuildRequires:  readline-devel >= 4.2
32 BuildRequires:  rpmbuild(macros) >= 1.268
33 Requires(post,preun):   /sbin/chkconfig
34 Requires:       bird-daemon
35 Requires:       rc-scripts
36 Obsoletes:      gated
37 Obsoletes:      mrt
38 Obsoletes:      zebra
39 Obsoletes:      zebra-guile
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 The BIRD project is an attempt to create a routing daemon running on
44 UNIX-like systems (but not necessarily limited to them) with full
45 support of all modern routing protocols, easy to use configuration
46 interface and powerful route filtering language.
47
48 %description -l pl.UTF-8
49 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
50 pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
51 protokołów routingu, łatwym interfejsem konfiguracji i językiem
52 filtrów o dużych możliwościach.
53
54 %package ipv4
55 Summary:        Routing daemon for IPv4
56 Summary(pl.UTF-8):      Demon dynamicznego routingu IPv4
57 Group:          Networking/Daemons
58 Requires(post,preun):   /sbin/chkconfig
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       rc-scripts
61 Provides:       bird-daemon
62 Provides:       routingdaemon
63 Obsoletes:      gated
64 Obsoletes:      mrt
65 Obsoletes:      zebra
66 Obsoletes:      zebra-guile
67
68 %description ipv4
69 The BIRD project is an attempt to create a routing daemon running on
70 UNIX-like systems (but not necessarily limited to them) with full
71 support of all modern routing protocols, easy to use configuration
72 interface and powerful route filtering language.
73
74 %description ipv4 -l pl.UTF-8
75 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
76 pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
77 protokołów routingu, łatwym interfejsem konfiguracji i językiem
78 filtrów o dużych możliwościach.
79
80 %package ipv6
81 Summary:        Routing daemon for IPv6
82 Summary(pl.UTF-8):      Demon dynamicznego routingu IPv6
83 Group:          Networking/Daemons
84 Requires(post,preun):   /sbin/chkconfig
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       rc-scripts
87 Provides:       bird-daemon
88 Provides:       routingdaemon
89 Obsoletes:      gated
90 Obsoletes:      mrt
91 Obsoletes:      zebra
92 Obsoletes:      zebra-guile
93
94 %description ipv6
95 The BIRD project is an attempt to create a routing daemon running on
96 UNIX-like systems (but not necessarily limited to them) with full
97 support of all modern routing protocols, easy to use configuration
98 interface and powerful route filtering language.
99
100 %description ipv6 -l pl.UTF-8
101 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
102 pracującego na systemach UNIX z pełnym wsparciem dla nowoczesnych
103 protokołów routingu, łatwym interfejsem konfiguracji i językiem
104 filtrów o dużych możliwościach.
105
106 %prep
107 %setup -q -a 5
108 %patch0 -p1
109 %{?with_alien:%patch1 -p1}
110
111 %build
112 cp -f /usr/share/automake/config.* tools
113 %{__autoconf}
114
115 export CFLAGS="%{rpmcflags} -I%{_includedir}/ncursesw"
116
117 %if %{with ipv6}
118 %configure \
119         --disable-memcheck \
120         --enable-client \
121         --enable-ipv6
122 %{__make} -j1
123
124 mv bird bird-6
125
126 %{__make} clean
127 %endif
128
129 %if %{with ipv4}
130 %configure \
131         --disable-memcheck \
132         --enable-client \
133         --disable-ipv6
134 %{__make} -j1
135 %endif
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_sbindir}}
140
141 install birdc $RPM_BUILD_ROOT%{_sbindir}
142
143 %if %{with ipv6}
144 install bird $RPM_BUILD_ROOT%{_sbindir}
145 install doc/bird.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
146 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv4
147 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv4
148 %endif
149
150 %if %{with ipv6}
151 install bird-6 $RPM_BUILD_ROOT%{_sbindir}
152 cat <<EOF > $RPM_BUILD_ROOT%{_sbindir}/birdc-6
153 #!/bin/sh
154 exec %{_sbindir}/birdc -s /var/run/bird-6.ctl
155 EOF
156 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv6
157 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv6
158 %endif
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post ipv4
164 /sbin/chkconfig --add %{name}-ipv4
165 %service %{name}-ipv4 restart "routing daemon"
166
167 %preun ipv4
168 if [ "$1" = "0" ]; then
169         %service %{name}-ipv4 stop
170         /sbin/chkconfig --del %{name}-ipv4
171 fi
172
173 %post ipv6
174 /sbin/chkconfig --add %{name}-ipv6
175 %service %{name}-ipv6 restart "routing daemon"
176
177 %preun ipv6
178 if [ "$1" = "0" ]; then
179         %service %{name}-ipv6 stop
180         /sbin/chkconfig --del %{name}-ipv6
181 fi
182
183 %files
184 %defattr(644,root,root,755)
185 %doc doc/*.html doc/reply_codes %{name}-doc-%{version}/doc/*.ps ChangeLog NEWS README TODO
186 %attr(755,root,root) %{_sbindir}/birdc
187
188 %if %{with ipv4}
189 %files ipv4
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_sbindir}/bird
192 %attr(754,root,root) /etc/rc.d/init.d/bird-ipv4
193 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv4
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird.conf
195 %endif
196
197 %if %{with ipv6}
198 %files ipv6
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_sbindir}/bird-6
201 %attr(755,root,root) %{_sbindir}/birdc-6
202 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv6
203 %attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rc.d/init.d/bird-ipv6
204 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird-6.conf
205 %endif
This page took 0.076201 seconds and 3 git commands to generate.