]> git.pld-linux.org Git - packages/bircd.git/blob - bircd.spec
- updated to 2.0.3rc12
[packages/bircd.git] / bircd.spec
1 #
2 # Conditional build
3 %bcond_with     smode   # build with /smode command support
4 %bcond_with     crypt   # build with crypted passwords support
5 #
6 Summary:        Internet Relay Chat Server
7 Summary(pl):    Serwer IRC (Internet Relay Chat)
8 Name:           bircd
9 Version:        2.0.3rc12
10 Release:        1
11 License:        GPL
12 Group:          Daemons
13 Source0:        ftp://ftp.benet.uu3.net/pub/ircd/%{name}-%{version}.tgz
14 # Source0-md5:  02d911afbe404d4b26adb73e8e0a3299
15 Source1:        %{name}.init
16 Source2:        %{name}.sysconfig
17 Source3:        %{name}.logrotate
18 Source4:        %{name}.motd
19 Patch0:         %{name}-makefile.patch
20 Patch1:         %{name}-config.patch
21 Patch2:         %{name}-smode.patch
22 Patch3:         %{name}-crypt.patch
23 URL:            http://www.benet.uu3.net/~borg/
24 BuildRequires:  rpmbuild(macros) >= 1.202
25 PreReq:         rc-scripts
26 Requires(pre):  /usr/bin/getgid
27 Requires(pre):  /bin/id
28 Requires(pre):  /usr/sbin/groupadd
29 Requires(pre):  /usr/sbin/useradd
30 Requires(post): fileutils
31 Requires(post,preun):   /sbin/chkconfig
32 Requires(postun):       /usr/sbin/groupdel
33 Requires(postun):       /usr/sbin/userdel
34 Provides:       group(ircd)
35 Provides:       user(ircd)
36 Obsoletes:      ircd
37 Obsoletes:      ircd6
38 Obsoletes:      ircd-hybrid
39 Obsoletes:      ircd-ptlink
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _sysconfdir     /etc/ircd
43 %define         _localstatedir  /var/lib/ircd
44
45 %description
46 bIRCd is a small, simple and very fast IRC server. It is easy to
47 configure and use. It also has support for IPv6.
48
49 %description -l pl
50 bIRCd jest ma³ym, prostym i bardzo szybkim serwerem IRC. Jest bardzo
51 prosty w konfiguracji i u¿ytkowaniu. Posiada równie¿ wsparcie dla
52 IPv6.
53
54 %prep
55 %setup -q -n %{name}
56 %patch0 -p1
57 %patch1 -p1
58 %{?with_smode:%patch2 -p1}
59 %{?with_crypt:%patch3 -p1}
60
61 %build
62 ./Config
63 %{__make} \
64         LIBDIR=%{_libdir}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_var}/log/{,archiv/}ircd,%{_sbindir}} \
69         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig,logrotate.d}} \
70         $RPM_BUILD_ROOT%{_localstatedir}
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ircd
76 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ircd
77 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/ircd
78 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/ircd.motd
79
80 touch $RPM_BUILD_ROOT%{_localstatedir}/ircd.pid
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %pre
86 %groupadd -f -g 75 ircd
87 %useradd -g ircd -d /etc/ircd -u 75 -s /bin/true -c "IRC Service account" ircd
88
89 %post
90 /sbin/chkconfig --add ircd
91 if [ -f /var/lock/subsys/ircd ]; then
92         /etc/rc.d/init.d/ircd restart 1>&2
93 else
94         echo "Run \"/etc/rc.d/init.d/ircd start\" to start IRC daemon."
95 fi
96 touch /var/log/ircd/{opers.log,rejects.log,users.log}
97 chmod 640 /var/log/ircd/*
98 chown ircd:ircd /var/log/ircd/*
99
100 %preun
101 # If package is being erased for the last time.
102 if [ "$1" = "0" ]; then
103         if [ -f /var/lock/subsys/ircd ]; then
104                 /etc/rc.d/init.d/ircd stop 1>&2
105         fi
106         /sbin/chkconfig --del ircd
107 fi
108
109 %postun
110 if [ "$1" = "0" ]; then
111         %userremove ircd
112         %groupremove ircd
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc README CHANGES
118 %doc doc/{Advertisement,Authors,Etiquette,Manual,Operators,README.patches}
119 %doc doc/{conf.doc,example.conf,tao.of.irc,whatsnew}
120 %attr(755,root,root) %{_sbindir}/*
121 %attr(770,root,ircd) %dir %{_var}/log/ircd
122 %attr(770,root,ircd) %dir %{_var}/log/archiv/ircd
123 %attr(770,root,ircd) %dir %{_localstatedir}
124 %attr(640,ircd,ircd) %ghost %{_localstatedir}/ircd.pid
125 %attr(750,root,ircd) %dir %{_sysconfdir}
126 %attr(660,root,ircd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ircd.conf
127 %attr(660,root,ircd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ircd.motd
128 %attr(754,root,root) /etc/rc.d/init.d/ircd
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ircd
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/ircd
This page took 0.064685 seconds and 4 git commands to generate.