]> git.pld-linux.org Git - packages/bircd.git/blob - bircd.spec
- obsoletes other IRC servers (not conflicts)
[packages/bircd.git] / bircd.spec
1 Summary:        Internet Relay Chat Server
2 Summary(pl):    Serwer IRC (Internet Relay Chat)
3 Name:           bircd
4 Version:        2.0.3rc6
5 Release:        0.1
6 License:        GPL
7 Group:          Daemons
8 Source0:        http://www.onthanet.nl/~borg/download/%{name}%{version}.tgz
9 # Source0-md5:  2b59be1677db237521ae0c628511866c
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-makefile.patch
14 Patch1:         %{name}-config.patch
15 Patch2:         %{name}-fix.patch
16 URL:            http://www.onthanet.nl/~borg/
17 PreReq:         rc-scripts
18 Requires(pre):  /usr/bin/getgid
19 Requires(pre):  /bin/id
20 Requires(pre):  /usr/sbin/groupadd
21 Requires(pre):  /usr/sbin/useradd
22 Requires(post): fileutils
23 Requires(post,preun):   /sbin/chkconfig
24 Requires(postun):       /usr/sbin/userdel
25 Requires(postun):       /usr/sbin/groupdel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 Obsoletes:      ircd
28 Obsoletes:      ircd6
29 Obsoletes:      ircd-hybrid
30 Obsoletes:      ircd-ptlink
31
32 %define         _sysconfdir     /etc/ircd
33 %define         _localstatedir  /var/lib/ircd
34
35 %description
36 bIRCd is a small, simple and very fast IRC server. It is easy to
37 configure and use. It also has support for IPv6.
38
39
40 %description -l pl
41 bIRCd jest ma³ym, prostym i bardzo szybkim serwerem IRC. Jest bardzo
42 prosty w konfiguracji i u¿ytkowaniu. Posiada równie¿ wsparcie dla
43 IPv6.
44
45 %prep
46 %setup -q -n bircd
47 %patch0 -p1
48 %patch1 -p1
49 %patch2 -p1
50
51 %build
52 ./Config
53 %{__make} \
54         LIBDIR=%{_libdir}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_var}/log/{,archiv/}ircd,%{_sbindir}} \
59         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig,logrotate.d}} \
60         $RPM_BUILD_ROOT%{_localstatedir}
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ircd
66 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ircd
67 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/ircd
68
69 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/ircd.motd
70
71 Powered by \ 2PLD\ 2 \ 2L\ 2inux \ 2D\ 2istribution \ 2IRC Server\ 2!
72
73 WWW\ 2:\ 2        \ 2http://www.pld-linux.org/\ 2
74 FTP\ 2:\ 2        \ 2ftp://ftp.pld-linux.org/\ 2
75 e-mail\ 2:\ 2      \ 2feedback@pld-linux.org\ 2
76
77 EOF
78
79 touch $RPM_BUILD_ROOT%{_localstatedir}/ircd.pid
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %pre
85 if [ -n "`getgid ircd`" ]; then
86         if [ "`getgid ircd`" != "75" ]; then
87                 echo "Error: group ircd doesn't have gid=75. Correct this before installing ircd." 1>&2
88                 exit 1
89         fi
90 else
91         %{_sbindir}/groupadd -f -g 75 ircd 2> /dev/null
92 fi
93 if [ -n "`id -u ircd 2>/dev/null`" ]; then
94         if [ "`id -u ircd`" != "75" ]; then
95                 echo "Error: user ircd doesn't have uid=75. Correct this before installing ircd." 1>&2
96                 exit 1
97         fi
98 else
99         %{_sbindir}/useradd -g ircd -d /etc/ircd -u 75 -s /bin/true -c "IRC Service account" ircd 2> /dev/null
100 fi
101
102 %post
103 /sbin/chkconfig --add ircd
104 if [ -f /var/lock/subsys/ircd ]; then
105         /etc/rc.d/init.d/ircd restart 1>&2
106 else
107         echo "Run \"/etc/rc.d/init.d/ircd start\" to start IRC daemon."
108 fi
109 touch /var/log/ircd/{opers.log,rejects.log,users.log}
110 chmod 640 /var/log/ircd/*
111 chown ircd:ircd /var/log/ircd/*
112
113 %preun
114 # If package is being erased for the last time.
115 if [ "$1" = "0" ]; then
116         if [ -f /var/lock/subsys/ircd ]; then
117                 /etc/rc.d/init.d/ircd stop 1>&2
118         fi
119         /sbin/chkconfig --del ircd
120 fi
121
122 %postun
123 # If package is being erased for the last time.
124 if [ "$1" = "0" ]; then
125         %{_sbindir}/userdel ircd 2> /dev/null
126         %{_sbindir}/groupdel ircd 2> /dev/null
127 fi
128
129 %files
130 %defattr(644,root,root,755)
131 %doc README CHANGES
132 %doc doc/{Advertisement,Authors,Etiquette,Manual,Operators,README.patches}
133 %doc doc/{conf.doc,example.conf,tao.of.irc,whatsnew}
134 %attr(755,root,root) %{_sbindir}/*
135 %attr(770,root,ircd) %dir %{_var}/log/ircd
136 %attr(770,root,ircd) %dir %{_var}/log/archiv/ircd
137 %attr(770,root,ircd) %dir %{_localstatedir}
138 %attr(640,ircd,ircd) %ghost %{_localstatedir}/ircd.pid
139 %attr(750,root,ircd) %dir %{_sysconfdir}
140 %attr(660,root,ircd) %config(noreplace) %{_sysconfdir}/ircd.conf
141 %attr(664,root,ircd) %{_sysconfdir}/ircd.motd
142 %attr(754,root,root) /etc/rc.d/init.d/ircd
143 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/ircd
144 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/ircd
This page took 0.042028 seconds and 4 git commands to generate.