]> git.pld-linux.org Git - packages/bircd.git/blob - bircd.spec
- new spec, bIRCd IRC server
[packages/bircd.git] / bircd.spec
1 Summary:        Internet Relay Chat Server
2 Summary(pl):    Serwer IRC (Internet Relay Chat)
3 Name:           bircd
4 Version:        2.0.3rc6
5 Release:        0.1
6 License:        GPL
7 Group:          Daemons
8 Source0:        http://www.onthanet.nl/~borg/download/%{name}%{version}.tgz
9 # Source0-md5:  2b59be1677db237521ae0c628511866c
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.logrotate
13 Patch0:         %{name}-makefile.patch
14 Patch1:         %{name}-config.patch
15 Patch2:         %{name}-fix.patch
16 URL:            http://www.onthanet.nl/~borg/
17 PreReq:         rc-scripts
18 Requires(pre):  /usr/bin/getgid
19 Requires(pre):  /bin/id
20 Requires(pre):  /usr/sbin/groupadd
21 Requires(pre):  /usr/sbin/useradd
22 Requires(post): fileutils
23 Requires(post,preun):   /sbin/chkconfig
24 Requires(postun):       /usr/sbin/userdel
25 Requires(postun):       /usr/sbin/groupdel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 Conflicts:      ircd
28 Conflicts:      ircd-hybrid
29
30 %define         _sysconfdir     /etc/ircd
31 %define         _localstatedir  /var/lib/ircd
32
33 %description
34 bIRCd is a small, simple and very fast IRC server. It is easy to
35 configure and use. It also has support for IPv6.
36
37
38 %description -l pl
39 bIRCd jest ma³ym, prostym i bardzo szybkim serwerem IRC. Jest bardzo
40 prosty w konfiguracji i u¿ytkowaniu. Posiada równie¿ wsparcie dla
41 IPv6.
42
43 %prep
44 %setup -q -n bircd
45 %patch0 -p1
46 %patch1 -p1
47 %patch2 -p1
48
49 %build
50 ./Config
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_var}/log/{,archiv/}ircd,%{_sbindir}} \
56         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig,logrotate.d}} \
57         $RPM_BUILD_ROOT%{_localstatedir}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ircd
63 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ircd
64 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/ircd
65
66 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/ircd.motd
67
68 Powered by \ 2PLD\ 2 \ 2L\ 2inux \ 2D\ 2istribution \ 2IRC Server\ 2!
69
70 WWW\ 2:\ 2        \ 2http://www.pld-linux.org/\ 2
71 FTP\ 2:\ 2        \ 2ftp://ftp.pld-linux.org/\ 2
72 e-mail\ 2:\ 2      \ 2feedback@pld-linux.org\ 2
73
74 EOF
75
76 touch $RPM_BUILD_ROOT%{_localstatedir}/ircd.pid
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %pre
82 if [ -n "`getgid ircd`" ]; then
83         if [ "`getgid ircd`" != "75" ]; then
84                 echo "Error: group ircd doesn't have gid=75. Correct this before installing ircd." 1>&2
85                 exit 1
86         fi
87 else
88         %{_sbindir}/groupadd -f -g 75 ircd 2> /dev/null
89 fi
90 if [ -n "`id -u ircd 2>/dev/null`" ]; then
91         if [ "`id -u ircd`" != "75" ]; then
92                 echo "Error: user ircd doesn't have uid=75. Correct this before installing ircd." 1>&2
93                 exit 1
94         fi
95 else
96         %{_sbindir}/useradd -g ircd -d /etc/ircd -u 75 -s /bin/true -c "IRC Service account" ircd 2> /dev/null
97 fi
98
99 %post
100 /sbin/chkconfig --add ircd
101 if [ -f /var/lock/subsys/ircd ]; then
102         /etc/rc.d/init.d/ircd restart 1>&2
103 else
104         echo "Run \"/etc/rc.d/init.d/ircd start\" to start IRC daemon."
105 fi
106 touch /var/log/ircd/{opers.log,rejects.log,users.log}
107 chmod 640 /var/log/ircd/*
108 chown ircd:ircd /var/log/ircd/*
109
110 %preun
111 # If package is being erased for the last time.
112 if [ "$1" = "0" ]; then
113         if [ -f /var/lock/subsys/ircd ]; then
114                 /etc/rc.d/init.d/ircd stop 1>&2
115         fi
116         /sbin/chkconfig --del ircd
117 fi
118
119 %postun
120 # If package is being erased for the last time.
121 if [ "$1" = "0" ]; then
122         %{_sbindir}/userdel ircd 2> /dev/null
123         %{_sbindir}/groupdel ircd 2> /dev/null
124 fi
125
126 %files
127 %defattr(644,root,root,755)
128 %doc README CHANGES
129 %doc doc/{Advertisement,Authors,Etiquette,Manual,Operators,README.patches}
130 %doc doc/{conf.doc,example.conf,tao.of.irc,whatsnew}
131 %attr(755,root,root) %{_sbindir}/*
132 %attr(770,root,ircd) %dir %{_var}/log/ircd
133 %attr(770,root,ircd) %dir %{_var}/log/archiv/ircd
134 %attr(770,root,ircd) %dir %{_localstatedir}
135 %attr(640,ircd,ircd) %ghost %{_localstatedir}/ircd.pid
136 %attr(750,root,ircd) %dir %{_sysconfdir}
137 %attr(660,root,ircd) %config(noreplace) %{_sysconfdir}/ircd.conf
138 %attr(664,root,ircd) %{_sysconfdir}/ircd.motd
139 %attr(754,root,root) /etc/rc.d/init.d/ircd
140 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/ircd
141 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/ircd
This page took 0.083597 seconds and 4 git commands to generate.