]> git.pld-linux.org Git - packages/binwalk.git/blob - binwalk.spec
- initial PLD release
[packages/binwalk.git] / binwalk.spec
1 Summary:        Binary image analyze tool
2 Name:           binwalk
3 Version:        0.3.8
4 Release:        1
5 License:        MIT
6 Group:          Applications/Development
7 Source0:        http://binwalk.googlecode.com/files/%{name}-%{version}.tar.gz
8 # Source0-md5:  bc145f8b9abd5e79d5bc3aecdc0ab829
9 URL:            http://code.google.com/p/binwalk/
10 BuildRequires:  autoconf >= 2.65
11 BuildRequires:  curl-devel
12 BuildRequires:  libmagic-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Binwalk is a tool for searching a given binary image for embedded files
17 and executable code. Specifically, it is designed for identifying files
18 and code embedded inside of firmware images. Binwalk uses the libmagic
19 library, so it is compatible with magic signatures created for the Unix
20 file utility.
21
22 Binwalk also includes a custom magic signature file which contains
23 improved signatures for files that are commonly found in firmware
24 images such as compressed/archived files, firmware headers, Linux
25 kernels, bootloaders, filesystems, etc. 
26
27 %prep
28 %setup -q
29 perl -ne 's/-lz/-lmagic/; print unless /^tar -zxvf \$FILE\.tar\.gz/' -i src/configure.ac
30 perl -ne 'print unless /FILE/' -i src/Makefile.in
31
32 %build
33 cd src
34 %{__autoconf}
35 %configure
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} -C src install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc docs/README
50 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
51 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.058949 seconds and 4 git commands to generate.