]> git.pld-linux.org Git - packages/binwalk.git/blob - binwalk.spec
- add "BuildArch: noarch"
[packages/binwalk.git] / binwalk.spec
1 # TODO:
2 # - split library into subpackage?
3 #
4 %define module  binwalk
5 Summary:        Binary image analyze tool
6 Name:           binwalk
7 Version:        2.1.1
8 Release:        3
9 License:        MIT
10 Group:          Applications/Development
11 Source0:        https://github.com/devttys0/binwalk/archive/v%{version}.tar.gz
12 # Source0-md5:  e5015a8d0eff287eda8c4afeeca89ed6
13 URL:            https://github.com/devttys0/binwalk
14 %if %{with python3}
15 BuildRequires:  python3-modules
16 BuildRequires:  python3-setuptools
17 %endif
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 BuildArch:      noarch
20
21 %description
22 Binwalk is a tool for searching a given binary image for embedded
23 files and executable code. Specifically, it is designed for
24 identifying files and code embedded inside of firmware images. Binwalk
25 uses the libmagic library, so it is compatible with magic signatures
26 created for the Unix file utility.
27
28 Binwalk also includes a custom magic signature file which contains
29 improved signatures for files that are commonly found in firmware
30 images such as compressed/archived files, firmware headers, Linux
31 kernels, bootloaders, filesystems, etc.
32
33 %prep
34 %setup -q
35
36 %build
37 %py3_build %{?with_tests:test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %py3_install
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc API.md README.md
50 %attr(755,root,root) %{_bindir}/binwalk
51 %{py3_sitescriptdir}/%{module}
52 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
53
This page took 0.078903 seconds and 4 git commands to generate.