]> git.pld-linux.org Git - packages/binfmt-detector.git/blob - binfmt-detector.spec
- new
[packages/binfmt-detector.git] / binfmt-detector.spec
1 Summary:        Microsoft PE executable type detector
2 Summary(pl):    Detector typu plików wykonywalnych PE Microsoftu
3 Name:           binfmt-detector
4 Version:        0.1
5 Release:        1
6 License:        GPL
7 Group:          Base
8 Source0:        http://team.pld-linux.org/~wolf/%{name}.tar.gz
9 # Source0-md5:  11623bddbeb536e88c47c8a1aedc9189
10 Source1:        %{name}.init
11 Conflicts:      wine <= 1:0.9.12-1
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 This utility determines the Microsoft PE executable file's type
16 (Native, .NET CLR) and runs it using the appropriate runtime (Wine,
17 Mono).
18
19 It is inteded to be used in a Linux binfmt configuration, since binfmt
20 itself is incapable of reliably distinguishing between various PE file
21 types (since they have no different "magic string") and runtimes
22 refuse to run files which they don't support (CLR runtimes refuse to
23 run Native images and vice versa).
24
25 %description -l pl
26 To narzêdzie okre¶la typ pliku wykonywalnego PE Microsoftu (natywny,
27 .NET CLR) i uruchamia odpowiednie ¶rodowisko wykonawcze (Wine, Mono).
28
29 Jest u¿ywane w po³±czeniu z Linuksowym binfmt, poniewa¿ samo binfmt
30 nie jest w stanie odró¿niæ ró¿nych typów plików PE (nie zawieraj± one
31 ró¿nych "magicznych ci±gów"), a ¶rodowiska uruchomieniowe nie
32 pozwalaj± uruchomiæ nieobs³ugiwanych przez siebie plików (CLR nie
33 uruchamia natywnych obrazów i vice versa).
34
35 %prep
36 %setup -q -n %{name}
37
38 %build
39 %{__cc} %{rpmcflags} binfmt-detector-cli.c -o binfmt-detector-cli
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/rc.d/init.d}
44
45 install binfmt-detector-cli $RPM_BUILD_ROOT%{_bindir}
46 install binfmt-detector.sh $RPM_BUILD_ROOT%{_bindir}
47
48 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/binfmt-detector
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/chkconfig --add binfmt-detector
55 if [ ! -f /var/lock/subsys/binfmt-detector ]; then
56         echo "Run \"/etc/rc.d/init.d/binfmt-detector start\" to start binfmt-detector service." >&2
57 fi
58
59 %preun
60 if [ "$1" = "0" ]; then
61         if [ -f /var/lock/subsys/binfmt-detector ]; then
62                 /etc/rc.d/init.d/binfmt-detector stop >&2
63         fi
64         /sbin/chkconfig --del binfmt-detector
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README
70 %attr(755,root,root) %{_bindir}/*
71 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/binfmt-detector
This page took 0.037748 seconds and 4 git commands to generate.