]> git.pld-linux.org Git - packages/binfmt-detector.git/blob - binfmt-detector.spec
- use %service
[packages/binfmt-detector.git] / binfmt-detector.spec
1 Summary:        Microsoft PE executable type detector
2 Summary(pl):    Detector typu plików wykonywalnych PE Microsoftu
3 Name:           binfmt-detector
4 Version:        0.1
5 Release:        1
6 License:        GPL
7 Group:          Base
8 Source0:        http://team.pld-linux.org/~wolf/%{name}.tar.gz
9 # Source0-md5:  11623bddbeb536e88c47c8a1aedc9189
10 Source1:        %{name}.init
11 BuildRequires:  rpmbuild(macros) >= 1.268
12 Conflicts:      wine <= 1:0.9.12-1
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 This utility determines the Microsoft PE executable file's type
17 (Native, .NET CLR) and runs it using the appropriate runtime (Wine,
18 Mono).
19
20 It is inteded to be used in a Linux binfmt configuration, since binfmt
21 itself is incapable of reliably distinguishing between various PE file
22 types (since they have no different "magic string") and runtimes
23 refuse to run files which they don't support (CLR runtimes refuse to
24 run Native images and vice versa).
25
26 %description -l pl
27 To narzêdzie okre¶la typ pliku wykonywalnego PE Microsoftu (natywny,
28 .NET CLR) i uruchamia odpowiednie ¶rodowisko wykonawcze (Wine, Mono).
29
30 Jest u¿ywane w po³±czeniu z Linuksowym binfmt, poniewa¿ samo binfmt
31 nie jest w stanie odró¿niæ ró¿nych typów plików PE (nie zawieraj± one
32 ró¿nych "magicznych ci±gów"), a ¶rodowiska uruchomieniowe nie
33 pozwalaj± uruchomiæ nieobs³ugiwanych przez siebie plików (CLR nie
34 uruchamia natywnych obrazów i vice versa).
35
36 %prep
37 %setup -q -n %{name}
38
39 %build
40 %{__cc} %{rpmcflags} binfmt-detector-cli.c -o binfmt-detector-cli
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_bindir},/etc/rc.d/init.d}
45
46 install binfmt-detector-cli $RPM_BUILD_ROOT%{_bindir}
47 install binfmt-detector.sh $RPM_BUILD_ROOT%{_bindir}
48
49 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/binfmt-detector
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /sbin/chkconfig --add binfmt-detector
56 %service binfmt-detector restart
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %service binfmt-detector stop
61         /sbin/chkconfig --del binfmt-detector
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %attr(755,root,root) %{_bindir}/*
68 %attr(754,root,root) /etc/rc.d/init.d/binfmt-detector
This page took 0.072119 seconds and 4 git commands to generate.