]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
deps and bcond for doh
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_without  lmdb            # LMDB storage support for addzone zones
10 %bcond_without  doh             # DNS over HTTPS support
11 %bcond_with     static_libs     # static libraries
12 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
13 %bcond_with     tests           # unit tests
14 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
15 %bcond_with     hip             # HIP RR support
16
17 %if "%{pld_release}" == "ac"
18 %bcond_with     epoll           # enable epoll support
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll           # disable epoll support
25 %endif
26
27 %define         ver     9.18.1
28 %if 0
29 %define         pverdot .P0
30 %define         pverdir -P0
31 %else
32 %define         pverdot %{nil}
33 %define         pverdir %{nil}
34 %endif
35 Summary:        BIND - DNS name server
36 Summary(de.UTF-8):      BIND - DNS-Namenserver
37 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
38 Summary(fr.UTF-8):      BIND - serveur de noms DNS
39 Summary(pl.UTF-8):      BIND - serwer nazw DNS
40 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
41 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
42 Summary(tr.UTF-8):      DNS alan adı sunucusu
43 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
44 Summary(zh_CN.UTF-8):   Internet 域名服务器
45 Name:           bind
46 Version:        %{ver}%{pverdot}
47 Release:        1
48 Epoch:          7
49 License:        MPL 2.0
50 Group:          Networking/Daemons
51 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
52 # Source0-md5:  d7072b2d774077f37bff51580b3a577b
53 Source1:        named.init
54 Source2:        named.sysconfig
55 Source3:        named.logrotate
56 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
57 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
58 Source6:        %{name}-hip.tar.gz
59 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
60 Source7:        https://www.internic.net/domain/named.root
61 # Source7-md5:  544504d19e2b71c259d2a09d231533aa
62 Source8:        %{name}-127.0.0.zone
63 Source9:        %{name}-localhost.zone
64 Source10:       %{name}-named.conf
65 Source11:       %{name}.tmpfiles
66 Source12:       named.service
67
68 Patch3:         jemalloc.patch
69 Patch4:         %{name}-ac-libs.patch
70 Patch5:         %{name}-edns-client-subnet.patch
71 URL:            https://www.isc.org/software/bind
72 BuildRequires:  autoconf >= 2.60
73 BuildRequires:  automake
74 BuildRequires:  bison
75 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
76 BuildRequires:  flex
77 %{?with_kerberos5:BuildRequires:        heimdal-devel}
78 BuildRequires:  jemalloc-devel
79 BuildRequires:  json-c-devel >= 0.11
80 BuildRequires:  libatomic-devel
81 BuildRequires:  libcap-devel
82 BuildRequires:  libidn2-devel
83 # note, there is no kyua in PLD yet (work in progress)
84 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
85 BuildRequires:  libtool
86 BuildRequires:  libuv-devel >= 1.37.0
87 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
88 BuildRequires:  libxml2-devel >= 1:2.6.0
89 %{?with_lmdb:BuildRequires:     lmdb-devel}
90 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
91 %{?with_doh:BuildRequires:      nghttp2-devel >= 1.6.0}
92 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
93 BuildRequires:  pkgconfig
94 BuildRequires:  python3-devel >= 1:3.2
95 BuildRequires:  python3-sphinx_rtd_theme
96 BuildRequires:  readline-devel
97 BuildRequires:  rpm >= 4.4.9-56
98 BuildRequires:  rpmbuild(macros) >= 1.647
99 BuildRequires:  sphinx-pdg
100 BuildRequires:  zlib-devel
101 %if %{with dnstap}
102 BuildRequires:  fstrm-devel
103 BuildRequires:  protobuf-c-devel
104 %endif
105 Requires(post,preun):   /sbin/chkconfig
106 Requires(postun):       /usr/sbin/groupdel
107 Requires(postun):       /usr/sbin/userdel
108 Requires(pre):  /bin/id
109 Requires(pre):  /usr/bin/getgid
110 Requires(pre):  /usr/sbin/groupadd
111 Requires(pre):  /usr/sbin/useradd
112 Requires(pre):  fileutils
113 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
114 Requires:       psmisc >= 20.1
115 Requires:       rc-scripts >= 0.2.0
116 Requires:       systemd-units >= 38
117 Requires:       uname(release) >= 2.2.18
118 Provides:       group(named)
119 Provides:       nameserver
120 Provides:       user(named)
121 Obsoletes:      caching-nameserver
122 Conflicts:      %{name}-chroot
123 Conflicts:      logrotate < 3.8.0
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %description
127 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
128 (Domain Name System) protocols. BIND includes a DNS server (named),
129 which resolves host names to IP addresses, and a resolver library
130 (routines for applications to use when interfacing with DNS). A DNS
131 server allows clients to name resources or objects and share the
132 information with other network machines. The named DNS server can be
133 used on workstations as a caching name server, but is generally only
134 needed on one machine for an entire network. Note that the
135 configuration files for making BIND act as a simple caching nameserver
136 are included in the caching-nameserver package.
137
138 Install the bind package if you need a DNS server for your network. If
139 you want bind to act a caching name server, you will also need to
140 install the caching-nameserver package.
141
142 %description -l de.UTF-8
143 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
144 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
145 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
146 Recher des Netzwerks erforderlich.
147
148 %description -l es.UTF-8
149 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
150 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
151 un servidor de nombres caché, pero generalmente sólo hace falta en una
152 máquina para toda la red.
153
154 %description -l fr.UTF-8
155 Contient le serveur de noms named, utilisé pour définir les
156 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
157 utilisé sur les stations de travail comme serveur de nom en cache mais
158 n'est souvent nécessaire que sur une machine pour un réseau entier.
159
160 %description -l pl.UTF-8
161 Pakiet ten zawiera demona named, który służy do zmieniania nazw
162 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
163 roboczych jako bufor odwołań do serwisu nazw (caching name server),
164 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
165 program na fragment sieci.
166
167 %description -l pt_BR.UTF-8
168 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
169 IP (e vice-versa). Pode ser usado em estações de trabalho como um
170 servidor de nomes cache, mas geralmente só é necessário em uma máquina
171 para toda a rede.
172
173 %description -l ru.UTF-8
174 BIND (Berkeley Internet Name Domain) является реализацией протоколов
175 DNS (Domain Name System). BIND включает DNS сервер (named) и
176 библиотеку "резолвера" (подпрограммы для приложений, через которые
177 происходят обращения к DNS). DNS сервер named может быть использован
178 на рабочих станциях как кеширующий сервер, но обычно запускается на
179 одной машине в локальной сети и используется остальными машинами (этим
180 достигается намного более эффективное кеширование).
181
182 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
183 кеширующего сервера, включены в пакет caching-nameserver.
184
185 %description -l tr.UTF-8
186 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
187 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
188 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
189 için sadece bir makina üzerinde kurulur.
190
191 %description -l uk.UTF-8
192 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
193 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
194 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
195 сервер named може бути використаний на робочих станціях як кешируючий
196 сервер, але звичайно запускається на одній машині в локальній мережі і
197 використовується іншими (цим досягається більша ефективність
198 використання кешу).
199
200 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
201 кешируючого серверу, включені в пакет caching-nameserver.
202
203 %package plugins
204 Summary:        Plugins for Bind DNS name server
205 Summary(pl.UTF-8):      Wtyczki dla serwera nazw DNS Bind
206 Group:          Networking/Utilities
207 Requires:       %{name} = %{epoch}:%{version}-%{release}
208
209 %description plugins
210 Plugins for extending of query processing functionality of Bind DNS name
211 server.
212
213 %description plugins -l pl.UTF-8
214 Wtyczki rozszerzające funkcjonalność przetwarzania zapytań przez serwer
215 nazw DNS Bind.
216
217 %package utils
218 Summary:        DNS utils - host, dig, dnsquery, nslookup
219 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
220 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
221 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
222 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
223 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
224 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
225 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
226 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
227 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
228 Group:          Networking/Utilities
229 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
230 Requires:       iconv
231
232 %description utils
233 Bind-utils contains a collection of utilities for querying DNS (Domain
234 Name Service) name servers to find out information about Internet
235 hosts. These tools will provide you with the IP addresses for given
236 host names, as well as other information about registered domains and
237 network addresses.
238
239 You should install bind-utils if you need to get information from DNS
240 name servers.
241
242 %description utils -l de.UTF-8
243 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
244 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
245 Informationen über registrierte Domains und Netzwerk-Adressen.
246
247 %description utils -l es.UTF-8
248 Conjunto de utilitarios para consulta a servidores de nombres. Estas
249 herramientas permiten la determinación de direcciones IP para nombres
250 de máquinas informados y busca información sobre dominios registrados
251 y direcciones de red.
252
253 %description utils -l fr.UTF-8
254 Ensemble d'utilitaires pour interroger les serveurs de noms et
255 rechercher des hôtes. Ces outils vous permettent de déterminer les
256 adresses IP pour des noms d'hôtes donnés, et trouver des informations
257 sur les noms de domaine déclarés et les adresses réseau.
258
259 %description utils -l pl.UTF-8
260 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
261 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
262 i ich adresach IP.
263
264 %description utils -l pt_BR.UTF-8
265 Conjunto de utilitários para consulta a servidores DNS. Estas
266 ferramentas permitem a determinação de endereços IP para nomes de
267 máquinas informados e busca informações sobre domínios registrados e
268 endereços de rede. Você deveria instalar este pacote se necessitar
269 obter informações de servidores DNS.
270
271 %description utils -l ru.UTF-8
272 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
273 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
274 доменному имени (и наоборот) и другую информацию о зарегистрированных
275 доменах и сетевых адресах.
276
277 %description utils -l tr.UTF-8
278 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
279 için kullanılan araçlar bulunmaktadır.
280
281 %description utils -l uk.UTF-8
282 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
283 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
284 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
285 домени та адреси.
286
287 %package libs
288 Summary:        DNS libraries
289 Summary(pl.UTF-8):      Biblioteki DNS
290 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
291 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
292 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
293 Group:          Libraries
294 Requires:       json-c >= 0.11
295 Requires:       libuv >= 1.37.0
296 Requires:       libxml2 >= 1:2.6.0
297 %{?with_doh:Requires:   nghttp2-libs >= 1.6.0}
298
299 %description libs
300 The bind-libs package contains all libraries required for running BIND
301 and bind utils.
302
303 %description libs -l pl.UTF-8
304 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
305 lub programów z pakietu bind-utils.
306
307 %description libs -l ru.UTF-8
308 Библиотеки, необходимые для работы bind.
309
310 %description libs -l uk.UTF-8
311 Бібліотеки, необхідні для роботи bind.
312
313 %package devel
314 Summary:        DNS development includes
315 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
316 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
317 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
318 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
319 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
320 Group:          Development/Libraries
321 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
322
323 %description devel
324 The bind-devel package contains all the include files and symlinks
325 required for DNS (Domain Name Service) development for BIND.
326
327 You should install bind-devel if you want to develop bind DNS
328 applications. If you install bind-devel, you'll also need to install
329 bind-libs.
330
331 %description devel -l es.UTF-8
332 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
333 para el bind.
334
335 %description devel -l pl.UTF-8
336 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
337 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
338 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
339 pakiet.
340
341 %description devel -l pt_BR.UTF-8
342 Todos os arquivos de cabeçalho e bibliotecas necessários para o
343 desenvolvimento com o bind.
344
345 %description devel -l ru.UTF-8
346 Все хедеры и библиотеки, необходимые для написания программ с
347 использованием BIND 9.x.x.
348
349 %description devel -l uk.UTF-8
350 Всі хедери та бібліотеки, необхідні для розробки програм з
351 використанням BIND 9.x.x.
352
353 %package static
354 Summary:        DNS static libs
355 Summary(pl.UTF-8):      Biblioteki statyczne DNS
356 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
357 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
358 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
359 Group:          Development/Libraries
360 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
361
362 %description static
363 Static bind libraries.
364
365 %description static -l pl.UTF-8
366 Statyczne biblioteki binda.
367
368 %description static -l pt_BR.UTF-8
369 Bibliotecas estáticas para desenvolvimento DNS.
370
371 %description static -l ru.UTF-8
372 Статические библиотеки, необходимые для написания программ с
373 использованием BIND.
374
375 %description static -l uk.UTF-8
376 Статичні бібліотеки, необхідні для розробки програм з використанням
377 BIND.
378
379 %prep
380 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
381
382 %patch3 -p1
383 %patch4 -p1
384 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
385 %{?with_edns_cli:%patch5 -p0}
386
387 %build
388 %{__libtoolize}
389 %{__aclocal}
390 %{__autoconf}
391 %{__automake}
392 %configure \
393         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
394         LDFLAGS="%{rpmldflags}" \
395         %{?with_dnstap:--enable-dnstap} \
396         %{!?with_doh:--disable-doh} \
397         %{!?with_epoll:--disable-epoll --disable-devpoll} \
398         --enable-full-report \
399         --enable-largefile \
400         %{?with_static_libs:--enable-static} \
401         %{?with_kerberos5:--with-gssapi} \
402         --with-jemalloc=yes \
403         --with-libidn2 \
404         --with-libxml2 \
405         %{?with_ssl:--with-openssl} \
406         %{?with_geoip:--with-maxminddb} \
407         --with-lmdb%{!?with_lmdb:=no} \
408         --with-tuning \
409         --disable-silent-rules
410
411 %{__make}
412 %{__make} -C doc/arm html
413
414 %{?with_hip:%{__make} -C bind-hip}
415
416 %if %{with tests}
417 %if %{with system_tests}
418 %{__make} test-force
419 %else
420 sh unit/unittest.sh
421 %endif
422 %endif
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
427         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
428         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
429         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
430
431 %{__make} install \
432         DESTDIR=$RPM_BUILD_ROOT
433
434 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
435 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
436 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
437 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
438
439 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
440 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
441 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
442 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
443 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
444 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
445 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
446 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
447
448 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
449 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
450 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
451 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
452
453 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
454
455 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
456 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
457
458 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
459
460 # we don't want Makefiles in documentation...
461 rm -rf _doc
462 cp -a doc _doc
463 %{__rm} _doc/misc/Makefile*
464
465 %clean
466 rm -rf $RPM_BUILD_ROOT
467
468 %pre
469 if [ -f %{_sysconfdir}/named.boot ]; then
470         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
471         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
472         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
473 fi
474 %groupadd -g 58 named
475 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
476
477 %post
478 /sbin/chkconfig --add named
479 %service named restart
480 %systemd_post named.service
481
482 %preun
483 if [ "$1" = "0" ]; then
484         %service named stop
485         /sbin/chkconfig --del named
486 fi
487 %systemd_preun named.service
488
489 %postun
490 if [ "$1" = "0" ]; then
491         %userremove named
492         %groupremove named
493 fi
494 %systemd_reload
495
496 %post   libs -p /sbin/ldconfig
497 %postun libs -p /sbin/ldconfig
498
499 %triggerpostun -- %{name} < 7:9.9.2.P2-2
500 %systemd_trigger named.service
501
502 %files
503 %defattr(644,root,root,755)
504 %doc README.md %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
505 %doc _doc/misc/* _doc/arm/_build/html/*.html
506
507 %{systemdunitdir}/named.service
508 %attr(754,root,root) /etc/rc.d/init.d/named
509 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
510 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
511 %{_sysconfdir}/named.conf
512 %{_sysconfdir}/bind.keys
513
514 %attr(755,root,root) %{_bindir}/dnssec-*
515 %attr(755,root,root) %{_bindir}/named-*
516 %attr(755,root,root) %{_bindir}/nsec3hash
517 %attr(755,root,root) %{_sbindir}/ddns-confgen
518 %attr(755,root,root) %{_sbindir}/named
519 %attr(755,root,root) %{_sbindir}/rndc
520 %attr(755,root,root) %{_sbindir}/rndc-confgen
521 %attr(755,root,root) %{_sbindir}/tsig-keygen
522
523 %{_mandir}/man1/dnssec-*.1*
524 %{_mandir}/man1/named-*.1*
525 %{_mandir}/man1/nsec3hash.1*
526 %{_mandir}/man5/named.conf.5*
527 %{_mandir}/man5/rndc.conf.5*
528 %{_mandir}/man8/ddns-confgen.8*
529 %{_mandir}/man8/named.8*
530 %{_mandir}/man8/rndc.8*
531 %{_mandir}/man8/rndc-confgen.8*
532 %{_mandir}/man8/tsig-keygen.8*
533 %lang(ja) %{_mandir}/ja/man8/named*
534
535 %{systemdtmpfilesdir}/%{name}.conf
536
537 %attr(770,root,named) %dir %{_var}/lib/named
538 %attr(770,root,named) %dir %{_var}/lib/named/D
539 %attr(770,root,named) %dir %{_var}/lib/named/M
540 %attr(770,root,named) %dir %{_var}/lib/named/S
541 %attr(770,root,named) %dir %{_var}/lib/named/dev
542 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
543 %attr(750,root,named) %dir %{_var}/lib/named/etc
544 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
545 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
546 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
547 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
548 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
549 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
550
551 %config(noreplace,missingok) %{_var}/log/named
552 %config(noreplace,missingok) %{_var}/log/named.stats
553
554 %attr(770,root,named) %dir %{_var}/run/named
555
556 %files plugins
557 %defattr(644,root,root,755)
558 %dir %{_libdir}/bind
559 %attr(755,root,root) %{_libdir}/bind/filter-a.so
560 %attr(755,root,root) %{_libdir}/bind/filter-aaaa.so
561 %{_mandir}/man8/filter-a.8*
562 %{_mandir}/man8/filter-aaaa.8*
563
564 %files utils
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_bindir}/arpaname
567 %attr(755,root,root) %{_bindir}/delv
568 %attr(755,root,root) %{_bindir}/dig
569 %attr(755,root,root) %{_bindir}/host
570 %attr(755,root,root) %{_bindir}/named-rrchecker
571 %attr(755,root,root) %{_bindir}/mdig
572 %attr(755,root,root) %{_bindir}/nslookup
573 %attr(755,root,root) %{_bindir}/nsupdate
574 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
575 %{_mandir}/man1/arpaname.1*
576 %{_mandir}/man1/delv.1*
577 %{_mandir}/man1/dig.1*
578 %{_mandir}/man1/host.1*
579 %{_mandir}/man1/mdig.1*
580 %{_mandir}/man1/named-rrchecker.1*
581 %{_mandir}/man1/nslookup.1*
582 %{_mandir}/man1/nsupdate.1*
583
584 %lang(fi) %{_mandir}/fi/man1/host.1*
585
586 %lang(fr) %{_mandir}/fr/man1/host.1*
587
588 %lang(hu) %{_mandir}/hu/man1/host.1*
589
590 %lang(ja) %{_mandir}/ja/man1/dig.1*
591 %lang(ja) %{_mandir}/ja/man1/host.1*
592 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
593 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
594
595 %lang(pl) %{_mandir}/pl/man1/host.1*
596
597 %files libs
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
600 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
601 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
602 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
603 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
604 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
605 %attr(755,root,root) %{_libdir}/libns-%{version}.so
606
607 %files devel
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/libbind9.so
610 %attr(755,root,root) %{_libdir}/libdns.so
611 %attr(755,root,root) %{_libdir}/libirs.so
612 %attr(755,root,root) %{_libdir}/libisc.so
613 %attr(755,root,root) %{_libdir}/libisccc.so
614 %attr(755,root,root) %{_libdir}/libisccfg.so
615 %attr(755,root,root) %{_libdir}/libns.so
616 %{_libdir}/libbind9.la
617 %{_libdir}/libdns.la
618 %{_libdir}/libirs.la
619 %{_libdir}/libisc.la
620 %{_libdir}/libisccc.la
621 %{_libdir}/libisccfg.la
622 %{_libdir}/libns.la
623 %{_includedir}/bind9
624 %{_includedir}/dns
625 %{_includedir}/dst
626 %{_includedir}/irs
627 %{_includedir}/isc
628 %{_includedir}/isccc
629 %{_includedir}/isccfg
630 %{_includedir}/ns
631
632 %if %{with static_libs}
633 %files static
634 %defattr(644,root,root,755)
635 %{_libdir}/libbind9.a
636 %{_libdir}/libdns.a
637 %{_libdir}/libirs.a
638 %{_libdir}/libisc.a
639 %{_libdir}/libisccc.a
640 %{_libdir}/libisccfg.a
641 %{_libdir}/libns.a
642 %endif
This page took 0.139358 seconds and 4 git commands to generate.