]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- Fixed URL, the old one seems to be dead.
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - mozilla extension?
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_without  apidocs         # don't build API documentation
10 %bcond_without  evolution       # don't include evolution support
11 %bcond_without  galago          # build without galago support
12 %bcond_without  gsf             # build without libgsf support
13 %bcond_without  gui             # don't build GNOME based GUI
14 %bcond_without  python          # don't build python libraries
15 %bcond_without  epiphany        # don't build epiphany extension
16 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
17 %bcond_with     thunderbird     # use Thunderbird backend
18 #
19 %if !%{with gui}
20 %undefine       with_evolution
21 %endif
22 #
23 Summary:        Beagle - An indexing subsystem
24 Summary(pl):    Beagle - podsystem indeksuj±cy
25 Name:           beagle
26 Version:        0.2.15.1
27 Release:        1
28 License:        Various
29 Group:          Libraries
30 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
31 # Source0-md5:  91fb5a499467b3ef468a5f003830c9fa
32 Patch0:         %{name}-desktop.patch
33 Patch1:         %{name}-crawl.patch
34 Patch2:         %{name}-kill_exec_a.patch
35 Patch3:         %{name}-configure.patch
36 URL:            http://beagle-project.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  chmlib-devel
40 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
41 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
42 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
43 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
44 #BuildRequires: dotnet-gst-sharp-devel
45 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
46 %if %{with epiphany} 
47 BuildRequires:  epiphany-devel >= 2.16.1
48 %endif
49 BuildRequires:  gtk+2-devel >= 2:2.10.6
50 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
51 BuildRequires:  libexif-devel >= 0.6.13
52 BuildRequires:  librsvg-devel >= 1:2.16.0
53 BuildRequires:  libpng-devel
54 BuildRequires:  libtool
55 BuildRequires:  libxml2-devel >= 1:2.6.26
56 BuildRequires:  mono-csharp >= 1.1.18
57 # not used atm
58 #BuildRequires: mozilla-devel
59 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.10.3}
60 BuildRequires:  pkgconfig
61 BuildRequires:  perl-XML-Parser
62 BuildRequires:  python-devel
63 %if %{with sqlite3}
64 BuildRequires:  sqlite3-devel >= 3.3.4
65 %else
66 BuildRequires:  sqlite-devel
67 %endif
68 BuildRequires:  wv-devel >= 1.2.4
69 BuildRequires:  xorg-lib-libXScrnSaver-devel
70 BuildRequires:  zip
71 # GUI BRs
72 %if %{with gui}
73 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
74 BuildRequires:  gnome-vfs2-devel >= 2.16.1
75 %endif
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       dotnet-gmime-sharp >= 2.2.3
78 %if %{with sqlite3}
79 Requires:       sqlite3
80 %else
81 Requires:       sqlite
82 %endif
83 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
84 ExcludeArch:    i386
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %description
88 Beagle is an indexing sub-system and search aggregator built on top of
89 Lucene.Net.
90
91 %description -l pl
92 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
93 bazie Lucene.Net.
94
95 %package libs
96 Summary:        Beagle libraries
97 Summary(pl):    Bibiloteki Beagle
98 Group:          Libraries
99
100 %description libs
101 Beagle libraries.
102
103 %description libs -l pl
104 Bibiloteki Beagle.
105
106 %package devel
107 Summary:        Beagle development files
108 Summary(pl):    Pliki programistyczne Beagle
109 Group:          Development/Libraries
110 Requires:       %{name}-libs = %{version}-%{release}
111
112 %description devel
113 Beagle development files.
114
115 %description devel -l pl
116 Pliki programistyczne Beagle.
117
118 %package static
119 Summary:        Beagle static libraries
120 Summary(pl):    Statyczne biblioteki Beagle
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description static
125 Beagle static libraries.
126
127 %description static -l pl
128 Statyczne biblioteki Beagle.
129
130 %package apidocs
131 Summary:        libbeagle API documentation
132 Summary(pl):    Dokumentacja API libbeagle
133 Group:          Documentation
134 Requires:       gtk-doc-common
135
136 %description apidocs
137 libbeagle API documentation.
138
139 %description apidocs -l pl
140 Dokumentacja API libbeagle.
141
142 %package crawl-system
143 Summary:        Beagle crawl system
144 Summary(pl):    System przeszukuj±cy beagle-crawl
145 Group:          Applications/System
146 Requires:       crondaemon
147 Provides:       group(beagleindex)
148 Provides:       user(beagleindex)
149
150 %description crawl-system
151 Beagle crawl system.
152
153 %description crawl-system -l pl
154 System przeszukuj±cy beagle-crawl.
155
156 %package evolution
157 Summary:        Beagle Evolution backend
158 Summary(pl):    Backend Beagle dla Evolution
159 Group:          X11/Applications/Networking
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       dotnet-evolution-sharp >= 0.11.1
162 Requires:       evolution >= 2.8.0
163
164 %description evolution
165 Beagle Evolution backend.
166
167 %description evolution -l pl
168 Backend Beagle dla Evolution.
169
170 %package thunderbird
171 Summary:        Beagle Mozilla Thunderbird backend
172 Summary(pl):    Backend Beagle dla Mozilli Thunderbird
173 Group:          X11/Applications/Networking
174 Requires:       %{name} = %{version}-%{release}
175
176 %description thunderbird
177 Beagle Mozilla Thunderbird backend.
178
179 %description thunderbird -l pl
180 Backend Beagle dla Mozilli Thunderbird.
181
182 %package -n epiphany-extension-beagle
183 Summary:        Epiphany extension - beagle
184 Summary(pl):    Rozszerzenie dla Epiphany - beagle
185 Group:          X11/Applications/Networking
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       epiphany-extensions >= 2.16.1
188
189 %description -n epiphany-extension-beagle
190 Epiphany extension that allows Beagle to index every page the user
191 views.
192
193 %description -n epiphany-extension-beagle -l pl
194 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
195 odwiedzan± stronê.
196
197 %package -n python-%{name}
198 Summary:        Beagle Python bindings
199 Summary(pl):    Wi±zania jêzyka Python dla Beagle
200 Group:          Libraries/Python
201 Requires:       %{name} = %{version}-%{release}
202 %pyrequires_eq  python-libs
203
204 %description -n python-%{name}
205 Beagle Python bindings.
206
207 %description -n python-%{name} -l pl
208 Wi±zania jêzyka Python dla Beagle.
209
210 %package search-gui
211 Summary:        GNOME based Beagle GUI
212 Summary(pl):    Oparty na GNOME graficzny interfejs dla Beagle
213 Group:          Libraries/Python
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       gtk+2 >= 2:2.10.6
216
217 %description search-gui
218 GNOME based Beagle GUI.
219
220 %description search-gui -l pl
221 Oparty na GNOME graficzny interfejs dla Beagle.
222
223 %package startup
224 Summary:        Automatic startup integration for Beagle
225 Summary(pl):    Integracja funkcji automatycznego startu Beagle
226 Group:          X11/Applications
227 Requires:       %{name} = %{version}-%{release}
228 Obsoletes:      beagle-gnome
229
230 %description startup
231 Automatic session startup integration for Beagle.
232
233 %description startup -l pl
234 Integracja funkcji automatycznego startu Beagle.
235
236 %prep
237 %setup -q
238 %patch0 -p1
239 %patch1 -p1
240 %patch2 -p1
241 %patch3 -p1
242
243 %build
244 %{__libtoolize}
245 %{__aclocal}
246 %{__autoconf}
247 %{__automake}
248 %configure \
249         --enable-static \
250         %{?with_apidocs:--enable-gtk-doc} \
251         --with-html-dir=%{_gtkdocdir} \
252         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
253         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
254         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
255         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird
256
257 %{__make} \
258         MOZILLA_HOME=%{_libdir}/mozilla \
259         pythondir=%{py_sitedir}
260
261 %install
262 rm -rf $RPM_BUILD_ROOT
263 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
264
265 %{__make} install \
266         DESTDIR=$RPM_BUILD_ROOT \
267         pythondir=%{py_sitedir}
268
269 # Kill useless files
270 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.16/extensions/*.{la,a} \
271         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
272
273 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
274 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
275
276 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
277
278 %find_lang %{name}
279
280 %clean
281 rm -rf $RPM_BUILD_ROOT
282
283 %pre crawl-system
284 %groupadd -g 166 -r -f beagleindex
285 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
286
287 %postun crawl-system
288 if [ "$1" = "0" ]; then
289         %userremove beagleindex
290         %groupremove beagleindex
291 fi
292
293 %post   libs -p /sbin/ldconfig
294 %postun libs -p /sbin/ldconfig
295
296 %files -f %{name}.lang
297 %defattr(644,root,root,755)
298 %doc AUTHORS COPYING ChangeLog NEWS README
299 %attr(755,root,root) %{_bindir}/beagle-config
300 %attr(755,root,root) %{_bindir}/beagled
301 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
302 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
303 %attr(755,root,root) %{_bindir}/beagle-extract-content
304 %attr(755,root,root) %{_bindir}/beagle-index-info
305 %attr(755,root,root) %{_bindir}/beagle-index-url
306 %attr(755,root,root) %{_bindir}/beagle-info
307 %attr(755,root,root) %{_bindir}/beagle-ping
308 %attr(755,root,root) %{_bindir}/beagle-query
309 %attr(755,root,root) %{_bindir}/beagle-shutdown
310 %attr(755,root,root) %{_bindir}/beagle-status
311 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
312 %attr(755,root,root) %{_libdir}/%{name}/*.exe
313 %dir %{_libdir}/%{name}
314 %dir %{_libdir}/%{name}/Backends
315 %dir %{_libdir}/%{name}/Filters
316 %{_libdir}/%{name}/*.dll
317 %{_libdir}/%{name}/*.dll.config
318 %{_libdir}/%{name}/Filters/*.dll
319 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
320 %{_mandir}/man*/*
321
322 %files libs
323 %defattr(644,root,root,755)
324 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
325
326 %files devel
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{_libdir}/*.so
329 %{_includedir}/libbeagle
330 %{_libdir}/*.la
331 %{_pkgconfigdir}/*
332
333 %files static
334 %defattr(644,root,root,755)
335 %{_libdir}/*.a
336
337 %if %{with apidocs}
338 %files apidocs
339 %defattr(644,root,root,755)
340 %{_gtkdocdir}/beagle
341 %endif
342
343 %files crawl-system
344 %defattr(644,root,root,755)
345 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
346 %dir %{_sysconfdir}/beagle
347 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
348 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
349 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
350 %attr(755,root,root) %{_sbindir}/*
351
352 %if %{with evolution}
353 %files evolution
354 %defattr(644,root,root,755)
355 %{_libdir}/%{name}/Backends/Evolution*.dll
356 %endif
357
358 %if %{with thunderbird}
359 %files thunderbird
360 %defattr(644,root,root,755)
361 %attr(755,root,root) %{_bindir}/beagle-contactviewer
362 %{_libdir}/%{name}/Backends/Thunderbird*.dll
363 %endif
364
365 %if %{with epiphany}
366 %files -n epiphany-extension-beagle
367 %defattr(644,root,root,755)
368 %doc epiphany-extension/README
369 %attr(755,root,root) %{_libdir}/epiphany/2.16/extensions/libbeagleextension.so*
370 %{_libdir}/epiphany/2.16/extensions/*.xml
371 %endif
372
373 %if %{with python}
374 %files -n python-%{name}
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{py_sitedir}/*.so
377 %endif
378
379 %if %{with gui}
380 %files search-gui
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
383 %attr(755,root,root) %{_bindir}/beagle-search
384 %attr(755,root,root) %{_bindir}/beagle-settings
385 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
386 %{_pixmapsdir}/*.png
387 %{_desktopdir}/*.desktop
388 %endif
389
390 %files startup
391 %defattr(644,root,root,755)
392 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
393 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
This page took 0.110293 seconds and 4 git commands to generate.