]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- 0.2.8, gtk-sharp patch included in sources, added thunderbird backend,
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.8
25 Release:        1
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  477e34538776ca2f4da8f3404edf28dd
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-kill_exec_a.patch
33 Patch3:         %{name}-configure.patch
34 Patch4:         %{name}-galago05.patch
35 URL:            http://beaglewiki.org/Main_Page
36 BuildRequires:  autoconf >= 2.52
37 BuildRequires:  automake
38 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
39 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
40 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
41 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
42 #BuildRequires: dotnet-gst-sharp-devel
43 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.9.0
44 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.15.3}
45 BuildRequires:  gtk+2-devel >= 2:2.9.4
46 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
47 BuildRequires:  libexif-devel >= 0.6.13
48 BuildRequires:  librsvg-devel >= 1:2.15.90
49 BuildRequires:  libpng-devel
50 BuildRequires:  libtool
51 BuildRequires:  libxml2-devel >= 1:2.6.26
52 BuildRequires:  mono-csharp >= 1.1.16.1
53 # not used atm
54 #BuildRequires: mozilla-devel
55 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.9.6}
56 BuildRequires:  pkgconfig
57 BuildRequires:  perl-XML-Parser
58 BuildRequires:  python-devel
59 %if %{with sqlite3}
60 BuildRequires:  sqlite3-devel >= 3.3.4
61 %else
62 BuildRequires:  sqlite-devel
63 %endif
64 BuildRequires:  wv-devel >= 1.2.1
65 BuildRequires:  xorg-lib-libXScrnSaver-devel
66 BuildRequires:  zip
67 # GUI BRs
68 %if %{with gui}
69 BuildRequires:  dotnet-gnome-sharp-devel >= 2.15.0
70 BuildRequires:  gnome-vfs2-devel >= 2.15.91
71 %endif
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       dotnet-gmime-sharp >= 2.2.3
74 %if %{with sqlite3}
75 Requires:       sqlite3
76 %else
77 Requires:       sqlite
78 %endif
79 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
80 ExcludeArch:    i386
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 Beagle is an indexing sub-system and search aggregator built on top of
85 Lucene.Net.
86
87 %description -l pl
88 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
89 bazie Lucene.Net.
90
91 %package libs
92 Summary:        Beagle libraries
93 Summary(pl):    Bibiloteki Beagle
94 Group:          Libraries
95
96 %description libs
97 Beagle libraries.
98
99 %description libs -l pl
100 Bibiloteki Beagle.
101
102 %package devel
103 Summary:        Beagle development files
104 Summary(pl):    Pliki programistyczne Beagle
105 Group:          Development/Libraries
106 Requires:       %{name}-libs = %{version}-%{release}
107
108 %description devel
109 Beagle development files.
110
111 %description devel -l pl
112 Pliki programistyczne Beagle.
113
114 %package static
115 Summary:        Beagle static libraries
116 Summary(pl):    Statyczne biblioteki Beagle
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119
120 %description static
121 Beagle static libraries.
122
123 %description static -l pl
124 Statyczne biblioteki Beagle.
125
126 %package apidocs
127 Summary:        libbeagle API documentation
128 Summary(pl):    Dokumentacja API libbeagle
129 Group:          Documentation
130 Requires:       gtk-doc-common
131
132 %description apidocs
133 libbeagle API documentation.
134
135 %description apidocs -l pl
136 Dokumentacja API libbeagle.
137
138 %package crawl-system
139 Summary:        Beagle crawl system
140 Summary(pl):    System przeszukuj±cy beagle-crawl
141 Group:          Applications/System
142 Requires:       crondaemon
143 Provides:       group(beagleindex)
144 Provides:       user(beagleindex)
145
146 %description crawl-system
147 Beagle crawl system.
148
149 %description crawl-system -l pl
150 System przeszukuj±cy beagle-crawl.
151
152 %package evolution
153 Summary:        Beagle Evolution backend
154 Summary(pl):    Backend Beagle dla Evolution
155 Group:          X11/Applications/Networking
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       dotnet-evolution-sharp >= 0.11.1
158 Requires:       evolution >= 2.7.3
159
160 %description
161 Beagle Evolution backend.
162
163 %description evolution -l pl
164 Backend Beagle dla Evolution.
165
166 %package thunderbird
167 Summary:        Beagle Mozilla Thunderbird backend
168 Summary(pl):    Backend Beagle dla Mozilli Thunderbird
169 Group:          X11/Applications/Networking
170 Requires:       %{name} = %{version}-%{release}
171
172 %description thunderbird
173 Beagle Mozilla Thunderbird backend.
174
175 %description thunderbird -l pl
176 Backend Beagle dla Mozilli Thunderbird.
177
178 %package -n epiphany-extension-beagle
179 Summary:        Epiphany extension - beagle
180 Summary(pl):    Rozszerzenie dla Epiphany - beagle
181 Group:          X11/Applications/Networking
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       epiphany-extensions >= 2.15.1
184
185 %description -n epiphany-extension-beagle
186 Epiphany extension that allows Beagle to index every page the user
187 views.
188
189 %description -n epiphany-extension-beagle -l pl
190 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
191 odwiedzan± stronê.
192
193 %package -n python-%{name}
194 Summary:        Beagle Python bindings
195 Summary(pl):    Wi±zania jêzyka Python dla Beagle
196 Group:          Libraries/Python
197 Requires:       %{name} = %{version}-%{release}
198 %pyrequires_eq  python-libs
199
200 %description -n python-%{name}
201 Beagle Python bindings.
202
203 %description -n python-%{name} -l pl
204 Wi±zania jêzyka Python dla Beagle.
205
206 %package search-gui
207 Summary:        GNOME based Beagle GUI
208 Summary(pl):    Bazowane na GNOME GUI dla Beagle
209 Group:          Libraries/Python
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       gtk+2 >= 2:2.10.1
212
213 %description search-gui
214 GNOME based Beagle GUI.
215
216 %description search-gui -l pl
217 Bazowane na GNOME GUI dla Beagle.
218
219 %prep
220 %setup -q
221 %patch0 -p1
222 %patch1 -p1
223 %patch2 -p1
224 %patch3 -p1
225 %patch4 -p1
226
227 %build
228 %{__libtoolize}
229 %{__aclocal}
230 %{__autoconf}
231 %{__automake}
232 %configure \
233         --enable-static \
234         %{?with_apidocs:--enable-gtk-doc} \
235         --with-html-dir=%{_gtkdocdir} \
236         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
237         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
238         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
239
240 %{__make} \
241         MOZILLA_HOME=%{_libdir}/mozilla \
242         pythondir=%{py_sitedir}
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
247
248 %{__make} install \
249         DESTDIR=$RPM_BUILD_ROOT \
250         pythondir=%{py_sitedir}
251
252 # Kill useless files
253 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
254         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
255
256 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
257 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
258
259 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
260
261 %find_lang %{name}
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %pre crawl-system
267 %groupadd -g 166 -r -f beagleindex
268 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
269
270 %postun crawl-system
271 if [ "$1" = "0" ]; then
272         %userremove beagleindex
273         %groupremove beagleindex
274 fi
275
276 %post   libs -p /sbin/ldconfig
277 %postun libs -p /sbin/ldconfig
278
279 %files -f %{name}.lang
280 %defattr(644,root,root,755)
281 %doc AUTHORS COPYING ChangeLog NEWS README
282 %attr(755,root,root) %{_bindir}/beagle-config
283 %attr(755,root,root) %{_bindir}/beagled
284 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
285 %attr(755,root,root) %{_bindir}/beagle-extract-content
286 %attr(755,root,root) %{_bindir}/beagle-index-info
287 %attr(755,root,root) %{_bindir}/beagle-index-url
288 %attr(755,root,root) %{_bindir}/beagle-info
289 %attr(755,root,root) %{_bindir}/beagle-ping
290 %attr(755,root,root) %{_bindir}/beagle-query
291 %attr(755,root,root) %{_bindir}/beagle-shutdown
292 %attr(755,root,root) %{_bindir}/beagle-status
293 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
294 %attr(755,root,root) %{_libdir}/%{name}/*.exe
295 %dir %{_libdir}/%{name}
296 %dir %{_libdir}/%{name}/Backends
297 %{_libdir}/%{name}/Filters
298 %{_libdir}/%{name}/*.dll*
299 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
300 %{_mandir}/man*/*
301
302 %files libs
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
305
306 %files devel
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_libdir}/*.so
309 %{_includedir}/libbeagle
310 %{_libdir}/*.la
311 %{_pkgconfigdir}/*
312
313 %files static
314 %defattr(644,root,root,755)
315 %{_libdir}/*.a
316
317 %if %{with apidocs}
318 %files apidocs
319 %defattr(644,root,root,755)
320 %{_gtkdocdir}/beagle
321 %endif
322
323 %files crawl-system
324 %defattr(644,root,root,755)
325 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
326 %dir %{_sysconfdir}/beagle
327 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
328 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
329 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
330 %attr(755,root,root) %{_sbindir}/*
331
332 %if %{with evolution}
333 %files evolution
334 %defattr(644,root,root,755)
335 %{_libdir}/%{name}/Backends/Evolution*.dll
336 %endif
337
338 %files thunderbird
339 %defattr(644,root,root,755)
340 %{_libdir}/%{name}/Backends/Thunderbird*.dll
341
342 %if %{with epiphany}
343 %files -n epiphany-extension-beagle
344 %defattr(644,root,root,755)
345 %doc epiphany-extension/README
346 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
347 %{_libdir}/epiphany/1.8/extensions/*.xml
348 %endif
349
350 %if %{with python}
351 %files -n python-%{name}
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{py_sitedir}/*.so
354 %endif
355
356 %if %{with gui}
357 %files search-gui
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_bindir}/beagle-contactviewer
360 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
361 %attr(755,root,root) %{_bindir}/beagle-search
362 %attr(755,root,root) %{_bindir}/beagle-settings
363 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
364 %{_pixmapsdir}/*.png
365 %{_desktopdir}/*.desktop
366 %endif
This page took 0.102957 seconds and 4 git commands to generate.