]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- sr@Latn -> sr@latin, rel. 3
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - mozilla extension?
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_without  apidocs         # don't build API documentation
10 %bcond_without  evolution       # don't include evolution support
11 %bcond_without  galago          # build without galago support
12 %bcond_without  gsf             # build without libgsf support
13 %bcond_without  gui             # don't build GNOME based GUI
14 %bcond_without  python          # don't build python libraries
15 %bcond_without  epiphany        # don't build epiphany extension
16 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
17 %bcond_with     thunderbird     # use Thunderbird backend
18 #
19 %if !%{with gui}
20 %undefine       with_evolution
21 %endif
22 #
23 Summary:        Beagle - An indexing subsystem
24 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
25 Name:           beagle
26 Version:        0.2.18
27 Release:        3
28 License:        Various
29 Group:          Libraries
30 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
31 # Source0-md5:  8bab6ce40fff497120dbfcfd0a789c65
32 Patch0:         %{name}-desktop.patch
33 Patch1:         %{name}-crawl.patch
34 Patch3:         %{name}-configure.patch
35 Patch4:         %{name}-epiphany-2.20.patch
36 URL:            http://beagle-project.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  chmlib-devel
40 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.13.3}
41 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
42 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
43 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
44 #BuildRequires: dotnet-gst-sharp-devel
45 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
46 %if %{with epiphany}
47 BuildRequires:  epiphany-devel >= 2.20.0
48 %endif
49 BuildRequires:  gtk+2-devel >= 2:2.10.10
50 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
51 BuildRequires:  libexif-devel >= 0.6.13
52 BuildRequires:  libpng-devel
53 BuildRequires:  librsvg-devel >= 1:2.16.1
54 BuildRequires:  libtool
55 BuildRequires:  libxml2-devel >= 1:2.6.27
56 BuildRequires:  mono-csharp >= 1.1.13.5
57 BuildRequires:  perl-XML-Parser
58 BuildRequires:  pkgconfig
59 BuildRequires:  python-devel
60 %{?with_python:BuildRequires:   python-pygtk-devel >= 2:2.10.4}
61 %if %{with sqlite3}
62 BuildRequires:  sqlite3-devel >= 3.3.4
63 %else
64 BuildRequires:  sqlite-devel
65 %endif
66 BuildRequires:  wv-devel >= 1.2.4
67 BuildRequires:  xorg-lib-libXScrnSaver-devel
68 BuildRequires:  zip
69 # GUI BRs
70 %if %{with gui}
71 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
72 BuildRequires:  gnome-vfs2-devel >= 2.18.0.1
73 %endif
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       dotnet-gmime-sharp >= 2.2.3
76 Requires:       dotnet-gsf-sharp
77 %if %{with sqlite3}
78 Requires:       sqlite3
79 %else
80 Requires:       sqlite
81 %endif
82 # sr@Latn vs. sr@latin
83 Conflicts:      glibc-misc < 6:2.7
84 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
85 ExcludeArch:    i386
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %description
89 Beagle is an indexing sub-system and search aggregator built on top of
90 Lucene.Net.
91
92 %description -l pl.UTF-8
93 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
94 bazie Lucene.Net.
95
96 %package libs
97 Summary:        Beagle libraries
98 Summary(pl.UTF-8):      Bibiloteki Beagle
99 Group:          Libraries
100
101 %description libs
102 Beagle libraries.
103
104 %description libs -l pl.UTF-8
105 Bibiloteki Beagle.
106
107 %package devel
108 Summary:        Beagle development files
109 Summary(pl.UTF-8):      Pliki programistyczne Beagle
110 Group:          Development/Libraries
111 Requires:       %{name}-libs = %{version}-%{release}
112
113 %description devel
114 Beagle development files.
115
116 %description devel -l pl.UTF-8
117 Pliki programistyczne Beagle.
118
119 %package static
120 Summary:        Beagle static libraries
121 Summary(pl.UTF-8):      Statyczne biblioteki Beagle
122 Group:          Development/Libraries
123 Requires:       %{name}-devel = %{version}-%{release}
124
125 %description static
126 Beagle static libraries.
127
128 %description static -l pl.UTF-8
129 Statyczne biblioteki Beagle.
130
131 %package apidocs
132 Summary:        libbeagle API documentation
133 Summary(pl.UTF-8):      Dokumentacja API libbeagle
134 Group:          Documentation
135 Requires:       gtk-doc-common
136
137 %description apidocs
138 libbeagle API documentation.
139
140 %description apidocs -l pl.UTF-8
141 Dokumentacja API libbeagle.
142
143 %package crawl-system
144 Summary:        Beagle crawl system
145 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
146 Group:          Applications/System
147 Requires:       crondaemon
148 Provides:       group(beagleindex)
149 Provides:       user(beagleindex)
150
151 %description crawl-system
152 Beagle crawl system.
153
154 %description crawl-system -l pl.UTF-8
155 System przeszukujący beagle-crawl.
156
157 %package evolution
158 Summary:        Beagle Evolution backend
159 Summary(pl.UTF-8):      Backend Beagle dla Evolution
160 Group:          X11/Applications/Networking
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       dotnet-evolution-sharp >= 0.11.1
163 Requires:       evolution >= 2.10.0
164
165 %description evolution
166 Beagle Evolution backend.
167
168 %description evolution -l pl.UTF-8
169 Backend Beagle dla Evolution.
170
171 %package thunderbird
172 Summary:        Beagle Mozilla Thunderbird backend
173 Summary(pl.UTF-8):      Backend Beagle dla Mozilli Thunderbird
174 Group:          X11/Applications/Networking
175 Requires:       %{name} = %{version}-%{release}
176
177 %description thunderbird
178 Beagle Mozilla Thunderbird backend.
179
180 %description thunderbird -l pl.UTF-8
181 Backend Beagle dla Mozilli Thunderbird.
182
183 %package -n mozilla-firefox-extension-beagle
184 Summary:        Mozilla Firefox extension - beagle
185 Summary(pl.UTF-8):      Rozszerzenie dla Mozilla Firefox - beagle
186 Group:          X11/Applications/Networking
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       mozilla-firefox >= 2.0.0.1-2
189
190 %description -n mozilla-firefox-extension-beagle
191 Mozilla Firefox extension that allows Beagle to index every page the
192 user views.
193
194 %description -n mozilla-firefox-extension-beagle -l pl.UTF-8
195 Rozszerzenie dla Mozilla Firefox sprawiające, że Beagle indeksuje
196 każdą odwiedzaną stronę.
197
198 %package -n epiphany-extension-beagle
199 Summary:        Epiphany extension - beagle
200 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
201 Group:          X11/Applications/Networking
202 Requires:       %{name} = %{version}-%{release}
203 Requires:       epiphany-extensions >= 2.20.0
204
205 %description -n epiphany-extension-beagle
206 Epiphany extension that allows Beagle to index every page the user
207 views.
208
209 %description -n epiphany-extension-beagle -l pl.UTF-8
210 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
211 odwiedzaną stronę.
212
213 %package -n python-%{name}
214 Summary:        Beagle Python bindings
215 Summary(pl.UTF-8):      Wiązania języka Python dla Beagle
216 Group:          Libraries/Python
217 Requires:       %{name} = %{version}-%{release}
218 %pyrequires_eq  python-libs
219
220 %description -n python-%{name}
221 Beagle Python bindings.
222
223 %description -n python-%{name} -l pl.UTF-8
224 Wiązania języka Python dla Beagle.
225
226 %package search-gui
227 Summary:        GNOME based Beagle GUI
228 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
229 Group:          Libraries/Python
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       gtk+2 >= 2:2.10.10
232
233 %description search-gui
234 GNOME based Beagle GUI.
235
236 %description search-gui -l pl.UTF-8
237 Oparty na GNOME graficzny interfejs dla Beagle.
238
239 %package startup
240 Summary:        Automatic startup integration for Beagle
241 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
242 Group:          X11/Applications
243 Requires:       %{name} = %{version}-%{release}
244 Obsoletes:      beagle-gnome
245
246 %description startup
247 Automatic session startup integration for Beagle.
248
249 %description startup -l pl.UTF-8
250 Integracja funkcji automatycznego startu Beagle.
251
252 %prep
253 %setup -q
254 %patch0 -p1
255 %patch1 -p1
256 %patch3 -p1
257 %patch4 -p1
258
259 %build
260 %{__intltoolize}
261 %{__libtoolize}
262 %{__aclocal}
263 %{__autoconf}
264 %{__automake}
265 %configure \
266         --enable-static \
267         %{?with_apidocs:--enable-gtk-doc} \
268         --with-html-dir=%{_gtkdocdir} \
269         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
270         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
271         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
272         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird
273
274 %{__make} \
275         MOZILLA_HOME=%{_libdir}/mozilla \
276         pythondir=%{py_sitedir}
277
278 %install
279 rm -rf $RPM_BUILD_ROOT
280 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
281
282 %{__make} install \
283         DESTDIR=$RPM_BUILD_ROOT \
284         pythondir=%{py_sitedir}
285
286 dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
287 install -d $dest $dest/chrome
288 install mozilla-extension/{chrome.manifest,install.rdf} $dest
289 install mozilla-extension/chrome/beagle.jar $dest/chrome
290
291 # Kill useless files
292 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.20/extensions/*.{la,a} \
293         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
294
295 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
296 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
297
298 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
299
300 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
301         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
302 %find_lang %{name}
303
304 %clean
305 rm -rf $RPM_BUILD_ROOT
306
307 %pre crawl-system
308 %groupadd -g 166 -r -f beagleindex
309 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
310
311 %postun crawl-system
312 if [ "$1" = "0" ]; then
313         %userremove beagleindex
314         %groupremove beagleindex
315 fi
316
317 %post   libs -p /sbin/ldconfig
318 %postun libs -p /sbin/ldconfig
319
320 %files -f %{name}.lang
321 %defattr(644,root,root,755)
322 %doc AUTHORS COPYING ChangeLog NEWS README
323 %attr(755,root,root) %{_bindir}/beagle-config
324 %attr(755,root,root) %{_bindir}/beagled
325 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
326 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
327 %attr(755,root,root) %{_bindir}/beagle-extract-content
328 %attr(755,root,root) %{_bindir}/beagle-index-info
329 %attr(755,root,root) %{_bindir}/beagle-index-url
330 %attr(755,root,root) %{_bindir}/beagle-info
331 %attr(755,root,root) %{_bindir}/beagle-ping
332 %attr(755,root,root) %{_bindir}/beagle-query
333 %attr(755,root,root) %{_bindir}/beagle-shutdown
334 %attr(755,root,root) %{_bindir}/beagle-status
335 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
336 %attr(755,root,root) %{_libdir}/%{name}/*.exe
337 %dir %{_libdir}/%{name}
338 %dir %{_libdir}/%{name}/Backends
339 %dir %{_libdir}/%{name}/Filters
340 %{_libdir}/%{name}/*.dll
341 %{_libdir}/%{name}/*.dll.config
342 %{_libdir}/%{name}/Filters/*.dll
343 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
344 %{_mandir}/man*/*
345
346 %files libs
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
349
350 %files devel
351 %defattr(644,root,root,755)
352 %attr(755,root,root) %{_libdir}/*.so
353 %{_includedir}/libbeagle
354 %{_libdir}/*.la
355 %{_pkgconfigdir}/*
356
357 %files static
358 %defattr(644,root,root,755)
359 %{_libdir}/*.a
360
361 %if %{with apidocs}
362 %files apidocs
363 %defattr(644,root,root,755)
364 %{_gtkdocdir}/beagle
365 %endif
366
367 %files crawl-system
368 %defattr(644,root,root,755)
369 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
370 %dir %{_sysconfdir}/beagle
371 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
372 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
373 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
374 %attr(755,root,root) %{_sbindir}/*
375
376 %if %{with evolution}
377 %files evolution
378 %defattr(644,root,root,755)
379 %{_libdir}/%{name}/Backends/Evolution*.dll
380 %endif
381
382 %if %{with thunderbird}
383 %files thunderbird
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_bindir}/beagle-contactviewer
386 %{_libdir}/%{name}/Backends/Thunderbird*.dll
387 %endif
388
389 %files -n mozilla-firefox-extension-beagle
390 %defattr(644,root,root,755)
391 %{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
392
393 %if %{with epiphany}
394 %files -n epiphany-extension-beagle
395 %defattr(644,root,root,755)
396 %doc epiphany-extension/README
397 %attr(755,root,root) %{_libdir}/epiphany/2.20/extensions/libbeagleextension.so*
398 %{_libdir}/epiphany/2.20/extensions/*.xml
399 %endif
400
401 %if %{with python}
402 %files -n python-%{name}
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{py_sitedir}/*.so
405 %endif
406
407 %if %{with gui}
408 %files search-gui
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
411 %attr(755,root,root) %{_bindir}/beagle-search
412 %attr(755,root,root) %{_bindir}/beagle-settings
413 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
414 %{_pixmapsdir}/*.png
415 %{_desktopdir}/*.desktop
416 %endif
417
418 %files startup
419 %defattr(644,root,root,755)
420 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
421 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
This page took 0.057209 seconds and 4 git commands to generate.