]> git.pld-linux.org Git - SPECS.git/blob - beagle.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - add qyoto based settings (requires new packages)
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # don't build API documentation
8 %bcond_with     avahi           # enable Avahi support
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 # required epiphany with python support (2009.06.06 removed permanently from epiphany)
14 %bcond_with     epiphany        # don't build epiphany extension
15 %bcond_without  thunderbird     # use Thunderbird backend
16 #
17 %if !%{with gui}
18 %undefine       with_evolution
19 %endif
20
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
23 Name:           beagle
24 Version:        0.3.9
25 Release:        7
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/GNOME/sources/beagle/0.3/%{name}-%{version}.tar.bz2
29 # Source0-md5:  b73c12423d2d67133dbb05933f4c8fe1
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-configure.patch
33 Patch3:         %{name}-use-xdg-open.patch
34 Patch4:         %{name}-epiphany.patch
35 Patch5:         %{name}-gmime-2.4.patch
36 Patch6:         %{name}-sqlite.patch
37 Patch7:         %{name}-mono28.patch
38 URL:            http://beagle-project.org/Main_Page
39 BuildRequires:  autoconf >= 2.52
40 BuildRequires:  automake
41 BuildRequires:  chmlib-devel
42 %{?with_avahi:BuildRequires:    dotnet-avahi-devel >= 0.6.10}
43 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.13.3}
44 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
45 BuildRequires:  dotnet-gmime-sharp-devel >= 2.3.5
46 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
47 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
48 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3.0
49 BuildRequires:  dotnet-ndesk-dbus-sharp-devel >= 0.6.0
50 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.22.0}
51 BuildRequires:  gettext-tools
52 BuildRequires:  intltool >= 0.40.0
53 BuildRequires:  libtool
54 BuildRequires:  mono-csharp >= 1.2.4
55 BuildRequires:  mono-devel >= 1.2.4
56 BuildRequires:  pkgconfig
57 BuildRequires:  sqlite3-devel >= 3.3.9
58 BuildRequires:  taglib-sharp-devel
59 BuildRequires:  wv-devel >= 1.2.4
60 BuildRequires:  xorg-lib-libXScrnSaver-devel
61 BuildRequires:  zip
62 # GUI BRs
63 %if %{with gui}
64 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
65 BuildRequires:  gtk+2-devel >= 2:2.10.10
66 BuildRequires:  librsvg-devel >= 1:2.16.1
67 BuildRequires:  rpm-pythonprov
68 %endif
69 Requires:       dotnet-gmime-sharp >= 2.3.5
70 Requires:       dotnet-gsf-sharp
71 Requires:       shared-mime-info
72 Requires:       sqlite3
73 Requires:       xdg-utils
74 Obsoletes:      beagle-libs
75 Obsoletes:      beagle-static
76 # sr@Latn vs. sr@latin
77 Conflicts:      glibc-misc < 6:2.7
78 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
79 ExcludeArch:    i386
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Beagle is an indexing sub-system and search aggregator built on top of
84 Lucene.Net.
85
86 %description -l pl.UTF-8
87 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
88 bazie Lucene.Net.
89
90 %package debug
91 Summary:        Debug files for the Mono part of Beagle
92 Summary(pl.UTF-8):      Pliki debugujące dla części Mono Beagle'a
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95
96 %description debug
97 Debug files for the Mono part of Beagle.
98
99 %description debug -l pl.UTF-8
100 Pliki debugujące dla części Mono Beagle'a.
101
102 %package devel
103 Summary:        Beagle development files
104 Summary(pl.UTF-8):      Pliki programistyczne Beagle
105 Group:          Development/Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description devel
109 Beagle development files.
110
111 %description devel -l pl.UTF-8
112 Pliki programistyczne Beagle.
113
114 %package apidocs
115 Summary:        libbeagle API documentation
116 Summary(pl.UTF-8):      Dokumentacja API libbeagle
117 Group:          Documentation
118 Requires:       gtk-doc-common
119
120 %description apidocs
121 libbeagle API documentation.
122
123 %description apidocs -l pl.UTF-8
124 Dokumentacja API libbeagle.
125
126 %package crawl-system
127 Summary:        Beagle crawl system
128 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
129 Group:          Applications/System
130 Requires:       crondaemon
131 Provides:       group(beagleindex)
132 Provides:       user(beagleindex)
133
134 %description crawl-system
135 Beagle crawl system.
136
137 %description crawl-system -l pl.UTF-8
138 System przeszukujący beagle-crawl.
139
140 %package search-gui
141 Summary:        GNOME based Beagle GUI
142 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
143 Group:          Libraries/Python
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       gtk+2 >= 2:2.10.10
146
147 %description search-gui
148 GNOME based Beagle GUI.
149
150 %description search-gui -l pl.UTF-8
151 Oparty na GNOME graficzny interfejs dla Beagle.
152
153 %package startup
154 Summary:        Automatic startup integration for Beagle
155 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
156 Group:          X11/Applications
157 Requires:       %{name} = %{version}-%{release}
158 Obsoletes:      beagle-gnome
159
160 %description startup
161 Automatic session startup integration for Beagle.
162
163 %description startup -l pl.UTF-8
164 Integracja funkcji automatycznego startu Beagle.
165
166 %package webinterface
167 Summary:        A web interface for Beagle
168 Summary(pl.UTF-8):      Interfejs sieciowy dla Beagle
169 Group:          Applications
170 Requires:       %{name} = %{version}-%{release}
171
172 %description webinterface
173 An AJAX interface that allows users to search for data through their
174 web browser.
175
176 %description webinterface -l pl.UTF-8
177 AJAX-owy interfejs pozwalający użytkownikom wyszukiwać dane za pomocą
178 przeglądarki internetowej.
179
180 %package evolution
181 Summary:        Beagle Evolution backend
182 Summary(pl.UTF-8):      Backend Beagle dla Evolution
183 Group:          X11/Applications/Networking
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       dotnet-evolution-sharp >= 0.11.1
186 Requires:       evolution >= 2.10.0
187
188 %description evolution
189 Beagle Evolution backend.
190
191 %description evolution -l pl.UTF-8
192 Backend Beagle dla Evolution.
193
194 %package icedove
195 Summary:        Beagle Icedove backend
196 Summary(pl.UTF-8):      Backend Beagle dla Icedove
197 Group:          X11/Applications/Networking
198 Requires:       %{name} = %{version}-%{release}
199 Requires:       icedove
200 Provides:       beagle-thunderbird
201 Obsoletes:      beagle-thunderbird
202
203 %description icedove
204 Beagle Icedove backend.
205
206 %description icedove -l pl.UTF-8
207 Backend Beagle dla Icedove.
208
209 %package -n epiphany-extension-beagle
210 Summary:        Epiphany extension - beagle
211 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
212 Group:          X11/Applications/Networking
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       epiphany-extensions >= 2.22.0
215
216 %description -n epiphany-extension-beagle
217 Epiphany extension that allows Beagle to index every page the user
218 views.
219
220 %description -n epiphany-extension-beagle -l pl.UTF-8
221 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
222 odwiedzaną stronę.
223
224 %package -n iceweasel-extension-beagle
225 Summary:        Iceweasel extension - beagle
226 Summary(pl.UTF-8):      Rozszerzenie dla przeglądarki Iceweasel - beagle
227 Group:          X11/Applications/Networking
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       iceweasel
230 Provides:       mozilla-firefox-extension-beagle
231 Obsoletes:      mozilla-firefox-extension-beagle
232
233 %description -n iceweasel-extension-beagle
234 Iceweasel extension that allows Beagle to index every page the user
235 views.
236
237 %description -n iceweasel-extension-beagle -l pl.UTF-8
238 Rozszerzenie dla przeglądarki Iceweasel sprawiające, że Beagle
239 indeksuje każdą odwiedzaną stronę.
240
241 %prep
242 %setup -q
243 %patch0 -p1
244 %patch1 -p1
245 %patch2 -p1
246 %patch3 -p1
247 %patch4 -p1
248 %patch5 -p1
249 %patch6 -p1
250 %patch7 -p1
251
252 %build
253 %{__intltoolize}
254 %{__libtoolize}
255 %{__aclocal}
256 %{__autoconf}
257 %{__autoheader}
258 %{__automake}
259 %configure \
260         --disable-static \
261         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
262         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution \
263         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
264         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird \
265         --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi
266
267 %{__make} -j1
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
272
273 %{__make} install \
274         DESTDIR=$RPM_BUILD_ROOT
275
276 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*glue.la
277
278 dest=$RPM_BUILD_ROOT%{_datadir}/iceweasel/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
279 install -d $dest $dest/chrome
280 install firefox-extension/{chrome.manifest,install.rdf} $dest
281 cp -r firefox-extension/chrome/* $dest/chrome
282
283 %if %{with thunderbird}
284 tdest=$RPM_BUILD_ROOT%{_libdir}/icedove/extensions/\{b656ef18-fd76-45e6-95cc-8043f26361e7\}
285 install -d $tdest
286 install thunderbird-extension/{chrome.manifest,install.rdf} $tdest
287 cp -r thunderbird-extension/{chrome,components,defaults} $tdest
288 %endif
289
290 %if %{with gui}
291 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
292         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
293 %find_lang %{name}
294 %else
295 touch %{name}.lang
296 %endif
297
298 %clean
299 rm -rf $RPM_BUILD_ROOT
300
301 %pre crawl-system
302 %groupadd -g 166 -r -f beagleindex
303 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
304
305 %postun crawl-system
306 if [ "$1" = "0" ]; then
307         %userremove beagleindex
308         %groupremove beagleindex
309 fi
310
311 %files -f %{name}.lang
312 %defattr(644,root,root,755)
313 %doc AUTHORS COPYING ChangeLog NEWS README
314 %attr(755,root,root) %{_bindir}/beagle-config
315 %{?with_gsf:%attr(755,root,root) %{_bindir}/beagle-doc-extractor}
316 %attr(755,root,root) %{_bindir}/beagle-extract-content
317 %attr(755,root,root) %{_bindir}/beagle-index-info
318 %attr(755,root,root) %{_bindir}/beagle-info
319 %attr(755,root,root) %{_bindir}/beagle-ping
320 %attr(755,root,root) %{_bindir}/beagle-query
321 %attr(755,root,root) %{_bindir}/beagle-shutdown
322 %attr(755,root,root) %{_bindir}/beagle-static-query
323 %attr(755,root,root) %{_bindir}/beagle-status
324 %attr(755,root,root) %{_bindir}/beagled
325 %attr(755,root,root) %{_bindir}/blocate
326 %attr(755,root,root) %{_libdir}/%{name}/*.exe
327 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
328 %dir %{_sysconfdir}/beagle
329 %dir %{_sysconfdir}/beagle/config-files
330 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/blocate.conf
331 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/query-mapping.xml
332 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/BeagleSearch.xml
333 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Daemon.xml
334 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/FilesQueryable.xml
335 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/GoogleBackends.xml
336 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Networking.xml
337 %dir %{_libdir}/%{name}
338 %dir %{_libdir}/%{name}/Backends
339 %dir %{_libdir}/%{name}/Filters
340 %{_libdir}/%{name}/*.dll
341 %{_libdir}/%{name}/*.dll.config
342 %{_libdir}/%{name}/Backends/GoogleBackends*.dll
343 %{_libdir}/%{name}/Filters/*.dll
344 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
345 %{_mandir}/man1/beagle-config.1*
346 %{_mandir}/man1/beagle-info.1*
347 %{_mandir}/man1/beagle-ping.1*
348 %{_mandir}/man1/beagle-query.1*
349 %{_mandir}/man1/beagle-shutdown.1*
350 %{_mandir}/man1/beagle-status.1*
351 %{_mandir}/man1/beagled.1*
352 %{_mandir}/man8/beagle-doc-extractor.8*
353 %{_mandir}/man8/beagle-index-info.8*
354
355 %files debug
356 %defattr(644,root,root,755)
357 %{_libdir}/%{name}/Backends/*.mdb
358 %{_libdir}/%{name}/Filters/*.mdb
359 %{_libdir}/%{name}/*.mdb
360
361 %files devel
362 %defattr(644,root,root,755)
363 %{_pkgconfigdir}/beagle-0.0.pc
364 %{?with_gui:%{_pkgconfigdir}/beagle-ui-0.0.pc}
365 %{_pkgconfigdir}/beagle-daemon.pc
366
367 %if %{with apidocs}
368 %files apidocs
369 %defattr(644,root,root,755)
370 %{_prefix}/lib/monodoc/sources/*
371 %endif
372
373 %files crawl-system
374 %defattr(644,root,root,755)
375 %dir %{_sysconfdir}/beagle/crawl-rules
376 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-applications
377 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-documentation
378 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-executables
379 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-manpages
380 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-monodoc
381 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-windows
382 # XXX: samples not here
383 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/external-filters.xml.sample
384 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/beagle-crawl-system
385 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
386 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
387 %attr(755,root,root) %{_sbindir}/beagle-build-index
388 %attr(755,root,root) %{_sbindir}/beagle-dump-index
389 %attr(755,root,root) %{_sbindir}/beagle-manage-index
390 %attr(755,root,root) %{_sbindir}/beagle-master-delete-button
391 %attr(755,root,root) %{_sbindir}/beagle-removable-index
392 %{_mandir}/man8/beagle-dump-index.8*
393 %{_mandir}/man8/beagle-build-index.8*
394 %{_mandir}/man8/beagle-extract-content.8*
395 %{_mandir}/man8/beagle-manage-index.8*
396
397 %if %{with gui}
398 %files search-gui
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
401 %attr(755,root,root) %{_bindir}/beagle-search
402 %attr(755,root,root) %{_bindir}/beagle-settings
403 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
404 %attr(755,root,root) %{_libdir}/%{name}/keygrabber.py
405 %{_mandir}/man1/beagle-search.1*
406 %{_mandir}/man1/beagle-settings.1*
407 %{_mandir}/man8/beagle-imlogviewer.8*
408 %{_desktopdir}/*.desktop
409 %endif
410
411 %files startup
412 %defattr(644,root,root,755)
413 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
414 %{?with_gui:%{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop}
415
416 %files webinterface
417 %defattr(644,root,root,755)
418 %{_datadir}/%{name}
419
420 %if %{with evolution}
421 %files evolution
422 %defattr(644,root,root,755)
423 %{_libdir}/%{name}/Backends/Evolution*.dll
424 %endif
425
426 %if %{with thunderbird}
427 %files icedove
428 %defattr(644,root,root,755)
429 %{_libdir}/%{name}/Backends/Thunderbird*.dll
430 %{_libdir}/icedove/extensions/{b656ef18-fd76-45e6-95cc-8043f26361e7}
431 %endif
432
433 %if %{with epiphany}
434 %files -n epiphany-extension-beagle
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_libdir}/epiphany/2.26/extensions/beagle.py
437 %{_libdir}/epiphany/2.26/extensions/*.ephy-extension
438 %endif
439
440 %files -n iceweasel-extension-beagle
441 %defattr(644,root,root,755)
442 %{_datadir}/iceweasel/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
This page took 1.068288 seconds and 3 git commands to generate.