]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
259de45844e25a78c99eb8e30b4042dff987ed65
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - mozilla extension?
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_without  apidocs         # don't build API documentation
10 %bcond_without  evolution       # don't include evolution support
11 %bcond_without  galago          # build without galago support
12 %bcond_without  gsf             # build without libgsf support
13 %bcond_without  gui             # don't build GNOME based GUI
14 %bcond_without  python          # don't build python libraries
15 %bcond_without  epiphany        # don't build epiphany extension
16 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
17 %bcond_with     thunderbird     # use Thunderbird backend
18 #
19 %if !%{with gui}
20 %undefine       with_evolution
21 %endif
22 #
23 Summary:        Beagle - An indexing subsystem
24 Summary(pl):    Beagle - podsystem indeksuj±cy
25 Name:           beagle
26 Version:        0.2.15.1
27 Release:        2
28 License:        Various
29 Group:          Libraries
30 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
31 # Source0-md5:  91fb5a499467b3ef468a5f003830c9fa
32 Patch0:         %{name}-desktop.patch
33 Patch1:         %{name}-crawl.patch
34 Patch2:         %{name}-kill_exec_a.patch
35 Patch3:         %{name}-configure.patch
36 URL:            http://beagle-project.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  chmlib-devel
40 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
41 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
42 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
43 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
44 #BuildRequires: dotnet-gst-sharp-devel
45 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
46 %if %{with epiphany} 
47 BuildRequires:  epiphany-devel >= 2.16.1
48 %endif
49 BuildRequires:  gtk+2-devel >= 2:2.10.6
50 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
51 BuildRequires:  libexif-devel >= 0.6.13
52 BuildRequires:  librsvg-devel >= 1:2.16.0
53 BuildRequires:  libpng-devel
54 BuildRequires:  libtool
55 BuildRequires:  libxml2-devel >= 1:2.6.26
56 BuildRequires:  mono-csharp >= 1.1.18
57 # not used atm
58 #BuildRequires: mozilla-devel
59 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.10.3}
60 BuildRequires:  pkgconfig
61 BuildRequires:  perl-XML-Parser
62 BuildRequires:  python-devel
63 %if %{with sqlite3}
64 BuildRequires:  sqlite3-devel >= 3.3.4
65 %else
66 BuildRequires:  sqlite-devel
67 %endif
68 BuildRequires:  wv-devel >= 1.2.4
69 BuildRequires:  xorg-lib-libXScrnSaver-devel
70 BuildRequires:  zip
71 # GUI BRs
72 %if %{with gui}
73 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
74 BuildRequires:  gnome-vfs2-devel >= 2.16.1
75 %endif
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       dotnet-gmime-sharp >= 2.2.3
78 %if %{with sqlite3}
79 Requires:       sqlite3
80 %else
81 Requires:       sqlite
82 %endif
83 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
84 ExcludeArch:    i386
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %description
88 Beagle is an indexing sub-system and search aggregator built on top of
89 Lucene.Net.
90
91 %description -l pl
92 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
93 bazie Lucene.Net.
94
95 %package libs
96 Summary:        Beagle libraries
97 Summary(pl):    Bibiloteki Beagle
98 Group:          Libraries
99
100 %description libs
101 Beagle libraries.
102
103 %description libs -l pl
104 Bibiloteki Beagle.
105
106 %package devel
107 Summary:        Beagle development files
108 Summary(pl):    Pliki programistyczne Beagle
109 Group:          Development/Libraries
110 Requires:       %{name}-libs = %{version}-%{release}
111
112 %description devel
113 Beagle development files.
114
115 %description devel -l pl
116 Pliki programistyczne Beagle.
117
118 %package static
119 Summary:        Beagle static libraries
120 Summary(pl):    Statyczne biblioteki Beagle
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description static
125 Beagle static libraries.
126
127 %description static -l pl
128 Statyczne biblioteki Beagle.
129
130 %package apidocs
131 Summary:        libbeagle API documentation
132 Summary(pl):    Dokumentacja API libbeagle
133 Group:          Documentation
134 Requires:       gtk-doc-common
135
136 %description apidocs
137 libbeagle API documentation.
138
139 %description apidocs -l pl
140 Dokumentacja API libbeagle.
141
142 %package crawl-system
143 Summary:        Beagle crawl system
144 Summary(pl):    System przeszukuj±cy beagle-crawl
145 Group:          Applications/System
146 Requires:       crondaemon
147 Provides:       group(beagleindex)
148 Provides:       user(beagleindex)
149
150 %description crawl-system
151 Beagle crawl system.
152
153 %description crawl-system -l pl
154 System przeszukuj±cy beagle-crawl.
155
156 %package evolution
157 Summary:        Beagle Evolution backend
158 Summary(pl):    Backend Beagle dla Evolution
159 Group:          X11/Applications/Networking
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       dotnet-evolution-sharp >= 0.11.1
162 Requires:       evolution >= 2.8.0
163
164 %description evolution
165 Beagle Evolution backend.
166
167 %description evolution -l pl
168 Backend Beagle dla Evolution.
169
170 %package thunderbird
171 Summary:        Beagle Mozilla Thunderbird backend
172 Summary(pl):    Backend Beagle dla Mozilli Thunderbird
173 Group:          X11/Applications/Networking
174 Requires:       %{name} = %{version}-%{release}
175
176 %description thunderbird
177 Beagle Mozilla Thunderbird backend.
178
179 %description thunderbird -l pl
180 Backend Beagle dla Mozilli Thunderbird.
181
182 %package -n mozilla-firefox-extension-beagle
183 Summary:        Mozilla Firefox extension - beagle
184 Summary(pl):    Rozszerzenie dla Mozilla Firefox - beagle
185 Group:          X11/Applications/Networking
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       mozilla-firefox >= 2.0.0.1-2
188
189 %description -n mozilla-firefox-extension-beagle
190 Mozilla Firefox extension that allows Beagle to index every page the
191 user views.
192
193 %description -n mozilla-firefox-extension-beagle -l pl
194 Rozszerzenie dla Mozilla Firefox sprawiaj±ce, ¿e Beagle indeksuje
195 ka¿d± odwiedzan± stronê.
196
197 %package -n epiphany-extension-beagle
198 Summary:        Epiphany extension - beagle
199 Summary(pl):    Rozszerzenie dla Epiphany - beagle
200 Group:          X11/Applications/Networking
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       epiphany-extensions >= 2.16.1
203
204 %description -n epiphany-extension-beagle
205 Epiphany extension that allows Beagle to index every page the user
206 views.
207
208 %description -n epiphany-extension-beagle -l pl
209 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
210 odwiedzan± stronê.
211
212 %package -n python-%{name}
213 Summary:        Beagle Python bindings
214 Summary(pl):    Wi±zania jêzyka Python dla Beagle
215 Group:          Libraries/Python
216 Requires:       %{name} = %{version}-%{release}
217 %pyrequires_eq  python-libs
218
219 %description -n python-%{name}
220 Beagle Python bindings.
221
222 %description -n python-%{name} -l pl
223 Wi±zania jêzyka Python dla Beagle.
224
225 %package search-gui
226 Summary:        GNOME based Beagle GUI
227 Summary(pl):    Oparty na GNOME graficzny interfejs dla Beagle
228 Group:          Libraries/Python
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       gtk+2 >= 2:2.10.6
231
232 %description search-gui
233 GNOME based Beagle GUI.
234
235 %description search-gui -l pl
236 Oparty na GNOME graficzny interfejs dla Beagle.
237
238 %package startup
239 Summary:        Automatic startup integration for Beagle
240 Summary(pl):    Integracja funkcji automatycznego startu Beagle
241 Group:          X11/Applications
242 Requires:       %{name} = %{version}-%{release}
243 Obsoletes:      beagle-gnome
244
245 %description startup
246 Automatic session startup integration for Beagle.
247
248 %description startup -l pl
249 Integracja funkcji automatycznego startu Beagle.
250
251 %prep
252 %setup -q
253 %patch0 -p1
254 %patch1 -p1
255 %patch2 -p1
256 %patch3 -p1
257
258 %build
259 %{__libtoolize}
260 %{__aclocal}
261 %{__autoconf}
262 %{__automake}
263 %configure \
264         --enable-static \
265         %{?with_apidocs:--enable-gtk-doc} \
266         --with-html-dir=%{_gtkdocdir} \
267         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
268         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
269         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
270         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird
271
272 %{__make} \
273         MOZILLA_HOME=%{_libdir}/mozilla \
274         pythondir=%{py_sitedir}
275
276 %install
277 rm -rf $RPM_BUILD_ROOT
278 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
279
280 %{__make} install \
281         DESTDIR=$RPM_BUILD_ROOT \
282         pythondir=%{py_sitedir}
283
284 dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
285 install -d $dest $dest/chrome
286 install mozilla-extension/{chrome.manifest,install.rdf} $dest
287 install mozilla-extension/chrome/beagle.jar $dest/chrome
288
289 # Kill useless files
290 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.16/extensions/*.{la,a} \
291         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
292
293 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
294 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
295
296 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
297
298 %find_lang %{name}
299
300 %clean
301 rm -rf $RPM_BUILD_ROOT
302
303 %pre crawl-system
304 %groupadd -g 166 -r -f beagleindex
305 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
306
307 %postun crawl-system
308 if [ "$1" = "0" ]; then
309         %userremove beagleindex
310         %groupremove beagleindex
311 fi
312
313 %post   libs -p /sbin/ldconfig
314 %postun libs -p /sbin/ldconfig
315
316 %files -f %{name}.lang
317 %defattr(644,root,root,755)
318 %doc AUTHORS COPYING ChangeLog NEWS README
319 %attr(755,root,root) %{_bindir}/beagle-config
320 %attr(755,root,root) %{_bindir}/beagled
321 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
322 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
323 %attr(755,root,root) %{_bindir}/beagle-extract-content
324 %attr(755,root,root) %{_bindir}/beagle-index-info
325 %attr(755,root,root) %{_bindir}/beagle-index-url
326 %attr(755,root,root) %{_bindir}/beagle-info
327 %attr(755,root,root) %{_bindir}/beagle-ping
328 %attr(755,root,root) %{_bindir}/beagle-query
329 %attr(755,root,root) %{_bindir}/beagle-shutdown
330 %attr(755,root,root) %{_bindir}/beagle-status
331 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
332 %attr(755,root,root) %{_libdir}/%{name}/*.exe
333 %dir %{_libdir}/%{name}
334 %dir %{_libdir}/%{name}/Backends
335 %dir %{_libdir}/%{name}/Filters
336 %{_libdir}/%{name}/*.dll
337 %{_libdir}/%{name}/*.dll.config
338 %{_libdir}/%{name}/Filters/*.dll
339 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
340 %{_mandir}/man*/*
341
342 %files libs
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
345
346 %files devel
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_libdir}/*.so
349 %{_includedir}/libbeagle
350 %{_libdir}/*.la
351 %{_pkgconfigdir}/*
352
353 %files static
354 %defattr(644,root,root,755)
355 %{_libdir}/*.a
356
357 %if %{with apidocs}
358 %files apidocs
359 %defattr(644,root,root,755)
360 %{_gtkdocdir}/beagle
361 %endif
362
363 %files crawl-system
364 %defattr(644,root,root,755)
365 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
366 %dir %{_sysconfdir}/beagle
367 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
368 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
369 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
370 %attr(755,root,root) %{_sbindir}/*
371
372 %if %{with evolution}
373 %files evolution
374 %defattr(644,root,root,755)
375 %{_libdir}/%{name}/Backends/Evolution*.dll
376 %endif
377
378 %if %{with thunderbird}
379 %files thunderbird
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_bindir}/beagle-contactviewer
382 %{_libdir}/%{name}/Backends/Thunderbird*.dll
383 %endif
384
385 %files -n mozilla-firefox-extension-beagle
386 %defattr(644,root,root,755)
387 %{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
388
389 %if %{with epiphany}
390 %files -n epiphany-extension-beagle
391 %defattr(644,root,root,755)
392 %doc epiphany-extension/README
393 %attr(755,root,root) %{_libdir}/epiphany/2.16/extensions/libbeagleextension.so*
394 %{_libdir}/epiphany/2.16/extensions/*.xml
395 %endif
396
397 %if %{with python}
398 %files -n python-%{name}
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{py_sitedir}/*.so
401 %endif
402
403 %if %{with gui}
404 %files search-gui
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
407 %attr(755,root,root) %{_bindir}/beagle-search
408 %attr(755,root,root) %{_bindir}/beagle-settings
409 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
410 %{_pixmapsdir}/*.png
411 %{_desktopdir}/*.desktop
412 %endif
413
414 %files startup
415 %defattr(644,root,root,755)
416 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
417 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
This page took 0.057146 seconds and 2 git commands to generate.