]> git.pld-linux.org Git - packages/bcm5700.git/blob - bcm5700.spec
76d22d581f163623dad729cae8089cc1a8fd0713
[packages/bcm5700.git] / bcm5700.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # don't build userspace programs
6 %bcond_with     verbose         # verbose build (V=1)
7
8 %if !%{with kernel}
9 %undefine       with_dist_kernel
10 %endif
11
12 %define         _rel    1
13 Summary:        Linux driver for the Broadcom's NetXtreme BCM57xx Network Interface Cards
14 Summary(pl.UTF-8):      Sterownik dla Linuksa do kart sieciowych Broadcom NetXtreme BCM57xx
15 Name:           bcm5700
16 Version:        8.3.14
17 Release:        %{_rel}
18 License:        GPL v2
19 Group:          Base/Kernel
20 # extracted from http://www.broadcom.com/docs/driver_download/570x/linux-8.3.14.zip
21 Source0:        %{name}-%{version}.tar.gz
22 # Source0-md5:  6dd814821f26ad67c7d7ce61c5275ca0
23 Source1:        %{name}-Makefile
24 Patch0:         %{name}-2.6.22.patch
25 URL:            http://www.broadcom.com/drivers/downloaddrivers.php
26 %if %{with kernel}
27 %{?with_dist_kernel:BuildRequires:      kernel-module-build >= 3:2.6.20.2}
28 BuildRequires:  rpmbuild(macros) >= 1.379
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This package contains the Linux driver for the Broadcom's NetXtreme
34 BCM57xx Network Interface Cards.
35
36 Note: this driver is obsoleted by Broadcom, use tg3 instead.
37
38 %description -l pl.UTF-8
39 Pakiet zawiera sterownik dla Linuksa do kart sieciowych Broadcom
40 BCM57xx.
41
42 Uwaga: ten sterownik Broadcomu jest przestarzały, należy używać tg3.
43
44 %package -n kernel-net-bcm5700
45 Summary:        Linux SMP driver for the Broadcom's NetXtreme BCM57xx Network Interface Cards
46 Summary(pl.UTF-8):      Sterownik dla Linuksa SMP do kart sieciowych Broadcom BCM57xx
47 Release:        %{_rel}@%{_kernel_ver_str}
48 Group:          Base/Kernel
49 Requires(post,postun):  /sbin/depmod
50 %if %{with dist_kernel}
51 %requires_releq_kernel
52 Requires(postun):       %releq_kernel
53 %endif
54
55 %description -n kernel-net-bcm5700
56 Linux driver for the Broadcom's NetXtreme BCM57xx Network Interface
57 Cards.
58
59 Note: this driver is obsoleted by Broadcom, use tg3 instead.
60
61 %description -n kernel-net-bcm5700 -l pl.UTF-8
62 Sterownik dla Linuksa do kart sieciowych Broadcom BCM57xx.
63
64 Uwaga: ten sterownik Broadcomu jest przestarzały, należy używać tg3.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 %build
71 %build_kernel_modules -C src -m bcm5700
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 cd src
76
77 %if %{with userspace}
78 install -d $RPM_BUILD_ROOT%{_mandir}/man4
79 install bcm5700.4 $RPM_BUILD_ROOT%{_mandir}/man4
80 %endif
81
82 %if %{with kernel}
83 %install_kernel_modules -m bcm5700 -d kernel/drivers/net
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -n kernel-net-bcm5700
90 %depmod %{_kernel_ver}
91
92 %postun -n kernel-net-bcm5700
93 %depmod %{_kernel_ver}
94
95 %if %{with userspace}
96 %files
97 %defattr(644,root,root,755)
98 %doc README.TXT
99 %{_mandir}/man4/bcm5700.*
100 %endif
101
102 %if %{with kernel}
103 %files -n kernel-net-bcm5700
104 %defattr(644,root,root,755)
105 /lib/modules/%{_kernel_ver}/kernel/drivers/net/bcm5700.ko*
106 %endif
This page took 0.029826 seconds and 3 git commands to generate.