]> git.pld-linux.org Git - packages/bcg729.git/blob - bcg729.spec
- switched to cmake (autotools build is deprecated)
[packages/bcg729.git] / bcg729.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        ITU G729 Annex A speech codec library
6 Summary(pl.UTF-8):      Biblioteka kodeka mowy ITU G729 Annex A
7 Name:           bcg729
8 Version:        1.1.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 #Source0Download: https://gitlab.linphone.org/BC/public/bcg729/tags
13 Source0:        https://gitlab.linphone.org/BC/public/bcg729/-/archive/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  23b0c28422df3251adbc81e596ef9861
15 URL:            http://www.linphone.org/technical-corner/bcg729
16 BuildRequires:  cmake >= 3.1
17 BuildRequires:  pkgconfig
18 BuildRequires:  rpmbuild(macros) >= 1.745
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 bcg729 is an opensource implementation of both encoder and decoder of
23 the ITU G729 Annex A speech codec. The library written in C99 is fully
24 portable and can be executed on many platforms including both ARM
25 processor and x86. libbcg729 supports concurrent channels
26 encoding/decoding for multi call application such conferencing. This
27 project was initially developed as part of Mediastreamer2, the
28 Linphone's media processing engine. So there is also available the
29 glue to be integrated in Linphone/Mediastreamer2.
30
31 %description -l pl.UTF-8
32 bcg729 to implementacja o otwartych źródłach kodera oraz dekorera
33 kodeka mowy ITU G729 Annex A. Biblioteka napisana w dialekcie C99 jest
34 w pełni przenośna i może być uruchamiana na wielu platformach, w tym
35 procesorach ARM i x86. libbcg729 obsługuje jednoczesne
36 kodowanie/dekodowanie wielu kanałów dla zastosowań z wieloma
37 rozmowami,takich jak konferencje. Ten projekt początkowo był częścią
38 Mediastreamera2 - silnika przetwarzania multimediów programu Linphone.
39 Dlatego jest też dostępny kod łączący z Linphonem/Mediastreamerem2.
40
41 %package devel
42 Summary:        Header files for bcg729 library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki bcg729
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for bcg729 library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki bcg729.
52
53 %package static
54 Summary:        Static bcg729 library
55 Summary(pl.UTF-8):      Statyczna biblioteka bcg729
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static bcg729 library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka bcg729.
64
65 %prep
66 %setup -q
67
68 %build
69 install -d build
70 cd build
71 %cmake .. \
72         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
73         %{!?with_static_libs:-DENABLE_STATIC=OFF}
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS.md CHANGELOG.md README.md
92 %attr(755,root,root) %{_libdir}/libbcg729.so.0
93
94 %files devel
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/libbcg729.so
97 %{_includedir}/bcg729
98 %{_pkgconfigdir}/libbcg729.pc
99 %dir %{_datadir}/Bcg729
100 %{_datadir}/Bcg729/cmake
101
102 %if %{with static_libs}
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libbcg729.a
106 %endif
This page took 0.090124 seconds and 4 git commands to generate.