]> git.pld-linux.org Git - SPECS.git/blob - bazel.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / bazel.spec
1 # TODO: use system jars
2 Summary:        Build and test software of any size, quickly and reliably
3 Summary(pl.UTF-8):      Budowanie i testowanie oprogramowania dowolnych rozmiarów - szybko i wiarygodnie
4 Name:           bazel
5 Version:        1.2.1
6 Release:        1
7 License:        Apache v2.0
8 Group:          Development/Tools
9 #Source0Download: https://github.com/bazelbuild/bazel/releases
10 Source0:        https://github.com/bazelbuild/bazel/releases/download/%{version}/%{name}-%{version}-dist.zip
11 # Source0-md5:  da63b5df0eb5075d6ed3e021ae79cf6b
12 Patch0:         %{name}-glibc.patch
13 Patch1:         %{name}-x86.patch
14 URL:            https://bazel.build/
15 BuildRequires:  bash
16 BuildRequires:  jdk >= 1.8
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  python3 >= 1:3.2
19 BuildRequires:  unzip
20 BuildRequires:  zip
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _noautostrip            .*%{_bindir}/bazel
24
25 %description
26 Build and test software of any size, quickly and reliably.
27
28 %description -l pl.UTF-8
29 Budowanie i testowanie oprogramowania dowolnych rozmiarów - szybko i
30 wiarygodnie.
31
32 %prep
33 %setup -q -c
34 %patch0 -p1
35 %patch1 -p1
36
37 %{__sed} -i -e 's,/bin/java" ,& -Xmx2g ,' scripts/bootstrap/compile.sh
38
39 %build
40 BAZEL_JAVAC_OPTS="-J-Xmx1g" \
41 EXTRA_BAZEL_ARGS="--host_javabase=@local_jdk//:jdk" \
42 bash ./compile.sh
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 install -D output/bazel $RPM_BUILD_ROOT%{_bindir}/bazel
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc AUTHORS CHANGELOG.md CONTRIBUTORS README.md
55 %attr(755,root,root) %{_bindir}/bazel
This page took 1.014759 seconds and 3 git commands to generate.