]> git.pld-linux.org Git - packages/bacula.git/blob - bacula.spec
dced1cd0d9d706402f527f4f58643856e6a9cdfc
[packages/bacula.git] / bacula.spec
1 # TODO:
2 #       - update desktop files, think about su-wrappers for console
3 #       - package web admin
4 #       - fix log file permissions
5 #
6 # Conditional build:
7 %bcond_without  console_wx      # wx-console program
8 %bcond_without  gnome           # gnome-console program
9 %bcond_without  sqlite          # use sqlite
10 %bcond_without  bat             # bat Qt4 GUI
11 %bcond_with     mysql           # use mysql
12 %bcond_with     pgsql           # use PostgreSQL
13 %bcond_with     python
14 %bcond_with     rescue
15 %bcond_with     sqlite3         # use sqlite3 insted sqlite
16 %bcond_with     sqlite3_sync_off        # makes sqlite3 backend much faster, but less reliable
17 %if %{with sqlite}
18 %define         _database       sqlite
19 %endif
20 %if %{with sqlite3}
21 %define         _database       sqlite3
22 %undefine       with_sqlite
23 %undefine       with_mysql
24 %undefine       with_pgsql
25 %endif
26 %if %{with pgsql}
27 %define         _database       postgresql
28 %undefine       with_sqlite
29 %undefine       with_sqlite3
30 %undefine       with_mysql
31 %endif
32 %if %{with mysql}
33 %define         _database       mysql
34 %undefine       with_sqlite
35 %undefine       with_sqlite3
36 %undefine       with_pgsql
37 %undefine       with_sqlite3_sync_off
38 %endif
39 #
40 Summary:        Bacula - The Network Backup Solution
41 Summary(pl.UTF-8):      Bacula - rozwiązanie do wykonywania kopii zapasowych po sieci
42 Name:           bacula
43 Version:        2.2.6
44 Release:        1
45 Epoch:          0
46 License:        extended GPL v2
47 Group:          Networking/Utilities
48 Source0:        http://dl.sourceforge.net/bacula/%{name}-%{version}.tar.gz
49 # Source0-md5:  fe964931ab3fc538a8884204d23e8a5a
50 Source1:        http://dl.sourceforge.net/bacula/%{name}-docs-%{version}.tar.bz2
51 # Source1-md5:  a251dc0b5a2c8250b43e2ae372526de2
52 Source2:        http://dl.sourceforge.net/bacula/%{name}-rescue-%{version}.tar.gz
53 # Source2-md5:  51bc4b1e5d60593cb9f9aa80d31ad8e4
54 Source10:       %{name}-dir.init
55 Source11:       %{name}-fd.init
56 Source12:       %{name}-sd.init
57 Source13:       %{name}.logrotate
58 Source14:       %{name}-dir.sysconfig
59 Source15:       %{name}-fd.sysconfig
60 Source16:       %{name}-sd.sysconfig
61 Patch0:         %{name}-dvd-handler_path.patch
62 Patch1:         %{name}-link.patch
63 Patch2:         %{name}-compile.patch
64 Patch3:         %{name}-wx28.patch
65 Patch4:         %{name}-sqlite3_init_query.patch
66 URL:            http://www.bacula.org/
67 BuildRequires:  acl-static
68 BuildRequires:  automake
69 %if %{with rescue}
70 BuildRequires:  fakeroot
71 %endif
72 BuildRequires:  glibc-static
73 %if %{with gnome}
74 BuildRequires:  libgnome-devel >= 2.0
75 BuildRequires:  libgnomeui-devel >= 2.0
76 %endif
77 BuildRequires:  libstdc++-static
78 BuildRequires:  libwrap-static
79 BuildRequires:  mtx
80 BuildRequires:  ncurses-devel
81 BuildRequires:  openssl-devel
82 BuildRequires:  openssl-static
83 BuildRequires:  pkgconfig
84 %if %{with python}
85 BuildRequires:  python-static
86 %endif
87 %if %{with bat}
88 BuildRequires:  qt4-qmake
89 BuildRequires:  qwt-devel >= 5.0.2-2
90 BuildRequires:  QtCore-devel
91 BuildRequires:  QtGui-devel
92 %endif
93 BuildRequires:  readline-devel
94 BuildRequires:  rpmbuild(macros) >= 1.268
95 BuildRequires:  sed >= 4.0
96 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
97 %{?with_sqlite:BuildRequires:  sqlite-devel}
98 %{?with_mysql:BuildRequires:  mysql-devel}
99 %{?with_pgsql:BuildRequires:  postgresql-devel}
100 %if %{with console_wx}
101 BuildRequires:  wxGTK2-unicode-devel >= 2.4.0
102 %endif
103 BuildRequires:  zlib-devel
104 BuildRequires:  zlib-static
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         _sysconfdir     /etc/%{name}
108 %define         _localstatedir  /var/lib/%{name}
109
110 # dependency section is broken. ccache usage is instead to makefiles
111 %undefine       with_ccache
112
113 %description
114 Bacula - It comes by night and sucks the vital essence from your
115 computers.
116
117 Bacula is a set of computer programs that permit you (or the system
118 administrator) to manage backup, recovery, and verification of
119 computer data across a network of computers of different kinds. In
120 technical terms, it is a network client/server based backup program.
121 Bacula is relatively easy to use and efficient, while offering many
122 advanced storage management features that make it easy to find and
123 recover lost or damaged files.
124
125 %description -l pl.UTF-8
126 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
127
128 Bacula to zbiór programów umożliwiających administratorowi na
129 zarządzanie kopiami zapasowymi, odzyskiwaniem i weryfikacją danych w
130 sieci komputerów różnego rodzaju. W terminologii technicznej jest to
131 program do kopii zapasowych pracujący w architekturze klient-serwer.
132 Bacula jest stosunkowo łatwa w użyciu i wydajna, oferując przy tym
133 wiele zaawansowanych możliwości przy zarządzaniu nośnikami,
134 ułatwiających znalezienie i odzyskanie utraconych lub uszkodzonych
135 plików.
136
137 %package common
138 Summary:        Common files for bacula package
139 Summary(pl.UTF-8):      Pliki wspólne dla pakietu bacula
140 Group:          Networking/Utilities
141 Requires(post): openssl-tools
142 Requires(post): sed >= 4.0
143 Requires(post,preun):   /sbin/chkconfig
144 Requires(postun):       /usr/sbin/groupdel
145 Requires(postun):       /usr/sbin/userdel
146 Requires(pre):  /usr/sbin/groupadd
147 Requires(pre):  /usr/sbin/useradd
148 Conflicts:      bacula-console < 0:1.34.6
149 Conflicts:      bacula-dir < 0:1.34.6
150 Conflicts:      bacula-fd < 0:1.34.6
151 Conflicts:      bacula-sd < 0:1.34.6
152
153 %description common
154 Bacula - It comes by night and sucks the vital essence from your
155 computers.
156
157 Bacula is a set of computer programs that permit you (or the system
158 administrator) to manage backup, recovery, and verification of
159 computer data across a network of computers of different kinds. In
160 technical terms, it is a network client/server based backup program.
161 Bacula is relatively easy to use and efficient, while offering many
162 advanced storage management features that make it easy to find and
163 recover lost or damaged files.
164
165 %description common -l pl.UTF-8
166 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
167
168 Bacula to zbiór programów umożliwiających administratorowi na
169 zarządzanie kopiami zapasowymi, odzyskiwaniem i weryfikacją danych w
170 sieci komputerów różnego rodzaju. W terminologii technicznej jest to
171 program do kopii zapasowych pracujący w architekturze klient-serwer.
172 Bacula jest stosunkowo łatwa w użyciu i wydajna, oferując przy tym
173 wiele zaawansowanych możliwości przy zarządzaniu nośnikami,
174 ułatwiających znalezienie i odzyskanie utraconych lub uszkodzonych
175 plików.
176
177 %package dir
178 Summary:        Bacula Director and Catalog services
179 Summary(pl.UTF-8):      Usługi Bacula Director i Catalog
180 Group:          Networking/Utilities
181 Requires(post): sed >= 4.0
182 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
183 Obsoletes:      bacula-updatedb
184
185 %description dir
186 Bacula - It comes by night and sucks the vital essence from your
187 computers.
188
189 Bacula Director is the program that supervises all the backup,
190 restore, verify and archive operations. The system administrator uses
191 the Bacula Director to schedule backups and to recover files. Catalog
192 services are comprised of the software programs responsible for
193 maintaining the file indexes and volume databases for all files backed
194 up. The Catalog services permit the System Administrator or user to
195 quickly locate and restore any desired file, since it maintains a
196 record of all Volumes used, all Jobs run, and all Files saved. This
197 build requires sqlite%{?with_sqlite3:3} to be installed separately as the catalog
198 database.
199
200 %description dir -l pl.UTF-8
201 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
202
203 Bacula Director to program nadzorujący wszystkie operacje wykonywania
204 kopii zapasowych, odzyskiwania, weryfikacji i archiwizowania.
205 Administrator używa Bacula Directora do szeregowania kopii zapasowych
206 oraz odzyskiwania plików. Usługi katalogowe (Catalog services) są
207 używane przez programy odpowiedzialne za zarządzanie indeksami plików
208 i bazą danych wolumenów dla wszystkich kopiowanych plików. Usługi
209 katalogowe umożliwiają administratorowi lub użytkownikowi szybko
210 zlokalizować i odtworzyć dowolny plik, ponieważ utrzymują rekord ze
211 wszystkimi używanymi wolumenami, uruchomionymi zadaniami i zapisanymi
212 plikami. Pakiet wymaga %{_database} zainstalowanego oddzielnie jako bazy
213 danych dla katalogu.
214
215 %package console
216 Summary:        Bacula Console
217 Summary(pl.UTF-8):      Konsola Baculi
218 Group:          Networking/Utilities
219 Requires(post): sed >= 4.0
220 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
221
222 %description console
223 Bacula - It comes by night and sucks the vital essence from your
224 computers.
225
226 Bacula Console is the program that allows the administrator or user to
227 communicate with the Bacula Director. This is the text only console
228 interface.
229
230 %description console -l pl.UTF-8
231 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
232
233 Bacula Console to program umożliwiający administratorowi lub
234 użytkownikowi komunikowanie się z programem Bacula Director. To jest
235 interfejs czysto tekstowy.
236
237 %package console-wx
238 Summary:        Bacula wxWidgets Console
239 Summary(pl.UTF-8):      Konsola Baculi oparta na wxWidgets
240 Group:          Networking/Utilities
241 Requires(post): sed >= 4.0
242 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
243
244 %description console-wx
245 Bacula - It comes by night and sucks the vital essence from your
246 computers.
247
248 Bacula Console is the program that allows the administrator or user to
249 communicate with the Bacula Director. This is the wxWidgets GUI
250 interface.
251
252 %description console-wx -l pl.UTF-8
253 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
254
255 Bacula Console to program umożliwiający administratorowi lub
256 użytkownikowi komunikowanie się z programem Bacula Director. To jest
257 interfejs graficzny oparty na wxWidgets.
258
259 %package console-gnome
260 Summary:        Bacula GNOME Console
261 Summary(pl.UTF-8):      Konsola Baculi oparta dla GNOME
262 Group:          Networking/Utilities
263 Requires(post): sed >= 4.0
264 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
265
266 %description console-gnome
267 Bacula - It comes by night and sucks the vital essence from your
268 computers.
269
270 Bacula Console is the program that allows the administrator or user to
271 communicate with the Bacula Director. This is the GNOME GUI interface.
272
273 %description console-gnome -l pl.UTF-8
274 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
275
276 Bacula Console to program umożliwiający administratorowi lub
277 użytkownikowi komunikowanie się z programem Bacula Director. To jest
278 interfejs graficzny oparty na GNOME.
279
280 %package console-qt4
281 Summary:        Bacula QT4 Console
282 Summary(pl.UTF-8):      Konsola Baculi oparta na QT4
283 Group:          Networking/Utilities
284 Requires(post): sed >= 4.0
285 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
286
287 %description console-qt4
288 Bacula - It comes by night and sucks the vital essence from your
289 computers.
290
291 Bacula Console is the program that allows the administrator or user to
292 communicate with the Bacula Director. This is the QT4 GUI interface.
293
294 %description console-qt4 -l pl.UTF-8
295 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
296
297 Bacula Console to program umożliwiający administratorowi lub
298 użytkownikowi komunikowanie się z programem Bacula Director. To jest
299 interfejs graficzny oparty na QT4.
300
301 %package tray-monitor
302 Summary:        Bacula Tray Monitor
303 Group:          Networking/Utilities
304 Requires(post): sed >= 4.0
305 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
306
307 %description tray-monitor
308 Bacula - It comes by night and sucks the vital essence from your
309 computers.
310
311 The Monitor program is typically an icon in the system tray. However,
312 once the icon is expanded into a full window, the administrator or
313 user can obtain status information about the Director or the backup
314 status on the local workstation or any other Bacula daemon that is
315 configured.
316
317 %package fd
318 Summary:        Bacula File services (Client)
319 Summary(pl.UTF-8):      Usługi Bacula File (klient)
320 Group:          Networking/Utilities
321 Requires(post): sed >= 4.0
322 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
323
324 %description fd
325 Bacula - It comes by night and sucks the vital essence from your
326 computers.
327
328 Bacula File services (or Client program) is the software program that
329 is installed on the machine to be backed up. It is specific to the
330 operating system on which it runs and is responsible for providing the
331 file attributes and data when requested by the Director. The File
332 services are also responsible for the file system dependent part of
333 restoring the file attributes and data during a recovery operation.
334 This program runs as a daemon on the machine to be backed up, and in
335 some of the documentation, the File daemon is referred to as the
336 Client (for example in Bacula configuration file).
337
338 %description fd -l pl.UTF-8
339 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
340
341 Usługi Bacula File (inaczej program kliencki) to oprogramowanie, które
342 instaluje się na maszynach, z których mają być wykonywane kopie
343 zapasowe. Są one specyficzne dla systemu operacyjnego, pod którym
344 działa dana maszyna i odpowiadają za dostarczanie atrybutów i danych
345 plików na żądanie Directora. Usługi plikowe są także odpowiedzialne za
346 zależną od systemu plików część odzyskiwania atrybutów i danych plików
347 podczas operacji odzyskiwania danych. Program działa jako demon na
348 maszynie, która ma być backupowana i w części dokumentacji demon ten
349 (File) jest nazywany klientem (na przykład w pliku konfiguracyjnym
350 Baculi).
351
352 %package sd
353 Summary:        Bacula Storage services
354 Summary(pl.UTF-8):      Usługi Bacula Storage
355 Group:          Networking/Utilities
356 Requires(post): sed >= 4.0
357 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
358 Conflicts:      dvd+rw-tools <= 5.21.4.10.8-1
359
360 %description sd
361 Bacula - It comes by night and sucks the vital essence from your
362 computers.
363
364 Bacula Storage services consist of the software programs that perform
365 the storage and recovery of the file attributes and data to the
366 physical backup media or volumes. In other words, the Storage daemon
367 is responsible for reading and writing your tapes (or other storage
368 media, e.g. files). The Storage services runs as a daemon on the
369 machine that has the backup device (usually a tape drive).
370
371 %description sd -l pl.UTF-8
372 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
373
374 Usługi Bacula Storage składają się z programów obsługujących
375 przechowywanie danych oraz odzyskiwanie atrybutów i danych na
376 fizycznych nośnikach lub wolumenach. Innymi słowy, demon Storage jest
377 odpowiedzialny za odczyt i zapis taśm (lub innych nośników do
378 przechowywania danych, np. plików). Usługi Storage działają jako demon
379 na maszynie, która zawiera urządzenie backupowe (zwykle napęd
380 taśmowy).
381
382 %package rescue
383 Summary:        Bacula - The Network Backup Solution
384 Summary(pl.UTF-8):      Bacula - rozwiązanie do wykonywania kopii zapasowych po sieci
385 Group:          Networking/Utilities
386 Requires:       %{name}-fd = %{epoch}:%{version}-%{release}
387 Requires:       coreutils
388 Requires:       util-linux
389
390 %description rescue
391 Bacula - It comes by night and sucks the vital essence from your
392 computers.
393
394 Bacula is a set of computer programs that permit you (or the system
395 administrator) to manage backup, recovery, and verification of
396 computer data across a network of computers of different kinds. In
397 technical terms, it is a network client/server based backup program.
398 Bacula is relatively easy to use and efficient, while offering many
399 advanced storage management features that make it easy to find and
400 recover lost or damaged files.
401
402 This package installs scripts for disaster recovery and builds rescue
403 floppy disk for bare metal recovery.
404
405 To make the bacula rescue disk run "./make_rescue_disk
406 --copy-static-bacula
407 - --copy-etc-files" from the %{_sysconfdir}/rescue directory. To
408   recreate the rescue information for this system run ./getdiskinfo
409   again.
410
411 %description rescue -l pl.UTF-8
412 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
413
414 Bacula to zbiór programów umożliwiających administratorowi na
415 zarządzanie kopiami zapasowymi, odzyskiwaniem i weryfikacją danych w
416 sieci komputerów różnego rodzaju. W terminologii technicznej jest to
417 program do kopii zapasowych pracujący w architekturze klient-serwer.
418 Bacula jest stosunkowo łatwa w użyciu i wydajna, oferując przy tym
419 wiele zaawansowanych możliwości przy zarządzaniu nośnikami,
420 ułatwiających znalezienie i odzyskanie utraconych lub uszkodzonych
421 plików.
422
423 Ten pakiet zawiera skrypty do odtwarzania po awarii i tworzy dyskietkę
424 ratunkowe do odtwarzania systemu od zera.
425
426 Aby stworzyć dyskietkę ratunkową Baculi, należy uruchomić "./make_rescue_disk
427 --copy-static-bacula - --copy-etc-files" z katalogu
428 %{_sysconfdir}/rescue . Aby ponownie utworzyć informacje ratunkowe dla
429 danego systemu, należy ponownie uruchomić ./getdiskinfo .
430
431 %prep
432 %setup -q -a 1
433
434 %patch0 -p1
435 %patch1 -p1
436 #%patch2 -p1
437 #%patch3 -p1
438 #%patch4 -p1
439
440 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
441 sed -i -e 's#wx-config#wx-gtk2-unicode-config#g' configure*
442 sed -i -e 's#-lreadline -lhistory -ltermcap#-lreadline -lhistory#g' configure*
443 sed -i -e 's#bindir=.*#bindir=%{_bindir}#g' \
444         src/cats/create_* src/cats/delete_* src/cats/drop_* \
445         src/cats/grant_* src/cats/make_* src/cats/update_*
446 sed -i -e 's/@hostname@/--hostname--/' src/*/*.conf.in
447
448 %build
449 cp -f %{_datadir}/automake/config.sub autoconf
450 CPPFLAGS="-I/usr/include/ncurses -I%{_includedir}/readline"
451 %configure \
452         --with-scriptdir=%{_libexecdir}/%{name} \
453         --%{!?with_gnome:dis}%{?with_gnome:en}able-gnome \
454         %{?with_bat:--enable-bat} \
455         --disable-conio \
456         --enable-smartalloc \
457         %{?with_console_wx:--enable-bwx-console} \
458         --enable-tray-monitor \
459         %{?with_python:--with-python} \
460         --with-readline \
461         --with-tcp-wrappers \
462         --with-working-dir=%{_var}/lib/%{name} \
463         --with-dump-email="root@localhost" \
464         --with-job-email="root@localhost" \
465         --with-smtp-host=localhost \
466         --with-pid-dir=/var/run \
467         --with-subsys-dir=/var/lock/subsys \
468         --with-%{_database} \
469         %{?with_sqlite3_sync_off:--enable-extra-sqlite3-init="pragma synchronous=0;"} \
470         --with-dir-password="#FAKE-dir-password#" \
471         --with-fd-password="#FAKE-fd-password#" \
472         --with-sd-password="#FAKE-sd-password#" \
473         --with-mon-dir-password="#FAKE-mon-dir-password#" \
474         --with-mon-fd-password="#FAKE-mon-fd-password#" \
475         --with-mon-sd-password="#FAKE-mon-sd-password#" \
476         --with-openssl
477
478 %if %{with bat}
479 cd src/qt-console
480 qt4-qmake bat.pro
481 cd ../..
482 %endif
483
484 %{__make}
485
486 %if %{with rescue}
487 cd rescue
488 %configure \
489         --with-bacula=../
490 cd linux/cdrom
491 fakeroot %{__make}
492 %endif
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496
497 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,pam.d,sysconfig}
498 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rescue
499 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_mandir},%{_bindir}}
500
501 %{__make} install \
502         DESTDIR=$RPM_BUILD_ROOT
503
504 # static daemon
505 #strip -R.comment -R.note src/filed/static-bacula-fd
506 #install src/filed/static-bacula-fd $RPM_BUILD_ROOT%{_sysconfdir}/rescue/bacula-fd
507
508 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/bacula-dir
509 install %{SOURCE11} $RPM_BUILD_ROOT/etc/rc.d/init.d/bacula-fd
510 install %{SOURCE12} $RPM_BUILD_ROOT/etc/rc.d/init.d/bacula-sd
511 install %{SOURCE13} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-dir
512 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/bacula-dir
513 install %{SOURCE15} $RPM_BUILD_ROOT/etc/sysconfig/bacula-fd
514 install %{SOURCE16} $RPM_BUILD_ROOT/etc/sysconfig/bacula-sd
515
516 %if %{with console_wx}
517 # tray-monitor is for regular users
518 mv $RPM_BUILD_ROOT%{_sbindir}/bacula-tray-monitor $RPM_BUILD_ROOT%{_bindir}
519
520 install scripts/bacula.png $RPM_BUILD_ROOT%{_pixmapsdir}/bacula.png
521 install src/tray-monitor/generic.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/bacula-tray-monitor.xpm
522 install scripts/bacula.desktop.gnome2 $RPM_BUILD_ROOT%{_desktopdir}/bacula.desktop
523 sed -e 's/gnome-console/wx-console/g;s/Console/Wx Console/g' \
524         scripts/bacula.desktop.gnome2 > $RPM_BUILD_ROOT%{_desktopdir}/bacula-wx.desktop
525 sed -e 's#%{_sbindir}#%{_bindir}#' \
526         scripts/bacula-tray-monitor.desktop > $RPM_BUILD_ROOT%{_desktopdir}/bacula-tray-monitor.desktop
527 %endif
528
529 %if %{with bat}
530 install src/qt-console/bat $RPM_BUILD_ROOT%{_sbindir}
531 install scripts/bat.desktop $RPM_BUILD_ROOT%{_desktopdir}
532 %endif
533
534 %if %{with rescue}
535 # install the rescue stuff, these are the rescue scripts
536 install rescue/linux/floppy/backup.etc.list $RPM_BUILD_ROOT%{_sysconfdir}/rescue
537 install rescue/linux/floppy/*_* $RPM_BUILD_ROOT%{_sysconfdir}/rescue
538 install rescue/linux/floppy/getdiskinfo $RPM_BUILD_ROOT%{_sysconfdir}/rescue
539 install rescue/linux/floppy/sfdisk.bz2 $RPM_BUILD_ROOT%{_sysconfdir}/rescue
540 %endif
541
542 # install the updatedb scripts
543 install updatedb/update_sqlite* $RPM_BUILD_ROOT%{_libexecdir}/%{name}
544
545 # place for site passwords
546 touch $RPM_BUILD_ROOT%{_sysconfdir}/{dir-password,fd-password,sd-password}
547 touch $RPM_BUILD_ROOT%{_sysconfdir}/{mon-dir-password,mon-fd-password,mon-sd-password}
548
549 # some file changes
550 rm -f $RPM_BUILD_ROOT%{_libexecdir}/%{name}/{gconsole,startmysql,stopmysql,bacula,bconsole,fd}
551 rm -f $RPM_BUILD_ROOT%{_sbindir}/static-bacula-fd
552 %if !%{with console_wx}
553 rm -f $RPM_BUILD_ROOT%{_desktopdir}/bacula-wx.desktop
554 %endif
555 touch $RPM_BUILD_ROOT%{_sysconfdir}/.pw.sed
556
557 %clean
558 rm -rf $RPM_BUILD_ROOT
559
560 %pre common
561 %groupadd -P %{name}-common -g 136 -r -f bacula
562 %useradd -P %{name}-common -u 136 -r -d /var/lib/bacula -s /bin/false -c "Bacula User" -g bacula bacula
563
564 %post common
565 echo "Updating bacula passwords and names..."
566 cd /etc/bacula
567 for f in *-password ; do
568         if [ ! -s $f ] ; then
569                 openssl rand -base64 33 > $f
570         fi
571         p=`cat $f`
572         for cf in *.conf *.conf.rpmnew ; do
573                 [ -f $cf ] && sed -i -e"s:#FAKE-$f#:$p:" "$cf" || :
574         done
575 done
576 for cf in *.conf *.conf.rpmnew ; do
577         [ -f $cf ] && sed -i -e"s:--hostname--:`hostname`:" "$cf" || :
578 done
579
580 %postun common
581 if [ "$1" = "0" ]; then
582         %userremove bacula
583         %groupremove bacula
584 fi
585
586 %post dir
587 umask 077
588 [ -s %{_localstatedir}/bacula.db ] && \
589         DB_VER=`echo "select * from Version;" | \
590         %{_bindir}/sqlite%{?with_sqlite3:3} %{_localstatedir}/bacula.db | tail -n 1 2>/dev/null`
591 if [ -z "$DB_VER" ]; then
592 # grant privileges and create tables
593         %{_libexecdir}/%{name}/grant_bacula_privileges > dev/null
594         %{_libexecdir}/%{name}/create_bacula_database > dev/null
595         %{_libexecdir}/%{name}/make_bacula_tables > dev/null
596 elif [ "$DB_VER" -lt "9" ]; then
597         echo "Backing up bacula tables"
598         echo ".dump" | sqlite%{?with_sqlite3:3} %{_localstatedir}/bacula.db | bzip2 > %{_localstatedir}/bacula_backup.sql.bz2
599         echo "Upgrading bacula tables"
600         %if %{with sqlite3}
601                 type=sqlite3
602                 if [ "$DB_VER" -lt "9" ]; then
603                         %{_libexecdir}/%{name}/update_${type}_tables_8_to_9
604                 fi
605         %endif
606         %if %{with sqlite}
607                 type=sqlite
608                 if [ "$DB_VER" -lt "9" ]; then
609                         if [ "$DB_VER" -lt "8" ]; then
610                                 if [ "$DB_VER" -lt "7" ]; then
611                                         if [ "$DB_VER" -lt "6" ]; then
612                                                 if [ "$DB_VER" -lt "5" ]; then
613                                                         %{_libexecdir}/%{name}/update_${type}_tables_4_to_5
614                                                 fi
615                                                 %{_libexecdir}/%{name}/update_${type}_tables_5_to_6
616                                         fi
617                                         %{_libexecdir}/%{name}/update_${type}_tables_6_to_7
618                                 fi
619                                 %{_libexecdir}/%{name}/update_${type}_tables_7_to_8
620                         fi
621                         %{_libexecdir}/%{name}/update_${type}_tables_8_to_9
622                 fi
623         %endif
624         %{_libexecdir}/%{name}/update_bacula_tables
625         echo "If bacula works correctly you can remove the backup file %{_localstatedir}/bacula_backup.sql.bz2"
626 fi
627 chown -R bacula:bacula %{_localstatedir}
628 chmod -R u+rX,go-rwx %{_localstatedir}/*
629
630 echo "Updating Bacula passwords and names..."
631 cd /etc/bacula
632 for f in *-password ; do
633         p=`cat $f`
634         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
635 done
636 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
637
638 /sbin/chkconfig --add bacula-dir
639 %service bacula-dir restart "Bacula Director daemon"
640
641 %preun dir
642 if [ "$1" = "0" ]; then
643         %service bacula-dir stop
644         /sbin/chkconfig --del bacula-dir
645 fi
646
647 %post fd
648 echo "Updating Bacula passwords and names..."
649 cd /etc/bacula
650 for f in *-password ; do
651         p=`cat $f`
652         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
653 done
654 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
655
656 /sbin/chkconfig --add bacula-fd
657 %service bacula-fd restart "Bacula File daemon"
658
659 %preun fd
660 if [ "$1" = "0" ]; then
661         %service bacula-fd stop
662         /sbin/chkconfig --del bacula-fd
663 fi
664
665 %post sd
666 echo "Updating Bacula passwords and names..."
667 cd /etc/bacula
668 for f in *-password ; do
669         p=`cat $f`
670         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
671 done
672 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
673
674 /sbin/chkconfig --add bacula-sd
675 %service bacula-sd restart "Bacula Storage daemon"
676
677 %preun sd
678 if [ "$1" = "0" ]; then
679         %service bacula-sd stop
680         /sbin/chkconfig --del bacula-sd
681 fi
682
683 %pre console
684 if [ -e %{_sysconfdir}/console.conf -a ! -e %{_sysconfdir}/bconsole.conf ]; then
685         mv %{_sysconfdir}/console.conf %{_sysconfdir}/bconsole.conf
686 fi
687
688 %post console
689 echo "Updating Bacula passwords and names..."
690 cd /etc/bacula
691 for f in *-password ; do
692         p=`cat $f`
693         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
694 done
695 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
696
697 %post console-wx
698 echo "Updating Bacula passwords and names..."
699 cd /etc/bacula
700 for f in *-password ; do
701         p=`cat $f`
702         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
703 done
704 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
705
706 %post console-gnome
707 echo "Updating Bacula passwords and names..."
708 cd /etc/bacula
709 for f in *-password ; do
710         p=`cat $f`
711         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
712 done
713 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
714
715 %post console-qt4
716 echo "Updating Bacula passwords and names..."
717 cd /etc/bacula
718 for f in *-password ; do
719         p=`cat $f`
720         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
721 done
722 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
723
724 %post tray-monitor
725 echo "Updating Bacula passwords and names..."
726 cd /etc/bacula
727 for f in *-password ; do
728         p=`cat $f`
729         sed -i -e"s:#FAKE-$f#:$p:" *.conf *.conf.rpmnew 2>/dev/null || :
730 done
731 sed -i -e"s:--hostname--:`hostname`:" *.conf *.conf.rpmnew 2>/dev/null || :
732
733 %post rescue
734 # link our current installed conf file to the rescue directory
735 ln -sf %{_sysconfdir}/bacula-fd.conf %{_sysconfdir}/rescue/bacula-fd.conf
736
737 # run getdiskinfo
738 echo "Creating rescue files for this system..."
739 cd %{_sysconfdir}/rescue
740 ./getdiskinfo
741
742 %preun rescue
743 # remove the files created after the initial rpm installation
744 if [ "$1" = "0" ]; then
745         rm -f %{_sysconfdir}/rescue/bacula-fd.conf
746         rm -f %{_sysconfdir}/rescue/partition.*
747         rm -f %{_sysconfdir}/rescue/format.*
748         rm -f %{_sysconfdir}/rescue/mount_drives
749         rm -f %{_sysconfdir}/rescue/start_network
750         rm -f %{_sysconfdir}/rescue/sfdisk
751         rm -rf %{_sysconfdir}/rescue/diskinfo/*
752 fi
753
754 %files common
755 %defattr(644,root,root,755)
756 %doc LICENSE
757 %dir %{_sysconfdir}
758 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*-password
759 %attr(755,root,root) %{_sbindir}/bsmtp
760 %attr(755,root,root) %{_sbindir}/btraceback
761 %{_mandir}/man8/bacula.8*
762 %{_mandir}/man1/bsmtp.1*
763 %{_mandir}/man8/btraceback.8*
764 %dir %{_libexecdir}/%{name}
765 %{_libexecdir}/%{name}/btraceback.dbx
766 %{_libexecdir}/%{name}/btraceback.gdb
767 %attr(770,root,bacula) %dir %{_localstatedir}
768
769 %files dir
770 %defattr(644,root,root,755)
771 %doc ChangeLog CheckList ReleaseNotes kernstodo LICENSE
772 #%doc examples %{name}-docs-%{version}/manual/{*.pdf,bacula}
773 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bacula-dir.conf
774 %ghost %{_sysconfdir}/.pw.sed
775 %attr(640,root,root) %config(noreplace) /etc/logrotate.d/bacula-dir
776 %attr(754,root,root) /etc/rc.d/init.d/bacula-dir
777 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bacula-dir
778 %attr(755,root,root) %{_sbindir}/bacula-dir
779 %attr(755,root,root) %{_sbindir}/bregex
780 %attr(755,root,root) %{_sbindir}/bwild
781 %attr(755,root,root) %{_sbindir}/dbcheck
782 %{_mandir}/man8/bacula-dir.8*
783 %{_mandir}/man8/dbcheck.8*
784 %{_libexecdir}/%{name}/query.sql
785 %if %{with sqlite3}
786 %attr(755,root,root) %{_libexecdir}/%{name}/create_sqlite3_database
787 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_database
788 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_tables
789 %attr(755,root,root) %{_libexecdir}/%{name}/grant_sqlite3_privileges
790 %attr(755,root,root) %{_libexecdir}/%{name}/make_sqlite3_tables
791 %attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite3_*
792 %endif
793 %if %{with sqlite}
794 %attr(755,root,root) %{_libexecdir}/%{name}/create_sqlite_database
795 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite_database
796 %attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite_tables
797 %attr(755,root,root) %{_libexecdir}/%{name}/grant_sqlite_privileges
798 %attr(755,root,root) %{_libexecdir}/%{name}/make_sqlite_tables
799 %attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite_*
800 %endif
801 %if %{with mysql}
802 %attr(755,root,root) %{_libexecdir}/%{name}/create_mysql_database
803 %attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_database
804 %attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_tables
805 %attr(755,root,root) %{_libexecdir}/%{name}/grant_mysql_privileges
806 %attr(755,root,root) %{_libexecdir}/%{name}/make_mysql_tables
807 %attr(755,root,root) %{_libexecdir}/%{name}/update_mysql_*
808 %endif
809 %if %{with pgsql}
810 %attr(755,root,root) %{_libexecdir}/%{name}/create_postgresql_database
811 %attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_database
812 %attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_tables
813 %attr(755,root,root) %{_libexecdir}/%{name}/grant_postgresql_privileges
814 %attr(755,root,root) %{_libexecdir}/%{name}/make_postgresql_tables
815 %attr(755,root,root) %{_libexecdir}/%{name}/update_postgresql_*
816 %endif
817 %attr(755,root,root) %{_libexecdir}/%{name}/create_bacula_database
818 %attr(755,root,root) %{_libexecdir}/%{name}/drop_bacula_database
819 %attr(755,root,root) %{_libexecdir}/%{name}/drop_bacula_tables
820 %attr(755,root,root) %{_libexecdir}/%{name}/grant_bacula_privileges
821 %attr(755,root,root) %{_libexecdir}/%{name}/make_bacula_tables
822 %attr(755,root,root) %{_libexecdir}/%{name}/update_bacula_tables
823 %attr(755,root,root) %{_libexecdir}/%{name}/make_catalog_backup
824 %attr(755,root,root) %{_libexecdir}/%{name}/delete_catalog_backup
825
826 %files fd
827 %defattr(644,root,root,755)
828 %doc LICENSE
829 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bacula-fd.conf
830 %attr(754,root,root) /etc/rc.d/init.d/bacula-fd
831 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bacula-fd
832 %attr(755,root,root) %{_sbindir}/bacula-fd
833 %{_mandir}/man8/bacula-fd.8*
834
835 %files sd
836 %defattr(644,root,root,755)
837 %doc LICENSE
838 %dir %{_sysconfdir}
839 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bacula-sd.conf
840 %attr(754,root,root) /etc/rc.d/init.d/bacula-sd
841 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bacula-sd
842 %attr(755,root,root) %{_sbindir}/bacula-sd
843 %attr(755,root,root) %{_sbindir}/bcopy
844 %attr(755,root,root) %{_sbindir}/bextract
845 %attr(755,root,root) %{_sbindir}/bls
846 %attr(755,root,root) %{_sbindir}/bscan
847 %attr(755,root,root) %{_sbindir}/btape
848 %attr(755,root,root) %{_libexecdir}/%{name}/mtx-changer
849 %attr(755,root,root) %{_libexecdir}/%{name}/disk-changer
850 %attr(755,root,root) %{_libexecdir}/%{name}/dvd-handler
851 %{_mandir}/man8/bacula-sd.8*
852 %{_mandir}/man8/bcopy.8*
853 %{_mandir}/man8/bextract.8*
854 %{_mandir}/man8/bls.8*
855 %{_mandir}/man8/bscan.8*
856 %{_mandir}/man8/btape.8*
857
858 %files console
859 %defattr(644,root,root,755)
860 %doc LICENSE
861 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bconsole.conf
862 %attr(755,root,root) %{_sbindir}/bconsole
863 %{_mandir}/man8/bconsole.8*
864
865 %if %{with console_wx}
866 %files console-wx
867 %defattr(644,root,root,755)
868 %doc LICENSE
869 %{_pixmapsdir}/%{name}.png
870 %{_desktopdir}/bacula-wx.desktop
871 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bwx-console.conf
872 %attr(755,root,root) %{_sbindir}/bwx-console
873 %{_mandir}/man1/bacula-bwxconsole.1*
874 %endif
875
876 %if %{with gnome}
877 %files console-gnome
878 %defattr(644,root,root,755)
879 %doc LICENSE
880 %{_pixmapsdir}/%{name}.png
881 %{_desktopdir}/bacula.desktop
882 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bgnome-console.conf
883 %attr(755,root,root) %{_sbindir}/bgnome-console
884 %{_mandir}/man1/bacula-bgnome-console.1*
885 %endif
886
887 %if %{with bat}
888 %files console-qt4
889 %defattr(644,root,root,755)
890 %doc LICENSE
891 %{_pixmapsdir}/%{name}.png
892 %{_desktopdir}/bat.desktop
893 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bat.conf
894 %attr(755,root,root) %{_sbindir}/bat
895 %{_mandir}/man1/bat.1*
896 %endif
897
898 %if %{with console_wx}
899 %files tray-monitor
900 %defattr(644,root,root,755)
901 %doc LICENSE
902 %{_pixmapsdir}/%{name}-tray-monitor.xpm
903 %{_desktopdir}/%{name}-tray-monitor.desktop
904 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/tray-monitor.conf
905 %attr(755,root,root) %{_bindir}/bacula-tray-monitor
906 %{_mandir}/man1/bacula-tray-monitor.1*
907 %endif
908
909 %if %{with rescue}
910 %files rescue
911 %defattr(644,root,root,755)
912 %doc LICENSE
913 %dir %{_sysconfdir}/rescue
914 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/backup.etc.list
915 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/bacula-fd
916 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/format_floppy
917 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/getdiskinfo
918 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/make_rescue_disk
919 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/restore_bacula
920 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/restore_etc
921 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/run_grub
922 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/run_lilo
923 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rescue/sfdisk.bz2
924 %endif
This page took 0.075545 seconds and 2 git commands to generate.