]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
- new, needs more deps packaged
[packages/axis.git] / axis.spec
1 # TODO
2 #  - servletapi5 is needed by axis-1.2.1-0.2jpp.1.noarch
3 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
4 %define archivever %(echo %{version} | tr . _)
5 Summary:        A SOAP implementation in Java
6 Name:           axis
7 Version:        1.2.1
8 Release:        0.2jpp.1
9 License:        Apache Software License
10 Group:          Development/Languages/Java
11 URL:            http://ws.apache.org/axis/
12 Source0:        %{url}/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
13 # Source0-md5:  157ad070accf373565bce80de1204a4d
14 #BuildRequires: ant-nodeps
15 BuildRequires:  jakarta-ant >= 1.6
16 BuildRequires:  jdk
17 # Mandatory requires
18 BuildRequires:  jaf
19 BuildRequires:  jakarta-commons-discovery
20 BuildRequires:  jakarta-commons-httpclient3
21 BuildRequires:  jakarta-commons-logging
22 BuildRequires:  jakarta-log4j
23 BuildRequires:  javamail
24 BuildRequires:  jaxp_parser_impl
25 BuildRequires:  servletapi5
26 BuildRequires:  wsdl4j
27 # optional requires
28 BuildRequires:  castor
29 BuildRequires:  httpunit
30 BuildRequires:  jakarta-oro
31 BuildRequires:  jimi
32 BuildRequires:  jms
33 BuildRequires:  jsse
34 BuildRequires:  junit
35 #BuildRequires: xml-security
36 Requires:       jaf
37 Requires:       jakarta-commons-discovery
38 Requires:       jakarta-commons-httpclient3
39 Requires:       jakarta-commons-logging
40 Requires:       java
41 Requires:       javamail
42 Requires:       jaxp_parser_impl
43 #Requires:      jpackage-utils >= 0:1.5
44 Requires:       log4j
45 Requires:       wsdl4j
46 BuildArch:      noarch
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Apache AXIS is an implementation of the SOAP ("Simple Object Access
51 Protocol") submission to W3C.
52
53 From the draft W3C specification:
54
55 SOAP is a lightweight protocol for exchange of information in a
56 decentralized, distributed environment. It is an XML based protocol
57 that consists of three parts: an envelope that defines a framework for
58 describing what is in a message and how to process it, a set of
59 encoding rules for expressing instances of application-defined
60 datatypes, and a convention for representing remote procedure calls
61 and responses.
62
63 This project is a follow-on to the Apache SOAP project.
64
65 %package javadoc
66 Summary:        Javadoc for %{name}
67 Group:          Development/Languages/Java
68
69 %description javadoc
70 Javadoc for %{name}.
71
72 %package manual
73 Summary:        Manual for %{name}
74 Group:          Development/Languages/Java
75
76 %description manual
77 Documentation for %{name}.
78
79 %prep
80 %setup -q -n %{name}-%{archivever}
81
82 # Remove provided binaries
83 find . -name "*.jar" -exec rm -f {} \;
84 find . -name "*.zip" -exec rm -f {} \;
85 find . -name "*.class" -exec rm -f {} \;
86
87 %build
88
89 [ -z "$JAVA_HOME" ] && export JAVA_HOME=%{_jvmdir}/java
90
91 CLASSPATH=$(build-classpath wsdl4j jakarta-commons-discovery jakarta-commons-httpclient3 jakarta-commons-logging log4j jaf javamail/mailapi servletapi5)
92 export CLASSPATH=$CLASSPATH:$(build-classpath oro junit jimi xml-security jsse httpunit jms castor 2>/dev/null)
93
94 export OPT_JAR_LIST="ant/ant-nodeps"
95 ant -Dcompile.ime=true \
96         -Dwsdl4j.jar=$(build-classpath wsdl4j) \
97         -Dcommons-discovery.jar=$(build-classpath jakarta-commons-discovery) \
98         -Dcommons-logging.jar=$(build-classpath jakarta-commons-logging) \
99         -Dcommons-httpclient.jar=$(build-classpath jakarta-commons-httpclient3) \
100         -Dlog4j-core.jar=$(build-classpath log4j) \
101         -Dactivation.jar=$(build-classpath jaf) \
102         -Dmailapi.jar=$(build-classpath javamail/mailapi) \
103         -Dxerces.jar=$(build-classpath jaxp_parser_impl) \
104         -Dservlet.jar=$(build-classpath servletapi5) \
105         -Dregexp.jar=$(build-classpath oro 2>/dev/null) \
106         -Djunit.jar=$(build-classpath junit 2>/dev/null) \
107         -Djimi.jar=$(build-classpath jimi 2>/dev/null) \
108         -Djsse.jar=$(build-classpath jsse/jsse 2>/dev/null) \
109         clean compile javadocs
110
111 %install
112
113 rm -rf $RPM_BUILD_ROOT
114 ### Jar files
115
116 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
117
118 cd build/lib
119    install -m 644 axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
120            $RPM_BUILD_ROOT%{_javadir}/%{name}
121 cd -
122
123 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
124         for jar in *.jar ; do
125                 vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
126                 mv $jar $vjar
127                 ln -fs $vjar $jar
128         done
129 cd -
130
131 ### Javadoc
132
133 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
134 cp -pr build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
135
136 cd docs
137    rm -fr apiDocs
138    ln -fs %{_javadocdir}/%{name} apiDocs
139 cd -
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post javadoc
145 rm -f %{_javadocdir}/%{name}
146 ln -s %{name}-%{version} %{_javadocdir}/%{name}
147
148 %postun javadoc
149 if [ "$1" = "0" ]; then
150         rm -f %{_javadocdir}/%{name}
151 fi
152
153 %files
154 %defattr(644,root,root,755)
155 %doc LICENSE README release-notes.html changelog.html
156 %dir %{_javadir}/%{name}
157 %{_javadir}/%{name}/*.jar
158
159 %files javadoc
160 %defattr(644,root,root,755)
161 %dir %{_javadocdir}/%{name}-%{version}
162 %{_javadocdir}/%{name}-%{version}/*
163
164 %files manual
165 %defattr(644,root,root,755)
166 %doc docs/*
This page took 0.097719 seconds and 3 git commands to generate.