]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- do not provide /etc/dhclient-{enter,exit}-hooks.d (reverts r 1.108)
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 #       - finish with_apidocs
4 #       - check BRs for gtk+3
5 #       - make gtk3 bcond enabled by default when gtk+3 will be stable
6 #       - introspection files
7 #       - dbus files
8 #
9 # Conditional build:
10 %bcond_with     apidocs         # build API documentation
11 %bcond_without  dotnet          # build without dotnet bindings
12 %bcond_without  gtk             # build without GTK+
13 %bcond_with     gtk3            # build without GTK+3
14 %bcond_without  pygtk           # build without PyGTK
15 %bcond_without  qt              # build without (any) qt bindings
16 %bcond_without  qt3             # build without qt3 bindings
17 %bcond_without  qt4             # build without qt4 bindings
18
19 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
20 %undefine with_dotnet
21 %endif
22 %ifarch i386
23 %undefine with_dotnet
24 %endif
25
26 %if %{without qt}
27 %undefine       with_qt3
28 %undefine       with_qt4
29 %endif
30
31 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
32 Summary:        Free mDNS/DNS-SD/Zeroconf implementation
33 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD/Zeroconf
34 Name:           avahi
35 Version:        0.6.28
36 Release:        2
37 License:        LGPL v2.1+
38 Group:          Applications
39 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
40 # Source0-md5:  d0143a5aa3265019072e53ab497818d0
41 Source1:        %{name}-daemon
42 Source2:        %{name}-dnsconfd
43 Source3:        %{name}.png
44 Source4:        %{name}-daemon.upstart
45 Source5:        %{name}-dnsconfd.upstart
46 Patch0:         %{name}-desktop.patch
47 Patch1:         %{name}-glade.patch
48 Patch2:         %{name}-destdir.patch
49 Patch3:         %{name}-mono-dir.patch
50 Patch4:         nss-mdns-package.patch
51 Patch5:         %{name}-dhclient_hooks.patch
52 Patch6:         %{name}-autoipd-sbin_ip.patch
53 URL:            http://avahi.org/
54 BuildRequires:  autoconf >= 2.63
55 BuildRequires:  automake >= 1:1.11
56 BuildRequires:  dbus-devel >= 0.92
57 %if %{with apidocs}
58 BuildRequires:  doxygen
59 # for the 'dot' tool used by doxygen
60 BuildRequires:  graphviz
61 %endif
62 BuildRequires:  expat-devel
63 BuildRequires:  gdbm-devel
64 BuildRequires:  gettext-devel
65 BuildRequires:  gobject-introspection-devel >= 0.9.5
66 %if %{with gtk}
67 BuildRequires:  glib2-devel >= 1:2.12.2
68 BuildRequires:  gtk+2-devel >= 2:2.14.0
69 BuildRequires:  libglade2-devel >= 1:2.6.0
70 %endif
71 %if %{with gtk3}
72 BuildRequires:  glib2-devel
73 BuildRequires:  gtk+3-devel
74 BuildRequires:  libglade2-devel
75 %endif
76 BuildRequires:  intltool >= 0.35
77 BuildRequires:  libcap-devel
78 BuildRequires:  libdaemon-devel >= 0.14
79 BuildRequires:  libtool
80 %if %{with dotnet}
81 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
82 BuildRequires:  mono-csharp
83 BuildRequires:  monodoc >= 2.6
84 %endif
85 BuildRequires:  pkgconfig
86 BuildRequires:  python >= 1:2.4
87 BuildRequires:  python-dbus >= 0.71
88 %{?with_pygtk:BuildRequires:    python-pygtk-devel >= 2:2.9.6}
89 %if %{with qt3}
90 BuildRequires:  qt-devel >= 1:3.0
91 %endif
92 %if %{with qt4}
93 BuildRequires:  QtCore-devel >= 4.0.0
94 BuildRequires:  qt4-build
95 %endif
96 BuildRequires:  rpm-pythonprov
97 BuildRequires:  rpmbuild(macros) >= 1.561
98 Requires(post,preun):   /sbin/chkconfig
99 Requires:       %{name}-libs = %{version}-%{release}
100 Requires:       dbus >= 0.92
101 Requires:       libdaemon >= 0.14
102 Requires:       rc-scripts >= 0.4.3
103 Suggests:       nss_mdns >= 0.10-2
104 Provides:       group(avahi)
105 Provides:       user(avahi)
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %description
109 Avahi is an implementation the DNS Service Discovery and Multicast DNS
110 specifications for Zeroconf Computing. It uses D-BUS for communication
111 between user applications and a system daemon.
112
113 %description -l pl.UTF-8
114 Avahi jest implementacją specyfikacji DNS Service Discovery i
115 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
116 pomiędzy programami użytkownika a demonem systemowym.
117
118 %package upstart
119 Summary:        Upstart jobs description for Avahi daemons
120 Summary(pl.UTF-8):      Opis zadań Upstart dla demonów Avahi
121 Group:          Daemons
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       upstart >= 0.6
124
125 %description upstart
126 Upstart jobs description for Avahi daemons.
127
128 %description upstart -l pl.UTF-8
129 Opis zadań Upstart dla demonów Avahi.
130
131 %package autoipd
132 Summary:        IPv4LL network address configuration daemon
133 Summary(pl.UTF-8):      Demon configurujący adresy IPv4LL
134 Group:          Networking/Daemons
135 Requires(postun):       /usr/sbin/groupdel
136 Requires(postun):       /usr/sbin/userdel
137 Requires(pre):  /bin/id
138 Requires(pre):  /usr/bin/getgid
139 Requires(pre):  /usr/sbin/groupadd
140 Requires(pre):  /usr/sbin/useradd
141 Provides:       group(avahi)
142 Provides:       user(avahi)
143
144 %description autoipd
145 avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4 Link-
146 Local Addresses" (IETF RFC3927), a protocol for automatic IP address
147 configuration from the link-local 169.254.0.0/16 range without the
148 need for a central server. It is primarily intended to be used in
149 ad-hoc networks which lack a DHCP server.
150
151 IPv4LL is part of the Zeroconf stack.
152
153 %description autoipd -l pl.UTF-8
154 avahi-autoipd jest implementacją IPv4LL, protokołu umożliwiającego
155 automatyczną konfigurację adresu z zakresu 169.254.0.0/16 bez potrzeby
156 użycia centralnego serwera. Jego głównym zastosowaniem są sieci
157 ad-hoc, w których brakuje serwera DHCP.
158
159 IPv4LL jest częścią stosu Zeroconf.
160
161 %package libs
162 Summary:        Avahi client, common and core libraries
163 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
164 Group:          Libraries
165
166 %description libs
167 Avahi client, common and core libraries.
168
169 %description libs -l pl.UTF-8
170 Biblioteki Avahi: klienta, wspólna i główna.
171
172 %package devel
173 Summary:        Header files for Avahi library
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
175 Group:          Development/Libraries
176 Requires:       %{name}-libs = %{version}-%{release}
177 Requires:       dbus-devel >= 0.92
178 Requires:       expat-devel
179
180 %description devel
181 This is the package containing the header files for Avahi library.
182
183 %description devel -l pl.UTF-8
184 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
185
186 %package static
187 Summary:        Static Avahi library
188 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
189 Group:          Development/Libraries
190 Requires:       %{name}-devel = %{version}-%{release}
191
192 %description static
193 Static Avahi library.
194
195 %description static -l pl.UTF-8
196 Statyczna biblioteka Avahi.
197
198 %package ui
199 Summary:        Avahi UI library
200 Summary(pl.UTF-8):      Biblioteka Avahi UI
201 Group:          X11/Libraries
202 Requires:       %{name}-libs = %{version}-%{release}
203 Requires:       gtk+2 >= 2:2.14.0
204
205 %description ui
206 Common GTK+ UI support library for Avahi.
207
208 %description ui -l pl.UTF-8
209 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
210
211 %package ui-devel
212 Summary:        Header files for Avahi UI library
213 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
214 Group:          X11/Development/Libraries
215 Requires:       %{name}-devel = %{version}-%{release}
216 Requires:       %{name}-ui = %{version}-%{release}
217 Requires:       gtk+2-devel >= 2:2.14.0
218
219 %description ui-devel
220 Header files for Avahi UI library.
221
222 %description ui-devel -l pl.UTF-8
223 Pliki nagłówkowe biblioteki Avahi UI.
224
225 %package ui-static
226 Summary:        Static Avahi UI library
227 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
228 Group:          X11/Development/Libraries
229 Requires:       %{name}-ui-devel = %{version}-%{release}
230
231 %description ui-static
232 Static Avahi UI library.
233
234 %description ui-static -l pl.UTF-8
235 Statyczna biblioteka Avahi UI.
236
237 %package compat-libdns_sd
238 Summary:        Avahi Bonjour compat library
239 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
240 Group:          Libraries
241 Provides:       mdns-bonjour
242 Obsoletes:      mDNSResponder-libs
243
244 %description compat-libdns_sd
245 Avahi Bonjour compat library.
246
247 %description compat-libdns_sd -l pl.UTF-8
248 Biblioteka Avahi zgodna z Bonjour.
249
250 %package compat-libdns_sd-devel
251 Summary:        Header files for Avahi Bonjour compat library
252 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
253 Group:          Development/Libraries
254 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
255 Requires:       %{name}-devel = %{version}-%{release}
256 Provides:       mdns-bonjour-devel
257 Obsoletes:      mDNSResponder-devel
258
259 %description compat-libdns_sd-devel
260 Header files for Avahi Bonjour compat library.
261
262 %description compat-libdns_sd-devel -l pl.UTF-8
263 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
264
265 %package compat-libdns_sd-static
266 Summary:        Static Avahi Bonjour compat library
267 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
268 Group:          Development/Libraries
269 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
270 Provides:       mdns-bonjour-static
271
272 %description compat-libdns_sd-static
273 Static Avahi Bonjour compat library.
274
275 %description compat-libdns_sd-static -l pl.UTF-8
276 Statyczna biblioteka Avahi zgodna z Bonjour.
277
278 %package compat-howl
279 Summary:        Avahi Howl compat library
280 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
281 Group:          Libraries
282 Provides:       mdns-howl-libs
283 Obsoletes:      howl-libs
284
285 %description compat-howl
286 Avahi Howl compat library.
287
288 %description compat-howl -l pl.UTF-8
289 Biblioteka Avahi zgodna z Howl.
290
291 %package compat-howl-devel
292 Summary:        Header files for Avahi Howl compat library
293 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
294 Group:          Development/Libraries
295 Requires:       %{name}-compat-howl = %{version}-%{release}
296 Requires:       %{name}-devel = %{version}-%{release}
297 Provides:       mdns-howl-devel
298 Obsoletes:      howl-devel
299
300 %description compat-howl-devel
301 Header files for Avahi Howl compat library.
302
303 %description compat-howl-devel -l pl.UTF-8
304 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
305
306 %package compat-howl-static
307 Summary:        Static Avahi Howl compat library
308 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
309 Group:          Development/Libraries
310 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
311 Provides:       mdns-howl-static
312 Obsoletes:      howl-static
313
314 %description compat-howl-static
315 Static Avahi Howl compat library.
316
317 %description compat-howl-static -l pl.UTF-8
318 Statyczna biblioteka Avahi zgodna z Howl.
319
320 %package glib
321 Summary:        Avahi GLib library bindings
322 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
323 Group:          Libraries
324
325 %description glib
326 Avahi GLib library bindings.
327
328 %description glib -l pl.UTF-8
329 Wiązania Avahi dla bibioteki GLib.
330
331 %package glib-devel
332 Summary:        Header files for Avahi GLib library bindings
333 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
334 Group:          Development/Libraries
335 Requires:       %{name}-devel = %{version}-%{release}
336 Requires:       %{name}-glib = %{version}-%{release}
337 Requires:       glib2-devel >= 1:2.12.2
338
339 %description glib-devel
340 This is the package containing the header files for Avahi-glib
341 library.
342
343 %description glib-devel -l pl.UTF-8
344 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
345
346 %package glib-static
347 Summary:        Static Avahi GLib library
348 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
349 Group:          Development/Libraries
350 Requires:       %{name}-glib-devel = %{version}-%{release}
351
352 %description glib-static
353 Static Avahi GLib library.
354
355 %description glib-static -l pl.UTF-8
356 Statyczna biblioteka Avahi GLib.
357
358 %package gobject
359 Summary:        Avahi GObject interface
360 Summary(pl.UTF-8):      Interfejs GObject do Avahi
361 Group:          Libraries
362
363 %description gobject
364 Avahi GObject interface.
365
366 %description gobject -l pl.UTF-8
367 Interfejs GObject do Avahi.
368
369 %package gobject-devel
370 Summary:        Header files for Avahi GObject interface
371 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu GObject do Avahi
372 Group:          Development/Libraries
373 Requires:       %{name}-devel = %{version}-%{release}
374 Requires:       %{name}-gobject = %{version}-%{release}
375 Requires:       glib2-devel >= 1:2.12.2
376
377 %description gobject-devel
378 This is the package containing the header files for Avahi GObject
379 interface.
380
381 %description gobject-devel -l pl.UTF-8
382 Ten pakiet zawiera pliki nagłówkowe interfejsu GObject do Avahi.
383
384 %package gobject-static
385 Summary:        Static Avahi GObject library
386 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GObject
387 Group:          Development/Libraries
388 Requires:       %{name}-gobject-devel = %{version}-%{release}
389
390 %description gobject-static
391 Static Avahi GObject library.
392
393 %description gobject-static -l pl.UTF-8
394 Statyczna biblioteka Avahi GObject.
395
396 %package qt
397 Summary:        Avahi Qt 3 library bindings
398 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
399 Group:          Libraries
400 Requires:       %{name}-libs = %{version}-%{release}
401 Obsoletes:      avahi-qt3
402
403 %description qt
404 Avahi Qt 3 library bindings.
405
406 %description qt -l pl.UTF-8
407 Wiązania Avahi dla biblioteki Qt 3.
408
409 %package qt-devel
410 Summary:        Header files for Avahi Qt 3 library bindings
411 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
412 Group:          Development/Libraries
413 Requires:       %{name}-devel = %{version}-%{release}
414 Requires:       %{name}-qt = %{version}-%{release}
415 Requires:       qt-devel >= 1:3.0
416 Obsoletes:      avahi-qt3-devel
417
418 %description qt-devel
419 Header files for Avahi Qt 3 library bindings.
420
421 %description qt-devel -l pl.UTF-8
422 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
423
424 %package qt-static
425 Summary:        Static Avahi Qt 3 library
426 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
427 Group:          Development/Libraries
428 Requires:       %{name}-qt-devel = %{version}-%{release}
429 Obsoletes:      avahi-qt3-static
430
431 %description qt-static
432 Static Avahi Qt 3 library.
433
434 %description qt-static -l pl.UTF-8
435 Statyczna biblioteka Avahi Qt 3.
436
437 %package Qt
438 Summary:        Avahi Qt 4 library bindings
439 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
440 Group:          Libraries
441 Requires:       %{name}-libs = %{version}-%{release}
442
443 %description Qt
444 Avahi Qt 4 library bindings.
445
446 %description Qt -l pl.UTF-8
447 Wiązania Avahi dla biblioteki Qt 4.
448
449 %package Qt-devel
450 Summary:        Header files for Avahi Qt 4 library bindings
451 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
452 Group:          Development/Libraries
453 Requires:       %{name}-Qt = %{version}-%{release}
454 Requires:       %{name}-devel = %{version}-%{release}
455
456 %description Qt-devel
457 Header files for Avahi Qt 4 library bindings.
458
459 %description Qt-devel -l pl.UTF-8
460 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
461
462 %package Qt-static
463 Summary:        Static Avahi Qt 4 library
464 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
465 Group:          Development/Libraries
466 Requires:       %{name}-Qt-devel = %{version}-%{release}
467
468 %description Qt-static
469 Static Avahi Qt 4 library.
470
471 %description Qt-static -l pl.UTF-8
472 Statyczna biblioteka Avahi Qt 4.
473
474 %package -n python-avahi
475 Summary:        Avahi Python bindings
476 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
477 Group:          Development/Languages/Python
478 Requires:       %{name}-libs = %{version}-%{release}
479 Requires:       python-dbus >= 0.71
480
481 %description -n python-avahi
482 Avahi Python bindings.
483
484 %description -n python-avahi -l pl.UTF-8
485 Wiązania Avahi dla Pythona.
486
487 %package -n dotnet-avahi
488 Summary:        Avahi MONO bindings
489 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
490 Group:          Libraries
491 Requires:       %{name}-libs = %{version}-%{release}
492
493 %description -n dotnet-avahi
494 Avahi MONO bindings.
495
496 %description -n dotnet-avahi -l pl.UTF-8
497 Wiązania Avahi dla MONO.
498
499 %package -n dotnet-avahi-devel
500 Summary:        Development files for MONO Avahi bindings
501 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
502 Group:          Development/Libraries
503 Requires:       dotnet-avahi = %{version}-%{release}
504 Requires:       monodoc >= 2.6
505
506 %description -n dotnet-avahi-devel
507 Development files for MONO Avahi bindings.
508
509 %description -n dotnet-avahi-devel -l pl.UTF-8
510 Pliki rozwojowe wiązań Avahi dla MONO.
511
512 %package -n dotnet-avahi-ui
513 Summary:        Avahi UI MONO bindings
514 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
515 Group:          X11/Libraries
516 Requires:       %{name}-ui = %{version}-%{release}
517 Requires:       dotnet-avahi = %{version}-%{release}
518
519 %description -n dotnet-avahi-ui
520 Avahi UI MONO bindings.
521
522 %description -n dotnet-avahi-ui -l pl.UTF-8
523 Wiązania Avahi UI dla MONO.
524
525 %package -n dotnet-avahi-ui-devel
526 Summary:        Development files for MONO Avahi UI bindings
527 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
528 Group:          X11/Development/Libraries
529 Requires:       dotnet-avahi-ui = %{version}-%{release}
530 Requires:       monodoc >= 2.6
531
532 %description -n dotnet-avahi-ui-devel
533 Development files for MONO Avahi UI bindings.
534
535 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
536 Pliki rozwojowe wiązań Avahi UI dla MONO.
537
538 %package bookmarks
539 Summary:        Miniature web server
540 Summary(pl.UTF-8):      Miniaturowy serwer WWW
541 Group:          Applications
542
543 %description bookmarks
544 A Python based miniature web server that browses for mDNS/DNS-SD
545 services of type '_http._tcp' (i.e. web sites) and makes them
546 available as HTML links on http://localhost:8080/.
547
548 %description bookmarks -l pl.UTF-8
549 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
550 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
551 je jako odnośniki HTML na http://localhost:8080/.
552
553 %package discover
554 Summary:        Avahi Zeroconf browser
555 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
556 Group:          Applications
557 Requires:       python-avahi = %{version}-%{release}
558 Requires:       python-pygtk-glade >= 2:2.9.6
559
560 %description discover
561 A tool for enumerating all available services on the local LAN
562 (python-pygtk implementation).
563
564 %description discover -l pl.UTF-8
565 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
566 (implementacja w python-pygtk).
567
568 %package discover-standalone
569 Summary:        Avahi Zeroconf browser
570 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
571 Group:          Applications
572 Requires:       %{name}-glib = %{version}-%{release}
573
574 %description discover-standalone
575 GTK+ tool for enumerating all available services on the local LAN.
576
577 %description discover-standalone -l pl.UTF-8
578 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
579 LAN.
580
581 %package utils
582 Summary:        Avahi CLI utilities
583 Summary(pl.UTF-8):      Narzędzia CLI Avahi
584 Group:          Applications
585
586 %description utils
587 Command line utilities using avahi-client.
588
589 %description utils -l pl.UTF-8
590 Narzędzia linii poleceń korzystające z avahi-client.
591
592 %prep
593 %setup -q
594 %patch0 -p1
595 %patch1 -p1
596 %patch2 -p1
597 %patch3 -p1
598 %patch4 -p1
599 %patch5 -p1
600 %patch6 -p1
601
602 %build
603 %{__intltoolize}
604 %{__libtoolize}
605 %{__aclocal} -I common
606 %{__autoconf}
607 %{__autoheader}
608 %{__automake}
609 %configure \
610         --disable-silent-rules \
611         --enable-compat-libdns_sd \
612         --enable-compat-howl \
613         --with-distro=none \
614         %{!?with_apidocs:--disable-doxygen-doc} \
615         %{!?with_gtk:--disable-gtk} \
616         %{!?with_gtk3:--disable-gtk3} \
617         %{!?with_pygtk:--disable-pygtk} \
618         %{!?with_qt3:--disable-qt3} \
619         %{!?with_qt4:--disable-qt4} \
620         %{!?with_dotnet:--disable-mono} \
621         %{!?with_dotnet:--disable-monodoc} \
622         --with-avahi-priv-access-group=adm \
623         --with-autoipd-user=avahi \
624         --with-autoipd-group=avahi
625 %{__make}
626
627 %install
628 rm -rf $RPM_BUILD_ROOT
629 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d,/etc/init}
630
631 %{__make} install \
632         DESTDIR=$RPM_BUILD_ROOT \
633         pythondir=%{py_sitedir}
634
635 install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
636 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
637
638 install %{SOURCE4} $RPM_BUILD_ROOT/etc/init/avahi-daemon.conf
639 install %{SOURCE5} $RPM_BUILD_ROOT/etc/init/avahi-dnsconfd.conf
640
641 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
642         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
643
644 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
645         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
646
647 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
648 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
649 %py_postclean
650
651 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
652 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
653 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
654 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
655 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
656 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
657 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
658
659 %find_lang %{name}
660
661 %clean
662 rm -rf $RPM_BUILD_ROOT
663
664 %pre
665 %groupadd -g 165 -r -f avahi
666 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
667
668 %pre autoipd
669 %groupadd -g 165 -r -f avahi
670 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
671
672 %post
673 /sbin/chkconfig --add %{name}-daemon
674 %service %{name}-daemon restart
675 /sbin/chkconfig --add %{name}-dnsconfd
676 %service %{name}-dnsconfd restart
677
678 %preun
679 if [ "$1" = "0" ]; then
680         %service -q %{name}-dnsconfd stop
681         /sbin/chkconfig --del %{name}-dnsconfd
682         %service -q %{name}-daemon stop
683         /sbin/chkconfig --del %{name}-daemon
684 fi
685
686 %postun
687 if [ "$1" = "0" ]; then
688         %userremove avahi
689         %groupremove avahi
690 fi
691
692 %postun autoipd
693 if [ "$1" = "0" ]; then
694         %userremove avahi
695         %groupremove avahi
696 fi
697
698 %post upstart
699 %upstart_post avahi-daemon
700 %upstart_post avahi-dnsconfd
701
702 %postun upstart
703 %upstart_postun avahi-daemon
704 %upstart_postun avahi-dnsconfd
705
706 %post   libs -p /sbin/ldconfig
707 %postun libs -p /sbin/ldconfig
708
709 %post   ui -p /sbin/ldconfig
710 %postun ui -p /sbin/ldconfig
711
712 %post   compat-libdns_sd -p /sbin/ldconfig
713 %postun compat-libdns_sd -p /sbin/ldconfig
714
715 %post   compat-howl -p /sbin/ldconfig
716 %postun compat-howl -p /sbin/ldconfig
717
718 %post   glib -p /sbin/ldconfig
719 %postun glib -p /sbin/ldconfig
720
721 %post   gobject -p /sbin/ldconfig
722 %postun gobject -p /sbin/ldconfig
723
724 %post   qt -p /sbin/ldconfig
725 %postun qt -p /sbin/ldconfig
726
727 %post   Qt -p /sbin/ldconfig
728 %postun Qt -p /sbin/ldconfig
729
730 %files
731 %defattr(644,root,root,755)
732 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
733
734 %dir %{_sysconfdir}/avahi
735 %dir %{_sysconfdir}/avahi/services
736 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
737 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
740 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
741 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*
742
743 %attr(755,root,root) %{_bindir}/avahi-set-host-name
744
745 %attr(755,root,root) %{_sbindir}/avahi-daemon
746 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
747 %dir %{_libdir}/%{name}
748 %{_libdir}/%{name}/service-types.db
749 #%%dir %{_datadir}/%{name}/introspection
750 #%%{_datadir}/%{name}/introspection/*.introspect
751 %{_datadir}/%{name}/avahi-service.dtd
752 %{_datadir}/%{name}/service-types
753 %{_datadir}/dbus-1/interfaces/org.freedesktop.Avahi.*.xml
754
755 %{_mandir}/man1/avahi-set-host-name.1*
756 %{_mandir}/man5/avahi-daemon.conf.5*
757 %{_mandir}/man5/avahi.hosts.5*
758 %{_mandir}/man5/avahi.service.5*
759 %{_mandir}/man8/avahi-daemon.8*
760 %{_mandir}/man8/avahi-dnsconfd.8*
761 %{_mandir}/man8/avahi-dnsconfd.action.8*
762
763 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
764 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
765
766 %if "%{pld_release}" != "ti"
767 %files upstart
768 %defattr(644,root,root,755)
769 %config(noreplace) %verify(not md5 mtime size) /etc/init/*.conf
770 %endif
771
772 %files autoipd
773 %defattr(644,root,root,755)
774 %dir %{_sysconfdir}/avahi
775 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
776 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-enter-hooks.d/avahi-autoipd
777 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-exit-hooks.d/avahi-autoipd
778 %attr(755,root,root) %{_sbindir}/avahi-autoipd
779 %{_mandir}/man8/avahi-autoipd.8*
780 %{_mandir}/man8/avahi-autoipd.action.8*
781
782 %files libs -f %{name}.lang
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
785 %attr(755,root,root) %ghost %{_libdir}/libavahi-client.so.3
786 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
787 %attr(755,root,root) %ghost %{_libdir}/libavahi-common.so.3
788 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
789 %attr(755,root,root) %ghost %{_libdir}/libavahi-core.so.7
790 # common for -discover*
791 %dir %{_datadir}/%{name}
792 %dir %{_datadir}/%{name}/interfaces
793
794 %files devel
795 %defattr(644,root,root,755)
796 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
797 %attr(755,root,root) %{_libdir}/libavahi-client.so
798 %attr(755,root,root) %{_libdir}/libavahi-common.so
799 %attr(755,root,root) %{_libdir}/libavahi-core.so
800 %{_libdir}/libavahi-client.la
801 %{_libdir}/libavahi-common.la
802 %{_libdir}/libavahi-core.la
803 %{_includedir}/avahi-client
804 %{_includedir}/avahi-common
805 %{_includedir}/avahi-core
806 %{_pkgconfigdir}/avahi-client.pc
807 %{_pkgconfigdir}/avahi-core.pc
808
809 %files static
810 %defattr(644,root,root,755)
811 %{_libdir}/libavahi-client.a
812 %{_libdir}/libavahi-common.a
813 %{_libdir}/libavahi-core.a
814
815 %if %{with gtk}
816 %files ui
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_bindir}/bshell
819 %attr(755,root,root) %{_bindir}/bssh
820 %attr(755,root,root) %{_bindir}/bvnc
821 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
822 %attr(755,root,root) %ghost %{_libdir}/libavahi-ui.so.0
823 %{_mandir}/man1/bssh.1*
824 %{_mandir}/man1/bvnc.1*
825 %{_desktopdir}/bssh.desktop
826 %{_desktopdir}/bvnc.desktop
827
828 %files ui-devel
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_libdir}/libavahi-ui.so
831 %{_libdir}/libavahi-ui.la
832 %{_includedir}/avahi-ui
833 %{_pkgconfigdir}/avahi-ui.pc
834
835 %files ui-static
836 %defattr(644,root,root,755)
837 %{_libdir}/libavahi-ui.a
838 %endif
839
840 %files compat-libdns_sd
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
843 %attr(755,root,root) %ghost %{_libdir}/libdns_sd.so.1
844
845 %files compat-libdns_sd-devel
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_libdir}/libdns_sd.so
848 %{_libdir}/libdns_sd.la
849 %{_includedir}/avahi-compat-libdns_sd
850 %{_includedir}/dns_sd.h
851 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
852
853 %files compat-libdns_sd-static
854 %defattr(644,root,root,755)
855 %{_libdir}/libdns_sd.a
856
857 %files compat-howl
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
860 %attr(755,root,root) %ghost %{_libdir}/libhowl.so.0
861
862 %files compat-howl-devel
863 %defattr(644,root,root,755)
864 %attr(755,root,root) %{_libdir}/libhowl.so
865 %{_libdir}/libhowl.la
866 %{_includedir}/avahi-compat-howl
867 %{_pkgconfigdir}/avahi-compat-howl.pc
868 %{_pkgconfigdir}/howl.pc
869
870 %files compat-howl-static
871 %defattr(644,root,root,755)
872 %{_libdir}/libhowl.a
873
874 %files -n python-avahi
875 %defattr(644,root,root,755)
876 %{py_sitedir}/avahi
877
878 %if %{with dotnet}
879 %files -n dotnet-avahi
880 %defattr(644,root,root,755)
881 %{_prefix}/lib/mono/gac/avahi-sharp
882
883 %files -n dotnet-avahi-devel
884 %defattr(644,root,root,755)
885 %{_prefix}/lib/mono/avahi-sharp
886 %{_prefix}/lib/monodoc/sources/avahi-sharp-docs.*
887 %{_pkgconfigdir}/avahi-sharp.pc
888
889 %files -n dotnet-avahi-ui
890 %defattr(644,root,root,755)
891 %{_prefix}/lib/mono/gac/avahi-ui-sharp
892
893 %files -n dotnet-avahi-ui-devel
894 %defattr(644,root,root,755)
895 %{_prefix}/lib/mono/avahi-ui-sharp
896 %{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.*
897 %{_pkgconfigdir}/avahi-ui-sharp.pc
898 %endif
899
900 %files glib
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
903 %attr(755,root,root) %ghost %{_libdir}/libavahi-glib.so.1
904
905 %files glib-devel
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_libdir}/libavahi-glib.so
908 %{_libdir}/libavahi-glib.la
909 %{_includedir}/avahi-glib
910 %{_pkgconfigdir}/avahi-glib.pc
911
912 %files glib-static
913 %defattr(644,root,root,755)
914 %{_libdir}/libavahi-glib.a
915
916 %files gobject
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/libavahi-gobject.so.*.*.*
919 %attr(755,root,root) %ghost %{_libdir}/libavahi-gobject.so.0
920 %{_libdir}/girepository-1.0/Avahi-0.6.typelib
921 %{_libdir}/girepository-1.0/AvahiCore-0.6.typelib
922
923 %files gobject-devel
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/libavahi-gobject.so
926 %{_libdir}/libavahi-gobject.la
927 %{_includedir}/avahi-gobject
928 %{_pkgconfigdir}/avahi-gobject.pc
929 %{_datadir}/gir-1.0/Avahi-0.6.gir
930 %{_datadir}/gir-1.0/AvahiCore-0.6.gir
931
932 %files gobject-static
933 %defattr(644,root,root,755)
934 %{_libdir}/libavahi-gobject.a
935
936 %if %{with qt3}
937 %files qt
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
940 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt3.so.1
941
942 %files qt-devel
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
945 %{_libdir}/libavahi-qt3.la
946 %{_includedir}/avahi-qt3
947 %{_pkgconfigdir}/avahi-qt3.pc
948
949 %files qt-static
950 %defattr(644,root,root,755)
951 %{_libdir}/libavahi-qt3.a
952 %endif
953
954 %if %{with qt4}
955 %files Qt
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
958 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt4.so.1
959
960 %files Qt-devel
961 %defattr(644,root,root,755)
962 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
963 %{_libdir}/libavahi-qt4.la
964 %{_includedir}/avahi-qt4
965 %{_pkgconfigdir}/avahi-qt4.pc
966
967 %files Qt-static
968 %defattr(644,root,root,755)
969 %{_libdir}/libavahi-qt4.a
970 %endif
971
972 %files bookmarks
973 %defattr(644,root,root,755)
974 %attr(755,root,root) %{_bindir}/avahi-bookmarks
975 %{_mandir}/man1/avahi-bookmarks.1*
976
977 %if %{with pygtk}
978 %files discover
979 %defattr(644,root,root,755)
980 %attr(755,root,root) %{_bindir}/avahi-discover
981 %{py_sitedir}/avahi_discover
982 %{_datadir}/%{name}/interfaces/avahi-discover.ui
983 %{_desktopdir}/avahi-discover.desktop
984 %{_pixmapsdir}/avahi.png
985 %{_mandir}/man1/avahi-discover.1*
986 %endif
987
988 %if %{with gtk}
989 %files discover-standalone
990 %defattr(644,root,root,755)
991 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
992 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
993 %endif
994
995 %files utils
996 %defattr(644,root,root,755)
997 %attr(755,root,root) %{_bindir}/avahi-browse
998 %attr(755,root,root) %{_bindir}/avahi-browse-domains
999 %attr(755,root,root) %{_bindir}/avahi-publish
1000 %attr(755,root,root) %{_bindir}/avahi-publish-address
1001 %attr(755,root,root) %{_bindir}/avahi-publish-service
1002 %attr(755,root,root) %{_bindir}/avahi-resolve
1003 %attr(755,root,root) %{_bindir}/avahi-resolve-address
1004 %attr(755,root,root) %{_bindir}/avahi-resolve-host-name
1005 %{_mandir}/man1/avahi-browse.1*
1006 %{_mandir}/man1/avahi-browse-domains.1*
1007 %{_mandir}/man1/avahi-publish.1*
1008 %{_mandir}/man1/avahi-publish-address.1*
1009 %{_mandir}/man1/avahi-publish-service.1*
1010 %{_mandir}/man1/avahi-resolve.1*
1011 %{_mandir}/man1/avahi-resolve-address.1*
1012 %{_mandir}/man1/avahi-resolve-host-name.1*
This page took 0.129672 seconds and 4 git commands to generate.