]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- without gtk and without pygtk bconds for GUI-free builds
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 #       - finish with_apidocs
4 #
5 # Conditional build:
6 %bcond_with     apidocs         # build API documentation
7 %bcond_without  dotnet          # build without dotnet bindings
8 %bcond_without  gtk             # build without GTK+
9 %bcond_without  pygtk           # build without PyGTK
10 %bcond_without  qt              # build without (any) qt bindings
11 %bcond_without  qt3             # build without qt3 bindings
12 %bcond_without  qt4             # build without qt4 bindings
13
14 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
15 %undefine with_dotnet
16 %endif
17 %ifarch i386
18 %undefine with_dotnet
19 %endif
20
21 %if %{without qt}
22 %undefine       with_qt3
23 %undefine       with_qt4
24 %endif
25
26 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
27 Summary:        Free mDNS/DNS-SD/Zeroconf implementation
28 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD/Zeroconf
29 Name:           avahi
30 Version:        0.6.25
31 Release:        7
32 License:        LGPL v2.1+
33 Group:          Applications
34 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
35 # Source0-md5:  a83155a6e29e3988f07e5eea3287b21e
36 Source1:        %{name}-daemon
37 Source2:        %{name}-dnsconfd
38 Source3:        %{name}.png
39 Source4:        %{name}-daemon.upstart
40 Source5:        %{name}-dnsconfd.upstart
41 Patch0:         %{name}-desktop.patch
42 Patch1:         %{name}-glade.patch
43 Patch2:         %{name}-destdir.patch
44 Patch3:         %{name}-mono-dir.patch
45 Patch4:         nss-mdns-package.patch
46 Patch5:         %{name}-dhclient_hooks.patch
47 Patch6:         %{name}-autoipd-sbin_ip.patch
48 URL:            http://avahi.org/
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  dbus-devel >= 0.92
52 %if %{with apidocs}
53 BuildRequires:  doxygen
54 # for the 'dot' tool used by doxygen
55 BuildRequires:  graphviz
56 %endif
57 BuildRequires:  expat-devel
58 BuildRequires:  gdbm-devel
59 BuildRequires:  gettext-devel
60 %if %{with gtk}
61 BuildRequires:  glib2-devel >= 1:2.12.2
62 BuildRequires:  gtk+2-devel >= 2:2.10.2
63 BuildRequires:  libglade2-devel >= 1:2.6.0
64 %endif
65 BuildRequires:  intltool >= 0.35
66 BuildRequires:  libcap-devel
67 BuildRequires:  libdaemon-devel >= 0.11
68 BuildRequires:  libtool
69 %if %{with dotnet}
70 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
71 BuildRequires:  mono-csharp
72 BuildRequires:  monodoc >= 2.6
73 %endif
74 BuildRequires:  pkgconfig
75 BuildRequires:  python >= 1:2.4
76 BuildRequires:  python-dbus >= 0.71
77 %{?with_pygtk:BuildRequires:    python-pygtk-devel >= 2:2.9.6}
78 %if %{with qt3}
79 BuildRequires:  qt-devel >= 1:3.0
80 %endif
81 %if %{with qt4}
82 BuildRequires:  QtCore-devel
83 BuildRequires:  qt4-build
84 %endif
85 BuildRequires:  rpm-pythonprov
86 BuildRequires:  rpmbuild(macros) >= 1.561
87 Requires(post,preun):   /sbin/chkconfig
88 Requires:       %{name}-libs = %{version}-%{release}
89 Requires:       dbus >= 0.92
90 Requires:       libdaemon >= 0.11
91 Requires:       rc-scripts >= 0.4.3
92 Suggests:       nss_mdns >= 0.10-2
93 Provides:       group(avahi)
94 Provides:       user(avahi)
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %description
98 Avahi is an implementation the DNS Service Discovery and Multicast DNS
99 specifications for Zeroconf Computing. It uses D-BUS for communication
100 between user applications and a system daemon.
101
102 %description -l pl.UTF-8
103 Avahi jest implementacją specyfikacji DNS Service Discovery i
104 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
105 pomiędzy programami użytkownika a demonem systemowym.
106
107 %package upstart
108 Summary:        Upstart jobs description for Avahi daemons
109 Summary(pl.UTF-8):      Opis zadań Upstart dla demonów Avahi
110 Group:          Daemons
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       upstart >= 0.6
113
114 %description upstart
115 Upstart jobs description for Avahi daemons.
116
117 %description upstart -l pl.UTF-8
118 Opis zadań Upstart dla demonów Avahi.
119
120 %package autoipd
121 Summary:        IPv4LL network address configuration daemon
122 Summary(pl.UTF-8):      Demon configurujący adresy IPv4LL
123 Group:          Networking/Daemons
124 Requires(postun):       /usr/sbin/groupdel
125 Requires(postun):       /usr/sbin/userdel
126 Requires(pre):  /bin/id
127 Requires(pre):  /usr/bin/getgid
128 Requires(pre):  /usr/sbin/groupadd
129 Requires(pre):  /usr/sbin/useradd
130 Provides:       group(avahi)
131 Provides:       user(avahi)
132
133 %description autoipd
134 avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4 Link-
135 Local Addresses" (IETF RFC3927), a protocol for automatic IP address
136 configuration from the link-local 169.254.0.0/16 range without the
137 need for a central server. It is primarily intended to be used in
138 ad-hoc networks which lack a DHCP server.
139
140 IPv4LL is part of the Zeroconf stack.
141
142 %description autoipd -l pl.UTF-8
143 avahi-autoipd jest implementacją IPv4LL, protokołu umożliwiającego
144 automatyczną konfigurację adresu z zakresu 169.254.0.0/16 bez potrzeby
145 użycia centralnego serwera. Jego głównym zastosowaniem są sieci
146 ad-hoc, w których brakuje serwera DHCP.
147
148 IPv4LL jest częścią stosu Zeroconf.
149
150 %package libs
151 Summary:        Avahi client, common and core libraries
152 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
153 Group:          Libraries
154
155 %description libs
156 Avahi client, common and core libraries.
157
158 %description libs -l pl.UTF-8
159 Biblioteki Avahi: klienta, wspólna i główna.
160
161 %package devel
162 Summary:        Header files for Avahi library
163 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
164 Group:          Development/Libraries
165 Requires:       %{name}-libs = %{version}-%{release}
166 Requires:       dbus-devel >= 0.92
167 Requires:       expat-devel
168
169 %description devel
170 This is the package containing the header files for Avahi library.
171
172 %description devel -l pl.UTF-8
173 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
174
175 %package static
176 Summary:        Static Avahi library
177 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
178 Group:          Development/Libraries
179 Requires:       %{name}-devel = %{version}-%{release}
180
181 %description static
182 Static Avahi library.
183
184 %description static -l pl.UTF-8
185 Statyczna biblioteka Avahi.
186
187 %package ui
188 Summary:        Avahi UI library
189 Summary(pl.UTF-8):      Biblioteka Avahi UI
190 Group:          X11/Libraries
191 Requires:       %{name}-libs = %{version}-%{release}
192 Requires:       gtk+2 >= 2:2.10.2
193
194 %description ui
195 Common GTK+ UI support library for Avahi.
196
197 %description ui -l pl.UTF-8
198 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
199
200 %package ui-devel
201 Summary:        Header files for Avahi UI library
202 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
203 Group:          X11/Development/Libraries
204 Requires:       %{name}-devel = %{version}-%{release}
205 Requires:       %{name}-ui = %{version}-%{release}
206 Requires:       gtk+2-devel >= 2:2.10.2
207
208 %description ui-devel
209 Header files for Avahi UI library.
210
211 %description ui-devel -l pl.UTF-8
212 Pliki nagłówkowe biblioteki Avahi UI.
213
214 %package ui-static
215 Summary:        Static Avahi UI library
216 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
217 Group:          X11/Development/Libraries
218 Requires:       %{name}-ui-devel = %{version}-%{release}
219
220 %description ui-static
221 Static Avahi UI library.
222
223 %description ui-static -l pl.UTF-8
224 Statyczna biblioteka Avahi UI.
225
226 %package compat-libdns_sd
227 Summary:        Avahi Bonjour compat library
228 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
229 Group:          Libraries
230 Provides:       mdns-bonjour
231 Obsoletes:      mDNSResponder-libs
232
233 %description compat-libdns_sd
234 Avahi Bonjour compat library.
235
236 %description compat-libdns_sd -l pl.UTF-8
237 Biblioteka Avahi zgodna z Bonjour.
238
239 %package compat-libdns_sd-devel
240 Summary:        Header files for Avahi Bonjour compat library
241 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
242 Group:          Development/Libraries
243 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
244 Requires:       %{name}-devel = %{version}-%{release}
245 Provides:       mdns-bonjour-devel
246 Obsoletes:      mDNSResponder-devel
247
248 %description compat-libdns_sd-devel
249 Header files for Avahi Bonjour compat library.
250
251 %description compat-libdns_sd-devel -l pl.UTF-8
252 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
253
254 %package compat-libdns_sd-static
255 Summary:        Static Avahi Bonjour compat library
256 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
257 Group:          Development/Libraries
258 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
259 Provides:       mdns-bonjour-static
260
261 %description compat-libdns_sd-static
262 Static Avahi Bonjour compat library.
263
264 %description compat-libdns_sd-static -l pl.UTF-8
265 Statyczna biblioteka Avahi zgodna z Bonjour.
266
267 %package compat-howl
268 Summary:        Avahi Howl compat library
269 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
270 Group:          Libraries
271 Provides:       mdns-howl-libs
272 Obsoletes:      howl-libs
273
274 %description compat-howl
275 Avahi Howl compat library.
276
277 %description compat-howl -l pl.UTF-8
278 Biblioteka Avahi zgodna z Howl.
279
280 %package compat-howl-devel
281 Summary:        Header files for Avahi Howl compat library
282 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
283 Group:          Development/Libraries
284 Requires:       %{name}-compat-howl = %{version}-%{release}
285 Requires:       %{name}-devel = %{version}-%{release}
286 Provides:       mdns-howl-devel
287 Obsoletes:      howl-devel
288
289 %description compat-howl-devel
290 Header files for Avahi Howl compat library.
291
292 %description compat-howl-devel -l pl.UTF-8
293 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
294
295 %package compat-howl-static
296 Summary:        Static Avahi Howl compat library
297 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
298 Group:          Development/Libraries
299 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
300 Provides:       mdns-howl-static
301 Obsoletes:      howl-static
302
303 %description compat-howl-static
304 Static Avahi Howl compat library.
305
306 %description compat-howl-static -l pl.UTF-8
307 Statyczna biblioteka Avahi zgodna z Howl.
308
309 %package glib
310 Summary:        Avahi GLib library bindings
311 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
312 Group:          Libraries
313
314 %description glib
315 Avahi GLib library bindings.
316
317 %description glib -l pl.UTF-8
318 Wiązania Avahi dla bibioteki GLib.
319
320 %package glib-devel
321 Summary:        Header files for Avahi GLib library bindings
322 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
323 Group:          Development/Libraries
324 Requires:       %{name}-devel = %{version}-%{release}
325 Requires:       %{name}-glib = %{version}-%{release}
326 Requires:       glib2-devel >= 1:2.12.2
327
328 %description glib-devel
329 This is the package containing the header files for Avahi-glib
330 library.
331
332 %description glib-devel -l pl.UTF-8
333 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
334
335 %package glib-static
336 Summary:        Static Avahi GLib library
337 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
338 Group:          Development/Libraries
339 Requires:       %{name}-glib-devel = %{version}-%{release}
340
341 %description glib-static
342 Static Avahi GLib library.
343
344 %description glib-static -l pl.UTF-8
345 Statyczna biblioteka Avahi GLib.
346
347 %package gobject
348 Summary:        Avahi GObject interface
349 Summary(pl.UTF-8):      Interfejs GObject do Avahi
350 Group:          Libraries
351
352 %description gobject
353 Avahi GObject interface.
354
355 %description gobject -l pl.UTF-8
356 Interfejs GObject do Avahi.
357
358 %package gobject-devel
359 Summary:        Header files for Avahi GObject interface
360 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu GObject do Avahi
361 Group:          Development/Libraries
362 Requires:       %{name}-devel = %{version}-%{release}
363 Requires:       %{name}-gobject = %{version}-%{release}
364 Requires:       glib2-devel >= 1:2.12.2
365
366 %description gobject-devel
367 This is the package containing the header files for Avahi GObject
368 interface.
369
370 %description gobject-devel -l pl.UTF-8
371 Ten pakiet zawiera pliki nagłówkowe interfejsu GObject do Avahi.
372
373 %package gobject-static
374 Summary:        Static Avahi GObject library
375 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GObject
376 Group:          Development/Libraries
377 Requires:       %{name}-gobject-devel = %{version}-%{release}
378
379 %description gobject-static
380 Static Avahi GObject library.
381
382 %description gobject-static -l pl.UTF-8
383 Statyczna biblioteka Avahi GObject.
384
385 %package qt
386 Summary:        Avahi Qt 3 library bindings
387 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
388 Group:          Libraries
389 Requires:       %{name}-libs = %{version}-%{release}
390 Obsoletes:      avahi-qt3
391
392 %description qt
393 Avahi Qt 3 library bindings.
394
395 %description qt -l pl.UTF-8
396 Wiązania Avahi dla biblioteki Qt 3.
397
398 %package qt-devel
399 Summary:        Header files for Avahi Qt 3 library bindings
400 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
401 Group:          Development/Libraries
402 Requires:       %{name}-devel = %{version}-%{release}
403 Requires:       %{name}-qt = %{version}-%{release}
404 Requires:       qt-devel >= 1:3.0
405 Obsoletes:      avahi-qt3-devel
406
407 %description qt-devel
408 Header files for Avahi Qt 3 library bindings.
409
410 %description qt-devel -l pl.UTF-8
411 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
412
413 %package qt-static
414 Summary:        Static Avahi Qt 3 library
415 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
416 Group:          Development/Libraries
417 Requires:       %{name}-qt-devel = %{version}-%{release}
418 Obsoletes:      avahi-qt3-static
419
420 %description qt-static
421 Static Avahi Qt 3 library.
422
423 %description qt-static -l pl.UTF-8
424 Statyczna biblioteka Avahi Qt 3.
425
426 %package Qt
427 Summary:        Avahi Qt 4 library bindings
428 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
429 Group:          Libraries
430 Requires:       %{name}-libs = %{version}-%{release}
431
432 %description Qt
433 Avahi Qt 4 library bindings.
434
435 %description Qt -l pl.UTF-8
436 Wiązania Avahi dla biblioteki Qt 4.
437
438 %package Qt-devel
439 Summary:        Header files for Avahi Qt 4 library bindings
440 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
441 Group:          Development/Libraries
442 Requires:       %{name}-Qt = %{version}-%{release}
443 Requires:       %{name}-devel = %{version}-%{release}
444
445 %description Qt-devel
446 Header files for Avahi Qt 4 library bindings.
447
448 %description Qt-devel -l pl.UTF-8
449 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
450
451 %package Qt-static
452 Summary:        Static Avahi Qt 4 library
453 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
454 Group:          Development/Libraries
455 Requires:       %{name}-Qt-devel = %{version}-%{release}
456
457 %description Qt-static
458 Static Avahi Qt 4 library.
459
460 %description Qt-static -l pl.UTF-8
461 Statyczna biblioteka Avahi Qt 4.
462
463 %package -n python-avahi
464 Summary:        Avahi Python bindings
465 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
466 Group:          Development/Languages/Python
467 Requires:       %{name}-libs = %{version}-%{release}
468 Requires:       python-dbus >= 0.71
469
470 %description -n python-avahi
471 Avahi Python bindings.
472
473 %description -n python-avahi -l pl.UTF-8
474 Wiązania Avahi dla Pythona.
475
476 %package -n dotnet-avahi
477 Summary:        Avahi MONO bindings
478 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
479 Group:          Libraries
480 Requires:       %{name}-libs = %{version}-%{release}
481
482 %description -n dotnet-avahi
483 Avahi MONO bindings.
484
485 %description -n dotnet-avahi -l pl.UTF-8
486 Wiązania Avahi dla MONO.
487
488 %package -n dotnet-avahi-devel
489 Summary:        Development files for MONO Avahi bindings
490 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
491 Group:          Development/Libraries
492 Requires:       dotnet-avahi = %{version}-%{release}
493 Requires:       monodoc >= 2.6
494
495 %description -n dotnet-avahi-devel
496 Development files for MONO Avahi bindings.
497
498 %description -n dotnet-avahi-devel -l pl.UTF-8
499 Pliki rozwojowe wiązań Avahi dla MONO.
500
501 %package -n dotnet-avahi-ui
502 Summary:        Avahi UI MONO bindings
503 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
504 Group:          X11/Libraries
505 Requires:       %{name}-ui = %{version}-%{release}
506 Requires:       dotnet-avahi = %{version}-%{release}
507
508 %description -n dotnet-avahi-ui
509 Avahi UI MONO bindings.
510
511 %description -n dotnet-avahi-ui -l pl.UTF-8
512 Wiązania Avahi UI dla MONO.
513
514 %package -n dotnet-avahi-ui-devel
515 Summary:        Development files for MONO Avahi UI bindings
516 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
517 Group:          X11/Development/Libraries
518 Requires:       dotnet-avahi-ui = %{version}-%{release}
519 Requires:       monodoc >= 2.6
520
521 %description -n dotnet-avahi-ui-devel
522 Development files for MONO Avahi UI bindings.
523
524 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
525 Pliki rozwojowe wiązań Avahi UI dla MONO.
526
527 %package bookmarks
528 Summary:        Miniature web server
529 Summary(pl.UTF-8):      Miniaturowy serwer web
530 Group:          Applications
531
532 %description bookmarks
533 A Python based miniature web server that browses for mDNS/DNS-SD
534 services of type '_http._tcp' (i.e. web sites) and makes them
535 available as HTML links on http://localhost:8080/.
536
537 %description bookmarks -l pl.UTF-8
538 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
539 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
540 je jako odnośniki HTML na http://localhost:8080/.
541
542 %package discover
543 Summary:        Avahi Zeroconf browser
544 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
545 Group:          Applications
546 Requires:       python-avahi = %{version}-%{release}
547 Requires:       python-pygtk-glade >= 2:2.9.6
548
549 %description discover
550 A tool for enumerating all available services on the local LAN
551 (python-pygtk implementation).
552
553 %description discover -l pl.UTF-8
554 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
555 (implementacja w python-pygtk).
556
557 %package discover-standalone
558 Summary:        Avahi Zeroconf browser
559 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
560 Group:          Applications
561 Requires:       %{name}-glib = %{version}-%{release}
562
563 %description discover-standalone
564 GTK+ tool for enumerating all available services on the local LAN.
565
566 %description discover-standalone -l pl.UTF-8
567 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
568 LAN.
569
570 %package utils
571 Summary:        Avahi CLI utilities
572 Summary(pl.UTF-8):      Narzędzia CLI Avahi
573 Group:          Applications
574
575 %description utils
576 Command line utilities using avahi-client.
577
578 %description utils -l pl.UTF-8
579 Narzędzia linii poleceń korzystające z avahi-client.
580
581 %prep
582 %setup -q
583 %patch0 -p1
584 %patch1 -p1
585 %patch2 -p1
586 %patch3 -p1
587 %patch4 -p1
588 %patch5 -p1
589 %patch6 -p1
590
591 %build
592 %{__intltoolize}
593 %{__libtoolize}
594 %{__aclocal} -I common
595 %{__autoconf}
596 %{__autoheader}
597 %{__automake}
598 %configure \
599         --enable-compat-libdns_sd \
600         --enable-compat-howl \
601         --with-distro=none \
602         %{!?with_apidocs:--disable-doxygen-doc} \
603         %{!?with_gtk:--disable-gtk} \
604         %{!?with_pygtk:--disable-pygtk} \
605         %{!?with_qt3:--disable-qt3} \
606         %{!?with_qt4:--disable-qt4} \
607         %{!?with_dotnet:--disable-mono} \
608         %{!?with_dotnet:--disable-monodoc} \
609         --with-avahi-priv-access-group=adm \
610         --with-autoipd-user=avahi \
611         --with-autoipd-group=avahi
612 %{__make}
613
614 %install
615 rm -rf $RPM_BUILD_ROOT
616 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d,/etc/init}
617
618 %{__make} install \
619         DESTDIR=$RPM_BUILD_ROOT \
620         pythondir=%{py_sitedir}
621
622 install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
623 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
624
625 install %{SOURCE4} $RPM_BUILD_ROOT/etc/init/avahi-daemon.conf
626 install %{SOURCE5} $RPM_BUILD_ROOT/etc/init/avahi-dnsconfd.conf
627
628 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
629         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
630
631 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
632         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
633
634 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
635 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
636 %py_postclean
637
638 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
639 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
640 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
641 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
642 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
643 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
644 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
645
646 %find_lang %{name}
647
648 %clean
649 rm -rf $RPM_BUILD_ROOT
650
651 %pre
652 %groupadd -g 165 -r -f avahi
653 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
654
655 %pre autoipd
656 %groupadd -g 165 -r -f avahi
657 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
658
659 %post
660 /sbin/chkconfig --add %{name}-daemon
661 %service %{name}-daemon restart
662 /sbin/chkconfig --add %{name}-dnsconfd
663 %service %{name}-dnsconfd restart
664
665 %preun
666 if [ "$1" = "0" ]; then
667         %service -q %{name}-dnsconfd stop
668         /sbin/chkconfig --del %{name}-dnsconfd
669         %service -q %{name}-daemon stop
670         /sbin/chkconfig --del %{name}-daemon
671 fi
672
673 %postun
674 if [ "$1" = "0" ]; then
675         %userremove avahi
676         %groupremove avahi
677 fi
678
679 %postun autoipd
680 if [ "$1" = "0" ]; then
681         %userremove avahi
682         %groupremove avahi
683 fi
684
685 %post upstart
686 %upstart_post avahi-daemon
687 %upstart_post avahi-dnsconfd
688
689 %postun upstart
690 %upstart_postun avahi-daemon
691 %upstart_postun avahi-dnsconfd
692
693 %post   libs -p /sbin/ldconfig
694 %postun libs -p /sbin/ldconfig
695
696 %post   ui -p /sbin/ldconfig
697 %postun ui -p /sbin/ldconfig
698
699 %post   compat-libdns_sd -p /sbin/ldconfig
700 %postun compat-libdns_sd -p /sbin/ldconfig
701
702 %post   compat-howl -p /sbin/ldconfig
703 %postun compat-howl -p /sbin/ldconfig
704
705 %post   glib -p /sbin/ldconfig
706 %postun glib -p /sbin/ldconfig
707
708 %post   gobject -p /sbin/ldconfig
709 %postun gobject -p /sbin/ldconfig
710
711 %post   qt -p /sbin/ldconfig
712 %postun qt -p /sbin/ldconfig
713
714 %post   Qt -p /sbin/ldconfig
715 %postun Qt -p /sbin/ldconfig
716
717 %files
718 %defattr(644,root,root,755)
719 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
720
721 %dir %{_sysconfdir}/avahi
722 %dir %{_sysconfdir}/avahi/services
723 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
724 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
725 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
726 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
727 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
728 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*
729
730 %attr(755,root,root) %{_bindir}/avahi-set-host-name
731
732 %attr(755,root,root) %{_sbindir}/avahi-daemon
733 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
734
735 %dir %{_datadir}/%{name}/introspection
736 %{_datadir}/%{name}/introspection/*.introspect
737 %{_datadir}/%{name}/avahi-service.dtd
738 %{_datadir}/%{name}/service-types
739 %dir %{_libdir}/%{name}
740 %{_libdir}/%{name}/service-types.db
741
742 %{_mandir}/man1/avahi-set-host-name.1*
743 %{_mandir}/man5/avahi-daemon.conf.5*
744 %{_mandir}/man5/avahi.hosts.5*
745 %{_mandir}/man5/avahi.service.5*
746 %{_mandir}/man8/avahi-daemon.8*
747 %{_mandir}/man8/avahi-dnsconfd.8*
748 %{_mandir}/man8/avahi-dnsconfd.action.8*
749
750 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
751 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
752
753 %files upstart
754 %defattr(644,root,root,755)
755 %config(noreplace) %verify(not md5 mtime size) /etc/init/*.conf
756
757 %files autoipd
758 %defattr(644,root,root,755)
759 %dir %{_sysconfdir}/avahi
760 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
761 %dir %{_sysconfdir}/dhclient-enter-hooks.d
762 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-enter-hooks.d/avahi-autoipd
763 %dir %{_sysconfdir}/dhclient-exit-hooks.d
764 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-exit-hooks.d/avahi-autoipd
765 %attr(755,root,root) %{_sbindir}/avahi-autoipd
766 %{_mandir}/man8/avahi-autoipd.8*
767 %{_mandir}/man8/avahi-autoipd.action.8*
768
769 %files libs -f %{name}.lang
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
772 %attr(755,root,root) %ghost %{_libdir}/libavahi-client.so.3
773 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
774 %attr(755,root,root) %ghost %{_libdir}/libavahi-common.so.3
775 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
776 %attr(755,root,root) %ghost %{_libdir}/libavahi-core.so.6
777 # common for -discover*
778 %dir %{_datadir}/%{name}
779 %dir %{_datadir}/%{name}/interfaces
780
781 %files devel
782 %defattr(644,root,root,755)
783 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
784 %attr(755,root,root) %{_libdir}/libavahi-client.so
785 %attr(755,root,root) %{_libdir}/libavahi-common.so
786 %attr(755,root,root) %{_libdir}/libavahi-core.so
787 %{_libdir}/libavahi-client.la
788 %{_libdir}/libavahi-common.la
789 %{_libdir}/libavahi-core.la
790 %{_includedir}/avahi-client
791 %{_includedir}/avahi-common
792 %{_includedir}/avahi-core
793 %{_pkgconfigdir}/avahi-client.pc
794 %{_pkgconfigdir}/avahi-core.pc
795
796 %files static
797 %defattr(644,root,root,755)
798 %{_libdir}/libavahi-client.a
799 %{_libdir}/libavahi-common.a
800 %{_libdir}/libavahi-core.a
801
802 %if %{with gtk}
803 %files ui
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_bindir}/bshell
806 %attr(755,root,root) %{_bindir}/bssh
807 %attr(755,root,root) %{_bindir}/bvnc
808 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
809 %attr(755,root,root) %ghost %{_libdir}/libavahi-ui.so.0
810 %{_mandir}/man1/bssh.1*
811 %{_mandir}/man1/bvnc.1*
812 %{_desktopdir}/bssh.desktop
813 %{_desktopdir}/bvnc.desktop
814
815 %files ui-devel
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libavahi-ui.so
818 %{_libdir}/libavahi-ui.la
819 %{_includedir}/avahi-ui
820 %{_pkgconfigdir}/avahi-ui.pc
821
822 %files ui-static
823 %defattr(644,root,root,755)
824 %{_libdir}/libavahi-ui.a
825 %endif
826
827 %files compat-libdns_sd
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
830 %attr(755,root,root) %ghost %{_libdir}/libdns_sd.so.1
831
832 %files compat-libdns_sd-devel
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/libdns_sd.so
835 %{_libdir}/libdns_sd.la
836 %{_includedir}/avahi-compat-libdns_sd
837 %{_includedir}/dns_sd.h
838 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
839
840 %files compat-libdns_sd-static
841 %defattr(644,root,root,755)
842 %{_libdir}/libdns_sd.a
843
844 %files compat-howl
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
847 %attr(755,root,root) %ghost %{_libdir}/libhowl.so.0
848
849 %files compat-howl-devel
850 %defattr(644,root,root,755)
851 %attr(755,root,root) %{_libdir}/libhowl.so
852 %{_libdir}/libhowl.la
853 %{_includedir}/avahi-compat-howl
854 %{_pkgconfigdir}/avahi-compat-howl.pc
855 %{_pkgconfigdir}/howl.pc
856
857 %files compat-howl-static
858 %defattr(644,root,root,755)
859 %{_libdir}/libhowl.a
860
861 %files -n python-avahi
862 %defattr(644,root,root,755)
863 %{py_sitedir}/avahi
864
865 %if %{with dotnet}
866 %files -n dotnet-avahi
867 %defattr(644,root,root,755)
868 %{_prefix}/lib/mono/gac/avahi-sharp
869
870 %files -n dotnet-avahi-devel
871 %defattr(644,root,root,755)
872 %{_prefix}/lib/mono/avahi-sharp
873 %{_prefix}/lib/monodoc/sources/avahi-sharp-docs.*
874 %{_pkgconfigdir}/avahi-sharp.pc
875
876 %files -n dotnet-avahi-ui
877 %defattr(644,root,root,755)
878 %{_prefix}/lib/mono/gac/avahi-ui-sharp
879
880 %files -n dotnet-avahi-ui-devel
881 %defattr(644,root,root,755)
882 %{_prefix}/lib/mono/avahi-ui-sharp
883 %{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.*
884 %{_pkgconfigdir}/avahi-ui-sharp.pc
885 %endif
886
887 %files glib
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
890 %attr(755,root,root) %ghost %{_libdir}/libavahi-glib.so.1
891
892 %files glib-devel
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_libdir}/libavahi-glib.so
895 %{_libdir}/libavahi-glib.la
896 %{_includedir}/avahi-glib
897 %{_pkgconfigdir}/avahi-glib.pc
898
899 %files glib-static
900 %defattr(644,root,root,755)
901 %{_libdir}/libavahi-glib.a
902
903 %files gobject
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/libavahi-gobject.so.*.*.*
906 %attr(755,root,root) %ghost %{_libdir}/libavahi-gobject.so.0
907
908 %files gobject-devel
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/libavahi-gobject.so
911 %{_libdir}/libavahi-gobject.la
912 %{_includedir}/avahi-gobject
913 %{_pkgconfigdir}/avahi-gobject.pc
914
915 %files gobject-static
916 %defattr(644,root,root,755)
917 %{_libdir}/libavahi-gobject.a
918
919 %if %{with qt3}
920 %files qt
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
923 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt3.so.1
924
925 %files qt-devel
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
928 %{_libdir}/libavahi-qt3.la
929 %{_includedir}/avahi-qt3
930 %{_pkgconfigdir}/avahi-qt3.pc
931
932 %files qt-static
933 %defattr(644,root,root,755)
934 %{_libdir}/libavahi-qt3.a
935 %endif
936
937 %if %{with qt4}
938 %files Qt
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
941 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt4.so.1
942
943 %files Qt-devel
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
946 %{_libdir}/libavahi-qt4.la
947 %{_includedir}/avahi-qt4
948 %{_pkgconfigdir}/avahi-qt4.pc
949
950 %files Qt-static
951 %defattr(644,root,root,755)
952 %{_libdir}/libavahi-qt4.a
953 %endif
954
955 %files bookmarks
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_bindir}/avahi-bookmarks
958 %{_mandir}/man1/avahi-bookmarks.1*
959
960 %if %{with pygtk}
961 %files discover
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_bindir}/avahi-discover
964 %{py_sitedir}/avahi_discover
965 %{_datadir}/%{name}/interfaces/avahi-discover.glade
966 %{_desktopdir}/avahi-discover.desktop
967 %{_pixmapsdir}/avahi.png
968 %{_mandir}/man1/avahi-discover.1*
969 %endif
970
971 %if %{with gtk}
972 %files discover-standalone
973 %defattr(644,root,root,755)
974 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
975 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
976 %endif
977
978 %files utils
979 %defattr(644,root,root,755)
980 %attr(755,root,root) %{_bindir}/avahi-browse
981 %attr(755,root,root) %{_bindir}/avahi-browse-domains
982 %attr(755,root,root) %{_bindir}/avahi-publish
983 %attr(755,root,root) %{_bindir}/avahi-publish-address
984 %attr(755,root,root) %{_bindir}/avahi-publish-service
985 %attr(755,root,root) %{_bindir}/avahi-resolve
986 %attr(755,root,root) %{_bindir}/avahi-resolve-address
987 %attr(755,root,root) %{_bindir}/avahi-resolve-host-name
988 %{_mandir}/man1/avahi-browse.1*
989 %{_mandir}/man1/avahi-browse-domains.1*
990 %{_mandir}/man1/avahi-publish.1*
991 %{_mandir}/man1/avahi-publish-address.1*
992 %{_mandir}/man1/avahi-publish-service.1*
993 %{_mandir}/man1/avahi-resolve.1*
994 %{_mandir}/man1/avahi-resolve-address.1*
995 %{_mandir}/man1/avahi-resolve-host-name.1*
This page took 0.096692 seconds and 3 git commands to generate.