]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- user/group deps in autoipd package as well; adapter
[packages/avahi.git] / avahi.spec
1 #
2 # Conditional build:
3 %bcond_without  dotnet          # build without dotnet bindings
4 %bcond_without  qt              # build without (any) qt bindings
5 %bcond_without  qt3             # build without qt3 bindings
6 %bcond_without  qt4             # build without qt4 bindings
7
8 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
9 %undefine with_dotnet
10 %endif
11 %ifarch i386
12 %undefine with_dotnet
13 %endif
14
15 %if %{without qt}
16 %undefine       with_qt3
17 %undefine       with_qt4
18 %endif
19
20 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
21 Summary:        Free mDNS/DNS-SD/Zeroconf implementation
22 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD/Zeroconf
23 Name:           avahi
24 Version:        0.6.25
25 Release:        5
26 License:        LGPL v2.1+
27 Group:          Applications
28 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
29 # Source0-md5:  a83155a6e29e3988f07e5eea3287b21e
30 Source1:        %{name}-daemon
31 Source2:        %{name}-dnsconfd
32 Source3:        %{name}.png
33 Patch0:         %{name}-desktop.patch
34 Patch1:         %{name}-glade.patch
35 Patch2:         %{name}-destdir.patch
36 Patch3:         %{name}-mono-dir.patch
37 Patch4:         nss-mdns-package.patch
38 Patch5:         %{name}-dhclient_hooks.patch
39 Patch6:         %{name}-autoipd-sbin_ip.patch
40 URL:            http://avahi.org/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  dbus-devel >= 0.92
44 BuildRequires:  doxygen
45 BuildRequires:  expat-devel
46 BuildRequires:  gdbm-devel
47 BuildRequires:  gettext-devel
48 BuildRequires:  glib2-devel >= 1:2.12.2
49 BuildRequires:  graphviz
50 BuildRequires:  gtk+2-devel >= 2:2.10.2
51 BuildRequires:  intltool >= 0.35
52 BuildRequires:  libcap-devel
53 BuildRequires:  libdaemon-devel >= 0.11
54 BuildRequires:  libglade2-devel >= 1:2.6.0
55 BuildRequires:  libtool
56 %if %{with dotnet}
57 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
58 BuildRequires:  mono-csharp
59 BuildRequires:  monodoc >= 2.6
60 %endif
61 BuildRequires:  pkgconfig
62 BuildRequires:  python >= 1:2.4
63 BuildRequires:  python-dbus >= 0.71
64 BuildRequires:  python-pygtk-devel >= 2:2.9.6
65 %if %{with qt3}
66 BuildRequires:  qt-devel >= 1:3.0
67 %endif
68 %if %{with qt4}
69 BuildRequires:  QtCore-devel
70 BuildRequires:  qt4-build
71 %endif
72 BuildRequires:  rpm-pythonprov
73 BuildRequires:  rpmbuild(macros) >= 1.228
74 Requires(post,preun):   /sbin/chkconfig
75 Requires:       %{name}-libs = %{version}-%{release}
76 Requires:       dbus >= 0.92
77 Requires:       libdaemon >= 0.11
78 Provides:       group(avahi)
79 Provides:       user(avahi)
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 Avahi is an implementation the DNS Service Discovery and Multicast DNS
84 specifications for Zeroconf Computing. It uses D-BUS for communication
85 between user applications and a system daemon.
86
87 %description -l pl.UTF-8
88 Avahi jest implementacją specyfikacji DNS Service Discovery i
89 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
90 pomiędzy programami użytkownika a demonem systemowym.
91
92 %package autoipd
93 Summary:        IPv4LL network address configuration daemon
94 Summary(pl.UTF-8):      Demon configurujący adresy IPv4LL
95 Group:          Networking/Daemons
96 Requires(postun):       /usr/sbin/groupdel
97 Requires(postun):       /usr/sbin/userdel
98 Requires(pre):  /bin/id
99 Requires(pre):  /usr/bin/getgid
100 Requires(pre):  /usr/sbin/groupadd
101 Requires(pre):  /usr/sbin/useradd
102 Provides:       group(avahi)
103 Provides:       user(avahi)
104
105 %description autoipd
106 avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4 Link-
107 Local Addresses" (IETF RFC3927), a protocol for automatic IP address
108 configuration from the link-local 169.254.0.0/16 range without the
109 need for a central server. It is primarily intended to be used in
110 ad-hoc networks which lack a DHCP server.
111
112 IPv4LL is part of the Zeroconf stack.
113
114 %description autoipd -l pl.UTF-8
115 avahi-autoipd jest implementacją IPv4LL, protokołu umożliwiającego
116 automatyczną konfigurację adresu z zakresu 169.254.0.0/16 bez potrzeby
117 użycia centralnego serwera. Jego głównym zastosowaniem są sieci
118 ad-hoc, w których brakuje serwera DHCP.
119
120 IPv4LL jest częścią stosu Zeroconf.
121
122 %package libs
123 Summary:        Avahi client, common and core libraries
124 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
125 Group:          Libraries
126
127 %description libs
128 Avahi client, common and core libraries.
129
130 %description libs -l pl.UTF-8
131 Biblioteki Avahi: klienta, wspólna i główna.
132
133 %package devel
134 Summary:        Header files for Avahi library
135 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
136 Group:          Development/Libraries
137 Requires:       %{name}-libs = %{version}-%{release}
138 Requires:       dbus-devel >= 0.92
139 Requires:       expat-devel
140
141 %description devel
142 This is the package containing the header files for Avahi library.
143
144 %description devel -l pl.UTF-8
145 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
146
147 %package static
148 Summary:        Static Avahi library
149 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
150 Group:          Development/Libraries
151 Requires:       %{name}-devel = %{version}-%{release}
152
153 %description static
154 Static Avahi library.
155
156 %description static -l pl.UTF-8
157 Statyczna biblioteka Avahi.
158
159 %package ui
160 Summary:        Avahi UI library
161 Summary(pl.UTF-8):      Biblioteka Avahi UI
162 Group:          X11/Libraries
163 Requires:       %{name}-libs = %{version}-%{release}
164 Requires:       gtk+2 >= 2:2.10.2
165
166 %description ui
167 Common GTK+ UI support library for Avahi.
168
169 %description ui -l pl.UTF-8
170 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
171
172 %package ui-devel
173 Summary:        Header files for Avahi UI library
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
175 Group:          X11/Development/Libraries
176 Requires:       %{name}-devel = %{version}-%{release}
177 Requires:       %{name}-ui = %{version}-%{release}
178 Requires:       gtk+2-devel >= 2:2.10.2
179
180 %description ui-devel
181 Header files for Avahi UI library.
182
183 %description ui-devel -l pl.UTF-8
184 Pliki nagłówkowe biblioteki Avahi UI.
185
186 %package ui-static
187 Summary:        Static Avahi UI library
188 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
189 Group:          X11/Development/Libraries
190 Requires:       %{name}-ui-devel = %{version}-%{release}
191
192 %description ui-static
193 Static Avahi UI library.
194
195 %description ui-static -l pl.UTF-8
196 Statyczna biblioteka Avahi UI.
197
198 %package compat-libdns_sd
199 Summary:        Avahi Bonjour compat library
200 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
201 Group:          Libraries
202 Provides:       mdns-bonjour
203 Obsoletes:      mDNSResponder-libs
204
205 %description compat-libdns_sd
206 Avahi Bonjour compat library.
207
208 %description compat-libdns_sd -l pl.UTF-8
209 Biblioteka Avahi zgodna z Bonjour.
210
211 %package compat-libdns_sd-devel
212 Summary:        Header files for Avahi Bonjour compat library
213 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
214 Group:          Development/Libraries
215 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
216 Requires:       %{name}-devel = %{version}-%{release}
217 Provides:       mdns-bonjour-devel
218 Obsoletes:      mDNSResponder-devel
219
220 %description compat-libdns_sd-devel
221 Header files for Avahi Bonjour compat library.
222
223 %description compat-libdns_sd-devel -l pl.UTF-8
224 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
225
226 %package compat-libdns_sd-static
227 Summary:        Static Avahi Bonjour compat library
228 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
229 Group:          Development/Libraries
230 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
231 Provides:       mdns-bonjour-static
232
233 %description compat-libdns_sd-static
234 Static Avahi Bonjour compat library.
235
236 %description compat-libdns_sd-static -l pl.UTF-8
237 Statyczna biblioteka Avahi zgodna z Bonjour.
238
239 %package compat-howl
240 Summary:        Avahi Howl compat library
241 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
242 Group:          Libraries
243 Provides:       mdns-howl-libs
244 Obsoletes:      howl-libs
245
246 %description compat-howl
247 Avahi Howl compat library.
248
249 %description compat-howl -l pl.UTF-8
250 Biblioteka Avahi zgodna z Howl.
251
252 %package compat-howl-devel
253 Summary:        Header files for Avahi Howl compat library
254 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
255 Group:          Development/Libraries
256 Requires:       %{name}-compat-howl = %{version}-%{release}
257 Requires:       %{name}-devel = %{version}-%{release}
258 Provides:       mdns-howl-devel
259 Obsoletes:      howl-devel
260
261 %description compat-howl-devel
262 Header files for Avahi Howl compat library.
263
264 %description compat-howl-devel -l pl.UTF-8
265 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
266
267 %package compat-howl-static
268 Summary:        Static Avahi Howl compat library
269 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
270 Group:          Development/Libraries
271 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
272 Provides:       mdns-howl-static
273 Obsoletes:      howl-static
274
275 %description compat-howl-static
276 Static Avahi Howl compat library.
277
278 %description compat-howl-static -l pl.UTF-8
279 Statyczna biblioteka Avahi zgodna z Howl.
280
281 %package glib
282 Summary:        Avahi GLib library bindings
283 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
284 Group:          Libraries
285
286 %description glib
287 Avahi GLib library bindings.
288
289 %description glib -l pl.UTF-8
290 Wiązania Avahi dla bibioteki GLib.
291
292 %package glib-devel
293 Summary:        Header files for Avahi GLib library bindings
294 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
295 Group:          Development/Libraries
296 Requires:       %{name}-devel = %{version}-%{release}
297 Requires:       %{name}-glib = %{version}-%{release}
298 Requires:       glib2-devel >= 1:2.12.2
299
300 %description glib-devel
301 This is the package containing the header files for Avahi-glib
302 library.
303
304 %description glib-devel -l pl.UTF-8
305 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
306
307 %package glib-static
308 Summary:        Static Avahi GLib library
309 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
310 Group:          Development/Libraries
311 Requires:       %{name}-glib-devel = %{version}-%{release}
312
313 %description glib-static
314 Static Avahi GLib library.
315
316 %description glib-static -l pl.UTF-8
317 Statyczna biblioteka Avahi GLib.
318
319 %package gobject
320 Summary:        Avahi GObject interface
321 Summary(pl.UTF-8):      Interfejs GObject do Avahi
322 Group:          Libraries
323
324 %description gobject
325 Avahi GObject interface.
326
327 %description gobject -l pl.UTF-8
328 Interfejs GObject do Avahi.
329
330 %package gobject-devel
331 Summary:        Header files for Avahi GObject interface
332 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu GObject do Avahi
333 Group:          Development/Libraries
334 Requires:       %{name}-devel = %{version}-%{release}
335 Requires:       %{name}-gobject = %{version}-%{release}
336 Requires:       glib2-devel >= 1:2.12.2
337
338 %description gobject-devel
339 This is the package containing the header files for Avahi GObject
340 interface.
341
342 %description gobject-devel -l pl.UTF-8
343 Ten pakiet zawiera pliki nagłówkowe interfejsu GObject do Avahi.
344
345 %package gobject-static
346 Summary:        Static Avahi GObject library
347 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GObject
348 Group:          Development/Libraries
349 Requires:       %{name}-gobject-devel = %{version}-%{release}
350
351 %description gobject-static
352 Static Avahi GObject library.
353
354 %description gobject-static -l pl.UTF-8
355 Statyczna biblioteka Avahi GObject.
356
357 %package qt
358 Summary:        Avahi Qt 3 library bindings
359 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
360 Group:          Libraries
361 Requires:       %{name}-libs = %{version}-%{release}
362 Obsoletes:      avahi-qt3
363
364 %description qt
365 Avahi Qt 3 library bindings.
366
367 %description qt -l pl.UTF-8
368 Wiązania Avahi dla biblioteki Qt 3.
369
370 %package qt-devel
371 Summary:        Header files for Avahi Qt 3 library bindings
372 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
373 Group:          Development/Libraries
374 Requires:       %{name}-devel = %{version}-%{release}
375 Requires:       %{name}-qt = %{version}-%{release}
376 Requires:       qt-devel >= 1:3.0
377 Obsoletes:      avahi-qt3-devel
378
379 %description qt-devel
380 Header files for Avahi Qt 3 library bindings.
381
382 %description qt-devel -l pl.UTF-8
383 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
384
385 %package qt-static
386 Summary:        Static Avahi Qt 3 library
387 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
388 Group:          Development/Libraries
389 Requires:       %{name}-qt-devel = %{version}-%{release}
390 Obsoletes:      avahi-qt3-static
391
392 %description qt-static
393 Static Avahi Qt 3 library.
394
395 %description qt-static -l pl.UTF-8
396 Statyczna biblioteka Avahi Qt 3.
397
398 %package Qt
399 Summary:        Avahi Qt 4 library bindings
400 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
401 Group:          Libraries
402 Requires:       %{name}-libs = %{version}-%{release}
403
404 %description Qt
405 Avahi Qt 4 library bindings.
406
407 %description Qt -l pl.UTF-8
408 Wiązania Avahi dla biblioteki Qt 4.
409
410 %package Qt-devel
411 Summary:        Header files for Avahi Qt 4 library bindings
412 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
413 Group:          Development/Libraries
414 Requires:       %{name}-Qt = %{version}-%{release}
415 Requires:       %{name}-devel = %{version}-%{release}
416
417 %description Qt-devel
418 Header files for Avahi Qt 4 library bindings.
419
420 %description Qt-devel -l pl.UTF-8
421 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
422
423 %package Qt-static
424 Summary:        Static Avahi Qt 4 library
425 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
426 Group:          Development/Libraries
427 Requires:       %{name}-Qt-devel = %{version}-%{release}
428
429 %description Qt-static
430 Static Avahi Qt 4 library.
431
432 %description Qt-static -l pl.UTF-8
433 Statyczna biblioteka Avahi Qt 4.
434
435 %package -n python-avahi
436 Summary:        Avahi Python bindings
437 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
438 Group:          Development/Languages/Python
439 Requires:       %{name}-libs = %{version}-%{release}
440 Requires:       python-dbus >= 0.71
441
442 %description -n python-avahi
443 Avahi Python bindings.
444
445 %description -n python-avahi -l pl.UTF-8
446 Wiązania Avahi dla Pythona.
447
448 %package -n dotnet-avahi
449 Summary:        Avahi MONO bindings
450 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
451 Group:          Libraries
452 Requires:       %{name}-libs = %{version}-%{release}
453
454 %description -n dotnet-avahi
455 Avahi MONO bindings.
456
457 %description -n dotnet-avahi -l pl.UTF-8
458 Wiązania Avahi dla MONO.
459
460 %package -n dotnet-avahi-devel
461 Summary:        Development files for MONO Avahi bindings
462 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
463 Group:          Development/Libraries
464 Requires:       dotnet-avahi = %{version}-%{release}
465 Requires:       monodoc >= 2.6
466
467 %description -n dotnet-avahi-devel
468 Development files for MONO Avahi bindings.
469
470 %description -n dotnet-avahi-devel -l pl.UTF-8
471 Pliki rozwojowe wiązań Avahi dla MONO.
472
473 %package -n dotnet-avahi-ui
474 Summary:        Avahi UI MONO bindings
475 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
476 Group:          X11/Libraries
477 Requires:       %{name}-ui = %{version}-%{release}
478 Requires:       dotnet-avahi = %{version}-%{release}
479
480 %description -n dotnet-avahi-ui
481 Avahi UI MONO bindings.
482
483 %description -n dotnet-avahi-ui -l pl.UTF-8
484 Wiązania Avahi UI dla MONO.
485
486 %package -n dotnet-avahi-ui-devel
487 Summary:        Development files for MONO Avahi UI bindings
488 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
489 Group:          X11/Development/Libraries
490 Requires:       dotnet-avahi-ui = %{version}-%{release}
491 Requires:       monodoc >= 2.6
492
493 %description -n dotnet-avahi-ui-devel
494 Development files for MONO Avahi UI bindings.
495
496 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
497 Pliki rozwojowe wiązań Avahi UI dla MONO.
498
499 %package bookmarks
500 Summary:        Miniature web server
501 Summary(pl.UTF-8):      Miniaturowy serwer web
502 Group:          Applications
503
504 %description bookmarks
505 A Python based miniature web server that browses for mDNS/DNS-SD
506 services of type '_http._tcp' (i.e. web sites) and makes them
507 available as HTML links on http://localhost:8080/.
508
509 %description bookmarks -l pl.UTF-8
510 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
511 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
512 je jako odnośniki HTML na http://localhost:8080/.
513
514 %package discover
515 Summary:        Avahi Zeroconf browser
516 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
517 Group:          Applications
518 Requires:       python-avahi = %{version}-%{release}
519 Requires:       python-pygtk-glade >= 2:2.9.6
520
521 %description discover
522 A tool for enumerating all available services on the local LAN
523 (python-pygtk implementation).
524
525 %description discover -l pl.UTF-8
526 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
527 (implementacja w python-pygtk).
528
529 %package discover-standalone
530 Summary:        Avahi Zeroconf browser
531 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
532 Group:          Applications
533 Requires:       %{name}-glib = %{version}-%{release}
534
535 %description discover-standalone
536 GTK+ tool for enumerating all available services on the local LAN.
537
538 %description discover-standalone -l pl.UTF-8
539 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
540 LAN.
541
542 %package utils
543 Summary:        Avahi CLI utilities
544 Summary(pl.UTF-8):      Narzędzia CLI Avahi
545 Group:          Applications
546
547 %description utils
548 Command line utilities using avahi-client.
549
550 %description utils -l pl.UTF-8
551 Narzędzia linii poleceń korzystające z avahi-client.
552
553 %prep
554 %setup -q
555 %patch0 -p1
556 %patch1 -p1
557 %patch2 -p1
558 %patch3 -p1
559 %patch4 -p1
560 %patch5 -p1
561 %patch6 -p1
562
563 %build
564 %{__intltoolize}
565 %{__libtoolize}
566 %{__aclocal} -I common
567 %{__autoconf}
568 %{__autoheader}
569 %{__automake}
570 %configure \
571         --enable-compat-libdns_sd \
572         --enable-compat-howl \
573         --with-distro=none \
574         %{!?with_qt3:--disable-qt3} \
575         %{!?with_qt4:--disable-qt4} \
576         %{!?with_dotnet:--disable-mono} \
577         %{!?with_dotnet:--disable-monodoc} \
578         --with-avahi-priv-access-group=adm \
579         --with-autoipd-user=avahi \
580         --with-autoipd-group=avahi
581 %{__make}
582
583 %install
584 rm -rf $RPM_BUILD_ROOT
585 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d}
586
587 %{__make} install \
588         DESTDIR=$RPM_BUILD_ROOT \
589         pythondir=%{py_sitedir}
590
591 install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
592 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
593
594 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
595         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
596
597 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
598         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
599
600 rm -f $RPM_BUILD_ROOT%{py_sitedir}/avahi/{__init__,SimpleGladeApp}.py \
601         $RPM_BUILD_ROOT%{py_sitedir}/avahi_discover/*.py
602
603 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
604 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
605 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
606 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
607 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
608 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
609 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
610
611 %find_lang %{name}
612
613 %clean
614 rm -rf $RPM_BUILD_ROOT
615
616 %pre
617 %groupadd -g 165 -r -f avahi
618 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
619
620 %pre autoipd
621 %groupadd -g 165 -r -f avahi
622 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
623
624 %post
625 /sbin/chkconfig --add %{name}-daemon
626 %service %{name}-daemon restart
627 /sbin/chkconfig --add %{name}-dnsconfd
628 %service %{name}-dnsconfd restart
629
630 %preun
631 if [ "$1" = "0" ]; then
632         %service -q %{name}-dnsconfd stop
633         /sbin/chkconfig --del %{name}-dnsconfd
634         %service -q %{name}-daemon stop
635         /sbin/chkconfig --del %{name}-daemon
636 fi
637
638 %postun
639 if [ "$1" = "0" ]; then
640         %userremove avahi
641         %groupremove avahi
642 fi
643
644 %postun autoipd
645 if [ "$1" = "0" ]; then
646         %userremove avahi
647         %groupremove avahi
648 fi
649
650 %post   libs -p /sbin/ldconfig
651 %postun libs -p /sbin/ldconfig
652
653 %post   ui -p /sbin/ldconfig
654 %postun ui -p /sbin/ldconfig
655
656 %post   compat-libdns_sd -p /sbin/ldconfig
657 %postun compat-libdns_sd -p /sbin/ldconfig
658
659 %post   compat-howl -p /sbin/ldconfig
660 %postun compat-howl -p /sbin/ldconfig
661
662 %post   glib -p /sbin/ldconfig
663 %postun glib -p /sbin/ldconfig
664
665 %post   gobject -p /sbin/ldconfig
666 %postun gobject -p /sbin/ldconfig
667
668 %post   qt -p /sbin/ldconfig
669 %postun qt -p /sbin/ldconfig
670
671 %post   Qt -p /sbin/ldconfig
672 %postun Qt -p /sbin/ldconfig
673
674 %files
675 %defattr(644,root,root,755)
676 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
677
678 %dir %{_sysconfdir}/avahi
679 %dir %{_sysconfdir}/avahi/services
680 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
681 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
682 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
683 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
684 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
685 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*
686
687 %attr(755,root,root) %{_bindir}/avahi-set-host-name
688
689 %attr(755,root,root) %{_sbindir}/avahi-daemon
690 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
691
692 %dir %{_datadir}/%{name}/introspection
693 %{_datadir}/%{name}/introspection/*.introspect
694 %{_datadir}/%{name}/avahi-service.dtd
695 %{_datadir}/%{name}/service-types
696 %dir %{_libdir}/%{name}
697 %{_libdir}/%{name}/service-types.db
698
699 %{_mandir}/man1/avahi-set-host-name.1*
700 %{_mandir}/man5/avahi-daemon.conf.5*
701 %{_mandir}/man5/avahi.hosts.5*
702 %{_mandir}/man5/avahi.service.5*
703 %{_mandir}/man8/avahi-daemon.8*
704 %{_mandir}/man8/avahi-dnsconfd.8*
705 %{_mandir}/man8/avahi-dnsconfd.action.8*
706
707 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
708 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
709
710 %files autoipd
711 %defattr(644,root,root,755)
712 %dir %{_sysconfdir}/avahi
713 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
714 %dir %{_sysconfdir}/dhclient-enter-hooks.d
715 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-enter-hooks.d/avahi-autoipd
716 %dir %{_sysconfdir}/dhclient-exit-hooks.d
717 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-exit-hooks.d/avahi-autoipd
718 %attr(755,root,root) %{_sbindir}/avahi-autoipd
719 %{_mandir}/man8/avahi-autoipd.8*
720 %{_mandir}/man8/avahi-autoipd.action.8*
721
722 %files libs -f %{name}.lang
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libavahi-client.so.3
726 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
727 %attr(755,root,root) %ghost %{_libdir}/libavahi-common.so.3
728 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libavahi-core.so.6
730 # common for -discover*
731 %dir %{_datadir}/%{name}
732 %dir %{_datadir}/%{name}/interfaces
733
734 %files devel
735 %defattr(644,root,root,755)
736 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
737 %attr(755,root,root) %{_libdir}/libavahi-client.so
738 %attr(755,root,root) %{_libdir}/libavahi-common.so
739 %attr(755,root,root) %{_libdir}/libavahi-core.so
740 %{_libdir}/libavahi-client.la
741 %{_libdir}/libavahi-common.la
742 %{_libdir}/libavahi-core.la
743 %{_includedir}/avahi-client
744 %{_includedir}/avahi-common
745 %{_includedir}/avahi-core
746 %{_pkgconfigdir}/avahi-client.pc
747 %{_pkgconfigdir}/avahi-core.pc
748
749 %files static
750 %defattr(644,root,root,755)
751 %{_libdir}/libavahi-client.a
752 %{_libdir}/libavahi-common.a
753 %{_libdir}/libavahi-core.a
754
755 %files ui
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_bindir}/bshell
758 %attr(755,root,root) %{_bindir}/bssh
759 %attr(755,root,root) %{_bindir}/bvnc
760 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
761 %attr(755,root,root) %ghost %{_libdir}/libavahi-ui.so.0
762 %{_mandir}/man1/bssh.1*
763 %{_mandir}/man1/bvnc.1*
764 %{_desktopdir}/bssh.desktop
765 %{_desktopdir}/bvnc.desktop
766
767 %files ui-devel
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_libdir}/libavahi-ui.so
770 %{_libdir}/libavahi-ui.la
771 %{_includedir}/avahi-ui
772 %{_pkgconfigdir}/avahi-ui.pc
773
774 %files ui-static
775 %defattr(644,root,root,755)
776 %{_libdir}/libavahi-ui.a
777
778 %files compat-libdns_sd
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
781 %attr(755,root,root) %ghost %{_libdir}/libdns_sd.so.1
782
783 %files compat-libdns_sd-devel
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libdns_sd.so
786 %{_libdir}/libdns_sd.la
787 %{_includedir}/avahi-compat-libdns_sd
788 %{_includedir}/dns_sd.h
789 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
790
791 %files compat-libdns_sd-static
792 %defattr(644,root,root,755)
793 %{_libdir}/libdns_sd.a
794
795 %files compat-howl
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
798 %attr(755,root,root) %ghost %{_libdir}/libhowl.so.0
799
800 %files compat-howl-devel
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libhowl.so
803 %{_libdir}/libhowl.la
804 %{_includedir}/avahi-compat-howl
805 %{_pkgconfigdir}/avahi-compat-howl.pc
806 %{_pkgconfigdir}/howl.pc
807
808 %files compat-howl-static
809 %defattr(644,root,root,755)
810 %{_libdir}/libhowl.a
811
812 %files -n python-avahi
813 %defattr(644,root,root,755)
814 %{py_sitedir}/avahi
815
816 %if %{with dotnet}
817 %files -n dotnet-avahi
818 %defattr(644,root,root,755)
819 %{_prefix}/lib/mono/gac/avahi-sharp
820
821 %files -n dotnet-avahi-devel
822 %defattr(644,root,root,755)
823 %{_prefix}/lib/mono/avahi-sharp
824 %{_prefix}/lib/monodoc/sources/avahi-sharp-docs.*
825 %{_pkgconfigdir}/avahi-sharp.pc
826
827 %files -n dotnet-avahi-ui
828 %defattr(644,root,root,755)
829 %{_prefix}/lib/mono/gac/avahi-ui-sharp
830
831 %files -n dotnet-avahi-ui-devel
832 %defattr(644,root,root,755)
833 %{_prefix}/lib/mono/avahi-ui-sharp
834 %{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.*
835 %{_pkgconfigdir}/avahi-ui-sharp.pc
836 %endif
837
838 %files glib
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
841 %attr(755,root,root) %ghost %{_libdir}/libavahi-glib.so.1
842
843 %files glib-devel
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libavahi-glib.so
846 %{_libdir}/libavahi-glib.la
847 %{_includedir}/avahi-glib
848 %{_pkgconfigdir}/avahi-glib.pc
849
850 %files glib-static
851 %defattr(644,root,root,755)
852 %{_libdir}/libavahi-glib.a
853
854 %files gobject
855 %defattr(644,root,root,755)
856 %attr(755,root,root) %{_libdir}/libavahi-gobject.so.*.*.*
857 %attr(755,root,root) %ghost %{_libdir}/libavahi-gobject.so.0
858
859 %files gobject-devel
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_libdir}/libavahi-gobject.so
862 %{_libdir}/libavahi-gobject.la
863 %{_includedir}/avahi-gobject
864 %{_pkgconfigdir}/avahi-gobject.pc
865
866 %files gobject-static
867 %defattr(644,root,root,755)
868 %{_libdir}/libavahi-gobject.a
869
870 %if %{with qt3}
871 %files qt
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
874 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt3.so.1
875
876 %files qt-devel
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
879 %{_libdir}/libavahi-qt3.la
880 %{_includedir}/avahi-qt3
881 %{_pkgconfigdir}/avahi-qt3.pc
882
883 %files qt-static
884 %defattr(644,root,root,755)
885 %{_libdir}/libavahi-qt3.a
886 %endif
887
888 %if %{with qt4}
889 %files Qt
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
892 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt4.so.1
893
894 %files Qt-devel
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
897 %{_libdir}/libavahi-qt4.la
898 %{_includedir}/avahi-qt4
899 %{_pkgconfigdir}/avahi-qt4.pc
900
901 %files Qt-static
902 %defattr(644,root,root,755)
903 %{_libdir}/libavahi-qt4.a
904 %endif
905
906 %files bookmarks
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_bindir}/avahi-bookmarks
909 %{_mandir}/man1/avahi-bookmarks.1*
910
911 %files discover
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_bindir}/avahi-discover
914 %{py_sitedir}/avahi_discover
915 %{_datadir}/%{name}/interfaces/avahi-discover.glade
916 %{_desktopdir}/avahi-discover.desktop
917 %{_pixmapsdir}/avahi.png
918 %{_mandir}/man1/avahi-discover.1*
919
920 %files discover-standalone
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
923 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
924
925 %files utils
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_bindir}/avahi-browse
928 %attr(755,root,root) %{_bindir}/avahi-browse-domains
929 %attr(755,root,root) %{_bindir}/avahi-publish
930 %attr(755,root,root) %{_bindir}/avahi-publish-address
931 %attr(755,root,root) %{_bindir}/avahi-publish-service
932 %attr(755,root,root) %{_bindir}/avahi-resolve
933 %attr(755,root,root) %{_bindir}/avahi-resolve-address
934 %attr(755,root,root) %{_bindir}/avahi-resolve-host-name
935 %{_mandir}/man1/avahi-browse.1*
936 %{_mandir}/man1/avahi-browse-domains.1*
937 %{_mandir}/man1/avahi-publish.1*
938 %{_mandir}/man1/avahi-publish-address.1*
939 %{_mandir}/man1/avahi-publish-service.1*
940 %{_mandir}/man1/avahi-resolve.1*
941 %{_mandir}/man1/avahi-resolve-address.1*
942 %{_mandir}/man1/avahi-resolve-host-name.1*
This page took 0.108937 seconds and 3 git commands to generate.