]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
f42593f53965e3d3353bdbcfd2ba9f41c79e77f9
[packages/automake.git] / automake.spec
1 Summary:        GNU automake - Makefile configuration tools
2 Summary(de):    GNU automake - Makefile-Konfigurationstools
3 Summary(fr):    automake de GNU - Outils de configuration des makefiles
4 Summary(pl):    GNU Automake - generator plików Makefile
5 Summary(tr):    Makefile yapýlandýrma araçlarý
6 Name:           automake
7 Version:        1.4
8 Release:        4
9 Copyright:      GPL
10 Group:          Development/Building
11 Group(pl):      Programowanie/Budowanie
12 Source:         ftp://ftp.cygnus.com/pub/tromey/%{name}-%{version}.tar.gz
13 Patch0:         automake-info.patch
14 URL:            http://sourceware.cygnus.com/automake/
15 Requires:       perl
16 Prereq:         /sbin/install-info
17 Buildroot:      /tmp/%{name}-%{version}-root
18 BuildArch:      noarch
19
20 %description
21 Automake is an experimental Makefile generator. It was inspired by the
22 4.4BSD make and include files, but aims to be portable and to conform to the
23 GNU standards for Makefile variables and targets.
24
25 %description -l de
26 Automake ist ein experimenteller Makefile-Generator, inspiriert durch die
27 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und Konformität
28 mit den GNU-Standards für Makefile-Variable und Targets abzielt.
29
30 %description -l fr
31 automake est un générateur expérimental de makefiles. Il a été inspiré par
32 le make de BSD 4.4, mais se veut portable et conforme aux standards GNU pour
33 les variables et les cibles des makefiles.
34
35 %description -l pl
36 Automake jest eksperymentalnym generatorem plików Makefile'a. Narzêdzie to
37 jest wzorowane na make i plikach nag³ówków z systemu 4.4BSD. Umo¿liwia ono
38 generowanie plików Makefile w oderwaniu od platformy systemowej bêd±c
39 jednoce¶nie zgodnym ze standardami GNU.
40
41 %description -l tr
42 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
43 dosyalarýndan esinlenilmistir, ama amaç taþýnabilir olmak ve Makefile
44 deðiþkenleri ve hedefleri için GNU standartlarýna uyum göstermektir.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 ./configure \
52         --prefix=/usr
53 make
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 make install prefix=$RPM_BUILD_ROOT/usr
58
59 gzip -9nf $RPM_BUILD_ROOT/usr/info/automake* \
60         AUTHORS ChangeLog NEWS README THANKS TODO
61
62 %post
63 /sbin/install-info /usr/info/automake.info.gz /etc/info-dir
64
65 %preun
66 if [ "$1" = "0" ]; then
67         /sbin/install-info --delete /usr/info/automake.info.gz /etc/info-dir
68 fi
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc {AUTHORS,ChangeLog,NEWS,README,THANKS,TODO}.gz
76 %attr(755,root,root) /usr/bin/*
77 /usr/info/automake*
78
79 /usr/share/aclocal
80
81 %dir /usr/share/automake
82 /usr/share/automake/*.am
83 /usr/share/automake/texinfo.tex
84 %attr(755,root,root) /usr/share/automake/config.guess
85 %attr(755,root,root) /usr/share/automake/config.sub
86 %attr(755,root,root) /usr/share/automake/install-sh
87 %attr(755,root,root) /usr/share/automake/mdate-sh
88 %attr(755,root,root) /usr/share/automake/elisp-comp
89 %attr(755,root,root) /usr/share/automake/acinstall
90 %attr(755,root,root) /usr/share/automake/ylwrap
91 %attr(755,root,root) /usr/share/automake/mkinstalldirs
92 %attr(755,root,root) /usr/share/automake/missing
93
94 %changelog
95 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
96   [1.4-4]
97 - full %attr description for files in /usr/share.
98
99 * Wed Jan 26 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
100   [1.4-1d]
101 - added Group(pl).
102
103 * Tue Dec 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
104   [1.3d-3]
105 - standarized {un}registering info pages (second try .. added
106   automake-info.patch).
107
108 * Wed Dec 23 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
109   [1.3d-2]
110 - (waiting for new autoconf): fixed @SHELL@ bug.
111
112 * Sat Dec 19 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
113   [1.3d-1]
114 - updated URL,
115 - standarized {un}registering info pages.
116
117 * Sat Nov 21 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
118   [1.3b-1]
119 - changed base Source url,
120 - cosmetic changes in %post, %preun in {un}registering autoame info page,
121 - added URL.
122
123 * Sat Aug  1 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
124   [1.3-5]
125 - modified pl translation,
126 - added -q %setup parameter,
127 - removed INSTALL and COPING from %doc (copyright statment is in Copyright
128   field),
129 - Buildroot changed to /tmp/%%{name}-%%{version}-root,
130 - fixed %defattr macro,
131 - added using %%{name} and %%{version} macro in Source.
132
133 * Mon Jun 29 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
134   [1.3-4]
135 - added pl translation,
136 - build from non root's account,
137 - added %defattr support.
138
139 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
140 - translations modified for de, fr, tr
141
142 * Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
143 - updated to 1.3
144
145 * Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
146 - added BuildRoot; added aclocal files
147
148 * Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
149 - made it a noarch package
150
151 * Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
152 - Fixed some tag lines to conform to 5.0 guidelines.
153
154 * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
155 - updated to 1.2
156
157 * Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
158 - first version (1.0)
This page took 0.074649 seconds and 2 git commands to generate.