]> git.pld-linux.org Git - packages/audit.git/blob - audit.spec
- up to 1.3
[packages/audit.git] / audit.spec
1 #
2 # Conditional build:
3 %bcond_without  pie     # auditd as PIE binary
4 %bcond_without  python  # don't build python bindings
5 #
6 Summary:        User space tools for 2.6 kernel auditing
7 Summary(pl):    Narzêdzia przestrzeni u¿ytkownika do audytu j±der 2.6
8 Name:           audit
9 Version:        1.3
10 Release:        1
11 License:        GPL
12 Group:          Daemons
13 Source0:        http://people.redhat.com/sgrubb/audit/%{name}-%{version}.tar.gz
14 # Source0-md5:  5aba24b53266b6eeb9b710178b874e73
15 # formerly http://people.redhat.com/sgrubb/audit/audit.h
16 Source1:        %{name}.h
17 Source2:        %{name}d.init
18 Source3:        %{name}d.sysconfig
19 Patch0:         %{name}-swig-fix.patch
20 Patch1:         %{name}-install.patch
21 URL:            http://people.redhat.com/sgrubb/audit/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.9
24 %{?with_pie:BuildRequires:      gcc >= 5:3.4}
25 BuildRequires:  glibc-headers >= 6:2.3.6
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  linux-libc-headers >= 2.6.11
29 %if %{with python}
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  swig-python
32 %else
33 BuildRequires:  sed >= 4.0
34 %endif
35 BuildRequires:  rpmbuild(macros) >= 1.268
36 Requires(post,preun):   /sbin/chkconfig
37 Requires:       %{name}-libs = %{version}-%{release}
38 Requires:       rc-scripts
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sbindir        /sbin
42
43 %description
44 The audit package contains the user space utilities for storing and
45 processing the audit records generate by the audit subsystem in the
46 Linux 2.6 kernel.
47
48 %description -l pl
49 Ten pakiet zawiera narzêdzia przestrzeni u¿ytkownika do przechowywania
50 i przetwarzania rekordów audytu generowanych przez podsystem audytu w
51 j±drach Linuksa 2.6.
52
53 %package libs
54 Summary:        Dynamic audit libraries
55 Summary(pl):    Biblioteki dynamiczne audit
56 License:        LGPL
57 Group:          Libraries
58
59 %description libs
60 The audit-libs package contains the dynamic libraries needed for
61 applications to use the audit framework.
62
63 %description libs -l pl
64 Ten pakiet zawiera biblioteki dynamiczne potrzebne dla aplikacji
65 u¿ywaj±cych ¶rodowiska audytu.
66
67 %package libs-devel
68 Summary:        Header files for audit libraries
69 Summary(pl):    Pliki nag³ówkowe bibliotek audit
70 License:        LGPL
71 Group:          Development/Libraries
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       linux-libc-headers >= 7:2.6.12.0-4
74
75 %description libs-devel
76 The audit-libs-devel package contains the header files needed for
77 developing applications that need to use the audit framework library.
78
79 %description libs-devel -l pl
80 Ten pakiet zawiera pliki nag³ówkowe potrzebne do tworzenia aplikacji
81 u¿ywaj±cych biblioteki ¶rodowiska audytu.
82
83 %package libs-static
84 Summary:        Static audit libraries
85 Summary(pl):    Statyczne biblioteki audit
86 License:        LGPL
87 Group:          Development/Libraries
88 Requires:       %{name}-libs-devel = %{version}-%{release}
89
90 %description libs-static
91 The audit-libs-static package contains the static libraries for
92 developing applications that need to use the audit framework.
93
94 %description libs-static -l pl
95 Ten pakiet zawiera statyczne biblioteki do tworzenia aplikacji
96 u¿ywaj±cych ¶rodowiska audytu.
97
98 %package -n python-audit
99 Summary:        Python interface to libaudit library
100 Summary(pl):    Pythonowy interfejs do biblioteki libaudit
101 License:        LGPL
102 Group:          Libraries/Python
103 Requires:       %{name}-libs = %{version}-%{release}
104
105 %description -n python-audit
106 Python interface to libaudit library.
107
108 %description -n python-audit -l pl
109 Pythonowy interfejs do biblioteki libaudit.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115
116 install -D %{SOURCE1} lib/linux/audit.h
117 install -D %{SOURCE1} src/mt/linux/audit.h
118
119 %if !%{with python}
120 sed '/PYTHON/d; s#swig/Makefile ##' -i configure.ac
121 sed 's/swig//' -i Makefile.am
122 %endif
123
124 %build
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure
131 # override auditd_{C,LD}FLAGS to avoid -fPIE unsupported by gcc 3.3
132 %{__make} \
133         %{!?with_pie:auditd_CFLAGS="-D_REENTRANT -D_GNU_SOURCE" auditd_LDFLAGS="-Wl,-z,relro"}
134
135 # temporarily not included in all
136 %{__make} -C auparse
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT%{_var}/log/audit
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 # temporarily not included in all
146 %{__make} -C auparse install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 install -d $RPM_BUILD_ROOT/%{_lib}
150 mv -f $RPM_BUILD_ROOT%{_libdir}/libaudit.so.* $RPM_BUILD_ROOT/%{_lib}
151 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libaudit.so.*.*.*) \
152         $RPM_BUILD_ROOT%{_libdir}/libaudit.so
153 mv -f $RPM_BUILD_ROOT%{_libdir}/libauparse.so.* $RPM_BUILD_ROOT/%{_lib}
154 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libauparse.so.*.*.*) \
155         $RPM_BUILD_ROOT%{_libdir}/libauparse.so
156
157 # We manually install this since Makefile doesn't
158 install -d $RPM_BUILD_ROOT%{_includedir}
159 install lib/libaudit.h $RPM_BUILD_ROOT%{_includedir}
160
161 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/auditd
162 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/auditd
163
164 %if %{with python}
165 if [ "%{py_sitedir}" != "/usr/lib/python2.4/site-packages" ]; then
166 install -d $RPM_BUILD_ROOT%{py_sitedir}
167 mv $RPM_BUILD_ROOT/usr/lib/python2.4/site-packages/* $RPM_BUILD_ROOT%{py_sitedir}
168 fi
169 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
170 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
171 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
172 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
173 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*.py
174 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.py
175 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
176 %else
177 rm -r $RPM_BUILD_ROOT/usr/lib/python2.4
178 %endif
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post   libs -p /sbin/ldconfig
184 %postun libs -p /sbin/ldconfig
185
186 %post
187 /sbin/chkconfig --add auditd
188 %service auditd restart "audit daemon"
189
190 %preun
191 if [ "$1" = "0" ]; then
192         %service auditd stop
193         /sbin/chkconfig --del auditd
194 fi
195
196 %files
197 %defattr(644,root,root,755)
198 %doc AUTHORS ChangeLog README THANKS TODO sample.rules
199 %attr(750,root,root) %{_sbindir}/auditctl
200 %attr(750,root,root) %{_sbindir}/auditd
201 %attr(750,root,root) %{_sbindir}/aureport
202 %attr(750,root,root) %{_sbindir}/ausearch
203 %attr(750,root,root) %{_sbindir}/autrace
204 %attr(754,root,root) /etc/rc.d/init.d/auditd
205 %dir %{_sysconfdir}/audit
206 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/audit/auditd.conf
207 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/audit/audit.rules
208 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/auditd
209 %attr(750,root,root) %dir %{_var}/log/audit
210 %{_mandir}/man8/*
211
212 %files libs
213 %defattr(644,root,root,755)
214 %attr(755,root,root) /%{_lib}/libaudit.so.*.*.*
215 %attr(755,root,root) /%{_lib}/libauparse.so.*.*.*
216 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libaudit.conf
217
218 %files libs-devel
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libaudit.so
221 %attr(755,root,root) %{_libdir}/libauparse.so
222 %{_libdir}/libaudit.la
223 %{_libdir}/libauparse.la
224 %{_includedir}/libaudit.h
225 %{_mandir}/man3/*
226
227 %files libs-static
228 %defattr(644,root,root,755)
229 %{_libdir}/libaudit.a
230 %{_libdir}/libauparse.a
231
232 %if %{with python}
233 %files -n python-audit
234 %defattr(644,root,root,755)
235 %attr(750,root,root) %{_sbindir}/audispd
236 %attr(755,root,root) %{py_sitedir}/_audit.so
237 %{py_sitescriptdir}/audit.py[co]
238 %{py_sitedir}/AuditMsg.py[co]
239 %endif
This page took 0.104377 seconds and 4 git commands to generate.