]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- addes static subpackage and Requires rule for main package in devel.
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        1.1.4
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 Patch0:         %{name}-miscfix.patch
10 URL:            http://oss.sgi.com/projects/xfs/
11 BuildRequires:  autoconf
12 BuildRequires:  e2fsprogs-devel
13 BuildRequires:  xfsprogs-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _bindir         /bin
17
18 %description
19 An experimental attr command to manipulate extended attributes under
20 Linux.
21
22 %description -l pl
23 Eksperymentalne wersja polecenia attr to zarz±dzania rozszerzonymi
24 atrybutami pod systemem Linux.
25
26 %package devel
27 Summary:        Header files and libraries to use extended attributes
28 Summary(pl):    Pliki nag³ówkowe i biblioteki
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}
31
32 %description devel
33 Header files and libraries to develop software which manipulate
34 extended attributes.
35
36 %description devel -l pl
37 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
38 manipuluj±cego rozszerzonymi atrybutami.
39
40 %package static
41 Summary:        Static libraries for extended attributes
42 Summary(pl):    Biblioteki statyczne attr
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}
45
46 %description static
47 Static libraries for extended attributes.
48
49 %description static -l pl
50 Biblioteki statyczne attr.
51
52 %prep
53 %setup  -q
54 %patch0 -p1
55
56 %build
57 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
58 autoconf
59 %configure
60
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 DIST_ROOT="$RPM_BUILD_ROOT"
67 DIST_INSTALL=`pwd`/install.manifest
68 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
69 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
70
71 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
72 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
73
74 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
75 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
76
77 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
78 ln -sf /lib/libattr.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/libattr.so
79
80 echo ".so man3/attr_get.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
81 echo ".so man3/attr_list.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
82 echo ".so man3/attr_multi.3"    > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
83 echo ".so man3/attr_remove.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
84 echo ".so man3/attr_set.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
85
86 gzip -9nf doc/CHANGES
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc doc/*.gz
97 %attr(755,root,root) %{_bindir}/*
98 %attr(755,root,root) /lib/lib*.so.*.*
99 %{_mandir}/man[18]/*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/lib*.la
104 %attr(755,root,root) %{_libdir}/lib*.so
105 %{_includedir}/attr
106 %{_mandir}/man[23]/*
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/lib*.a
This page took 0.072254 seconds and 4 git commands to generate.