]> git.pld-linux.org Git - packages/attica.git/blob - attica.spec
autodetects wrong qt series
[packages/attica.git] / attica.spec
1 # TODO
2 # - ensure consistent build (qt4 or qt5), currently it autodetects
3 %define         qt_ver          4.8.3
4 Summary:        Attica Library - implementation of Open Collaboration Services API for Qt
5 Summary(pl.UTF-8):      Attica Library - implementacja API Serwisów Otwartej Współpracy dla Qt
6 Name:           attica
7 Version:        0.4.2
8 Release:        2
9 License:        GPL
10 Group:          X11/Libraries
11 # svn co svn://anonsvn.kde.org/home/kde/trunk/kdesupport/attica/
12 Source0:        ftp://ftp.kde.org/pub/kde/stable/attica/%{name}-%{version}.tar.bz2
13 # Source0-md5:  d62c5c9489a68432e8d990dde7680c24
14 URL:            http://www.kde.org/
15 BuildRequires:  QtTest-devel >= %{qt_ver}
16 BuildRequires:  QtCore-devel >= %{qt_ver}
17 BuildRequires:  QtGui-devel >= %{qt_ver}
18 BuildRequires:  QtNetwork-devel >= %{qt_ver}
19 BuildRequires:  QtXml-devel >= %{qt_ver}
20 BuildRequires:  cmake >= 2.8.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  qt4-build >= %{qt_ver}
23 BuildRequires:  qt4-qmake >= %{qt_ver}
24 BuildRequires:  rpmbuild(macros) >= 1.600
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Attica is a Qt library that implements the Open Collaboration Services
29 API. It grants easy access to the services such as querying
30 information about persons and contents.
31
32 %description -l pl.UTF-8
33 Attica jest biblioteką Qt, która implementuje API Serwisów Otwartej
34 Współpracy. Pozwala na łatwy dostęp do serwisów takich jak zapytania o
35 informacje o osobach i treściach.
36
37 %package devel
38 Summary:        Header files for attica library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki attica
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for attica library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki attica.
48
49 %prep
50 %setup -q
51
52 %build
53 install -d build
54 cd build
55 %cmake ..
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} -C build install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post   -p      /sbin/ldconfig
67 %postun -p      /sbin/ldconfig
68
69 %files
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_libdir}/libattica.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/libattica.so.0.4
73
74 %files devel
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_libdir}/libattica.so
77 %{_includedir}/attica
78 %{_pkgconfigdir}/libattica.pc
This page took 0.143755 seconds and 4 git commands to generate.