]> git.pld-linux.org Git - packages/at.git/blob - at.spec
- "Requires: rc-scripts >= 0.2.0",
[packages/at.git] / at.spec
1 Summary:        at job spooler
2 Summary(de):    at-Job-Spooler
3 Summary(fr):    Gestionnaire de taches at
4 Summary(pl):    Demon kontroli zadañ
5 Summary(tr):    þ düzenleyici
6 Name:           at
7 Version:        3.1.8
8 Release:        15
9 License:        GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 Source0:        ftp://tsx-11.mit.edu/pub/linux/sources/usr.bin/%{name}-%{version}.tar.gz
13 Source1:        atd.init
14 Source2:        at.sysconfig
15 Source3:        at.1.pl
16 Source4:        at_allow.5.pl
17 Source5:        atd.8.pl
18 Source6:        atrun.8.pl
19 Patch0:         at-lockfile.patch
20 Patch1:         at-install.patch
21 Patch2:         at-man.patch
22 Patch3:         at.patch
23 Patch4:         at-typo.patch
24 Patch5:         at-sigchld.patch
25 BuildRequires:  autoconf
26 Prereq:         fileutils
27 Prereq:         /sbin/chkconfig
28 Requires:       mailx
29 Requires:       rc-scripts >= 0.2.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _sysconfdir     /etc/at
33
34 %description
35 at and batch read commands from standard input or a specified file which
36 are to be executed at a later time, using /bin/sh.
37
38 %description -l de
39 Stapelverarbeitung von Lesebefehlen von einer Standard- oder einer
40 genannten Datei zu einem späteren Zeitpunkt unter Verwendung von /bin/sh.
41
42 %description -l fr
43 at et batch lisent, sur l'entrée standard ou dans un fichier, des commandes
44 qui doivent être exécutées plus tard en utilisant /bin/sh.
45
46 %description -l pl
47 At i batch czytaj± komendy ze standardowego wej¶cia lub specyficznego
48 pliku, które s± nastêpnie wykonywane o okre¶lonej godzinie, przy pomocy
49 /bin/sh.
50
51 %description -l tr
52 at ve batch /bin/sh kabuðunu kullanarak, belli bir saatte çalýþtýrmak üzere
53 standart giriþden ya da bir dosyadan komut okur.
54
55 %prep
56 %setup -q
57 %patch0 -p1 
58 %patch1 -p1 
59 %patch2 -p1 
60 %patch3 -p1 
61 %patch4 -p1 
62 %patch5 -p1 
63
64 %build
65 aclocal
66 autoconf
67 LDFLAGS="-s"; export LDFLAGS
68 %configure \
69         --with-atspool=/var/spool/at/spool \
70         --with-jobdir=/var/spool/at \
71         --with-etcdir=%{_sysconfdir} \
72         --with-daemon_username=root \
73         --with-daemon_groupname=root
74 make 
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},%{_mandir}/pl/man{1,5,8}}
79
80 make IROOT=$RPM_BUILD_ROOT install
81
82 install at.deny $RPM_BUILD_ROOT%{_sysconfdir}
83
84 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/atd
85 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/at
86
87 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{atq,atrm,batch}.1
88 rm -f $RPM_BUILD_ROOT%{_mandir}/man5/at_deny.5
89
90 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/atq.1
91 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/atrm.1
92 echo .so at.1 > $RPM_BUILD_ROOT%{_mandir}/man1/batch.1
93
94 echo .so at_allow.5 > $RPM_BUILD_ROOT%{_mandir}/man5/at_deny.5
95 echo .so at_allow.5 > $RPM_BUILD_ROOT%{_mandir}/man5/at_acces.5
96
97 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1/at.1
98 echo ".so at.1" > $RPM_BUILD_ROOT%{_mandir}/pl/man1/atq.1
99 echo ".so at.1" > $RPM_BUILD_ROOT%{_mandir}/pl/man1/atrm.1
100 echo ".so at.1" > $RPM_BUILD_ROOT%{_mandir}/pl/man1/batch.1
101 install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/pl/man5/at_allow.5
102 echo ".so at_allow.5" > $RPM_BUILD_ROOT%{_mandir}/pl/man5/at.access.5
103 echo ".so at_allow.5" > $RPM_BUILD_ROOT%{_mandir}/pl/man5/at.deny.5
104 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/pl/man8/atd.8
105 install %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/pl/man8/atrun.8
106
107 touch $RPM_BUILD_ROOT/var/spool/at/.SEQ
108
109 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/{man*/*,pl/man?/*} \
110         ChangeLog README
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 /sbin/chkconfig --add atd
117 if [ -f /var/lock/subsys/atd ]; then
118         /etc/rc.d/init.d/atd restart >&2
119 else
120         echo "Run \"/etc/rc.d/init.d/atd start\" to start atd daemon."
121 fi
122
123 %preun
124 if [ "$1" = "0" ] ; then
125         if [ -f /var/lock/subsys/atd ]; then
126                 /etc/rc.d/init.d/atd stop >&2
127         fi
128         /sbin/chkconfig --del atd
129 fi
130
131 %files
132 %defattr(644,root,root,755)
133 %doc {ChangeLog,README}.gz
134
135 %attr(750,root,root) %dir %{_sysconfdir}
136 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*
137 %attr(640,root,root) %config %verify(not size mtime md5) /etc/sysconfig/*
138
139 %attr(754,root,root) /etc/rc.d/init.d/atd
140 %attr(755,root,root) %{_sbindir}/*
141
142 %attr(4755,root,root) %{_bindir}/at
143
144 %attr(755,root,root) %{_bindir}/atq
145 %attr(755,root,root) %{_bindir}/atrm
146 %attr(755,root,root) %{_bindir}/batch
147
148 %{_mandir}/man*/*
149 %lang(pl) %{_mandir}/pl/man*/*
150
151 %attr(750,root,root) %dir /var/spool/at
152 %attr(750,root,root) %dir /var/spool/at/spool
153 %attr(600,root,root) %ghost /var/spool/at/.SEQ
This page took 0.033846 seconds and 3 git commands to generate.