]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- state changed from snapshots to unstable, updating to 3.3.0rc1
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #bcond_with     cvs     # use cvs sources instead of source0
7 #
8
9 %define         _state          unstable
10 %define         _ver            1.3.0
11 #define         _snap           040724
12
13 Summary:        aRts sound server
14 Summary(pl):    Serwer d¼wiêku
15 Summary(pt_BR): Servidor de sons usado pelo KDE
16 Name:           arts
17 Version:        %{_ver}
18 Release:        0.rc1.1
19 Epoch:          13
20 License:        LGPL
21 Group:          Libraries
22 Source0:        http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}-rc1.tar.bz2
23 # Source0-md5:  851eb8eb8f6c28c289857322169d7120
24 #if ! %{with cvs}
25 #Source0:       ftp://ftp.pld-linux.org/software/kde/%{name}-%{version}rc1.tar.bz2
26 #else
27 #Source0:       kdesource.tar.gz
28 #endif
29 URL:            http://www.kde.org/
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 BuildRequires:  audiofile-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  docbook-dtd41-sgml
35 BuildRequires:  docbook-utils >= 0.6.13-3
36 %{?with_esd:BuildRequires:      esound-devel}
37 BuildRequires:  glib2-devel >= 2.0.0
38 BuildRequires:  libmad-devel
39 BuildRequires:  libtool >= 2:1.5-2
40 BuildRequires:  libvorbis-devel
41 %{?with_nas:BuildRequires:      nas-devel}
42 BuildRequires:  pkgconfig
43 BuildRequires:  qt-devel >= 6:3.2.1-4
44 BuildRequires:  unsermake >= 040805-1
45 Obsoletes:      arts-glib
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 The Analog Real-Time Synthesizer, or aRts, is a modular system for
50 synthesizing sound and music on a digital computer. Using small
51 building blocks called modules, the user can easily build complex
52 audio processing tools. Modules typically provide functions such as
53 sound waveform generators, filters, audio effects, mixing, and
54 playback of digital audio in different file formats. The artsd sound
55 server mixes audio from several sources in real time, allowing
56 multiple sound applications to transparently share access to sound
57 hardware.
58
59 %description -l pl
60 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
61 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
62 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
63 d¼wiêku. Modu³y umo¿liwiaj± generacjê kstza³tu fali, filtrowanie,
64 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
65 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
66 odtwarzanie d¼wiêku z wielu ¼róde³.
67
68 %description -l pt_BR
69 O aRts é um sintetizador analógico em tempo real que é completamente
70 modular. Você pode criar sons e músicas (síntese em tempo real de
71 midi) usando pequenos módulos como oscilador para criar waveforms,
72 vários filtros, mixers, faders, etc. Você pode configurar tudo através
73 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
74 design foi escolhido para permitir que outras aplicações usem o aRts
75 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
76 outros.
77
78 %package devel
79 Summary:        Sound server - header files
80 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
81 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
82 Group:          Development/Libraries
83 Requires:       %{name} = %{epoch}:%{version}-%{release}
84 # not necessary for all libs (e.g. mcop), but propagated by artsflow
85 %{?with_alsa:Requires:  alsa-lib-devel}
86 Requires:       audiofile-devel
87 Requires:       esound-devel
88 Requires:       glib2-devel >= 2.0.0
89 Requires:       libmad-devel
90 Requires:       libvorbis-devel
91 %{?with_nas:Requires:   nas-devel}
92
93 %description devel
94 Header files required to compile programs using arts.
95
96 %description devel -l pl
97 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
98 arts.
99
100 %description devel -l pt_BR
101 Arquivos para desenvolvimento com o o aRts.
102
103 # separate from arts-devel because they are mostly independent and
104 # have very # different deps  there is no artsc base - it would be
105 # small and would require arts - so there is no reason to separate
106 %package -n artsc-devel
107 Summary:        Development files for artsc libraries
108 Summary(pl):    Pliki programistyczne bibliotek artsc
109 Group:          Development/Libraries
110 Requires:       %{name} = %{epoch}:%{version}-%{release}
111 Requires:       glib2-devel >= 2.0.0
112 Conflicts:      arts-devel < 12:1.2.0.031126-2
113
114 %description -n artsc-devel
115 Development files for artsc libraries (C interface to aRts sound
116 system).
117
118 %description -n artsc-devel -l pl
119 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
120 d¼wiêku aRts).
121
122 %package X11
123 Summary:        X11 dependent part of aRts
124 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
125 Group:          X11/Libraries
126 Requires:       %{name} = %{epoch}:%{version}-%{release}
127
128 %description X11
129 X11 dependent part of aRts (x11globalcomm module).
130
131 %description X11 -l pl
132 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
133
134 %package qt
135 Summary:        QT dependend part of aRts
136 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
137 Group:          X11/Libraries
138 Requires:       %{name} = %{epoch}:%{version}-%{release}
139 Requires:       qt >= 6:3.2.1-4
140
141 %description qt
142 QT dependend part of aRts (qtmcop library).
143
144 %description qt -l pl
145 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
146
147 %package qt-devel
148 Summary:        Development files for qtmcop library
149 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
150 Group:          X11/Development/Libraries
151 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
152 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
153 Requires:       qt-devel >= 6:3.2.1-4
154
155 %description qt-devel
156 Development files for qtmcop library.
157
158 %description qt-devel -l pl
159 Pliki programistyczne dla biblioteki qtmcop.
160
161 %prep
162 #if ! %{with cvs}
163 %setup -q -n %{name}-%{version}
164 #else
165 #setup -q -n %{name} -D
166 #endif
167
168 %build
169
170 cp /usr/share/automake/config.sub admin
171
172 export UNSERMAKE=/usr/share/unsermake/unsermake
173
174 %{__make} -f admin/Makefile.common cvs
175
176 %configure \
177         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
178         --%{?debug:en}%{!?debug:dis}able-debug \
179         --disable-rpath \
180         --enable-final \
181         --with-qt-libraries=%{_libdir} \
182         --with%{!?with_alsa:out}-alsa
183
184 %{__make}
185
186 %install
187 rm -rf $RPM_BUILD_ROOT
188
189 %{__make} install \
190         DESTDIR=$RPM_BUILD_ROOT
191
192 # Debian manpages
193 install -d $RPM_BUILD_ROOT%{_mandir}/man1
194 cd debian/man
195 for f in *.sgml ; do
196         base="$(basename $f .sgml)"
197         upper="$(echo ${base} | tr a-z A-Z)"
198         db2man $f
199         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
200 done
201
202 %clean
203 rm -rf $RPM_BUILD_ROOT
204
205 %post   -p /sbin/ldconfig
206 %postun -p /sbin/ldconfig
207
208 %post   X11 -p /sbin/ldconfig
209 %postun X11 -p /sbin/ldconfig
210
211 %post   qt -p /sbin/ldconfig
212 %postun qt -p /sbin/ldconfig
213
214 %files
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/artscat
217 %attr(755,root,root) %{_bindir}/artsd
218 %attr(755,root,root) %{_bindir}/artsdsp
219 %attr(755,root,root) %{_bindir}/artsplay
220 %attr(755,root,root) %{_bindir}/artsrec
221 %attr(755,root,root) %{_bindir}/artsshell
222 %attr(755,root,root) %{_bindir}/artswrapper
223 # shared libraries
224 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
228 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
229 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
230 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
231 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
232 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
233 # lt_dlopened modules (*.la needed)
234 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
235 %{_libdir}/libartscbackend.la
236 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
237 %{_libdir}/libartsdsp.la
238 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
239 %{_libdir}/libartsdsp_st.la
240 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
241 %{_libdir}/libartsgslplayobject.la
242 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
243 %{_libdir}/libartswavplayobject.la
244 #
245 %{_libdir}/mcop
246 %{_mandir}/man1/artscat.1*
247 %{_mandir}/man1/artsd.1*
248 %{_mandir}/man1/artsdsp.1*
249 %{_mandir}/man1/artsplay.1*
250 %{_mandir}/man1/artsrec.1*
251 %{_mandir}/man1/artsshell.1*
252 %{_mandir}/man1/artswrapper.1*
253
254 %files devel
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_bindir}/mcopidl
257 %attr(755,root,root) %{_libdir}/libartsflow.so
258 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
259 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
260 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
261 %attr(755,root,root) %{_libdir}/libgmcop.so
262 %attr(755,root,root) %{_libdir}/libkmedia2.so
263 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
264 %attr(755,root,root) %{_libdir}/libmcop.so
265 %attr(755,root,root) %{_libdir}/libmcop_mt.so
266 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
267 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
268 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
269 # shared libraries
270 %{_libdir}/libartsflow.la
271 %{_libdir}/libartsflow_idl.la
272 %{_libdir}/libgmcop.la
273 %{_libdir}/libkmedia2.la
274 %{_libdir}/libkmedia2_idl.la
275 %{_libdir}/libmcop.la
276 %{_libdir}/libmcop_mt.la
277 %{_libdir}/libsoundserver_idl.la
278 #
279 %{_includedir}/arts
280 %exclude %{_includedir}/arts/qiomanager.h
281 %{_mandir}/man1/mcopidl.1*
282
283 %files -n artsc-devel
284 %defattr(644,root,root,755)
285 %attr(755,root,root) %{_bindir}/artsc-config
286 %attr(755,root,root) %{_libdir}/libartsc.so
287 %attr(755,root,root) %{_libdir}/libartscbackend.so
288 %attr(755,root,root) %{_libdir}/libartsdsp.so
289 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
290 %{_libdir}/libartsc.la
291 %{_includedir}/artsc
292 %{_mandir}/man1/artsc-config.1*
293
294 %files X11
295 %defattr(644,root,root,755)
296 # lt_dlopened module (.la needed)
297 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
298 %{_libdir}/libx11globalcomm.la
299
300 %files qt
301 %defattr(644,root,root,755)
302 # shared library
303 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
304
305 %files qt-devel
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_libdir}/libqtmcop.so
308 %{_libdir}/libqtmcop.la
309 %{_includedir}/arts/qiomanager.h
This page took 0.174233 seconds and 3 git commands to generate.