]> git.pld-linux.org Git - packages/arm-trusted-firmware.git/blob - arm-trusted-firmware.spec
remove fix for binutils >= 2.39 (already handled upstream)
[packages/arm-trusted-firmware.git] / arm-trusted-firmware.spec
1 Summary:        ARM Trusted Firmware
2 Name:           arm-trusted-firmware
3 Version:        2.10.0
4 Release:        1
5 License:        BSD
6 Group:          Base/Kernel
7 Source0:        https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/snapshot/trusted-firmware-a-%{version}.tar.gz
8 # Source0-md5:  a262a00bae874ce7cb355d30fbee6767
9 URL:            https://developer.arm.com/tools-and-software/open-source-software/firmware/trusted-firmware
10 BuildRequires:  crossarm-gcc
11 BuildRequires:  dtc
12 BuildRequires:  openssl-tools
13 BuildRequires:  rpmbuild(macros) >= 1.750
14 ExclusiveArch:  aarch64
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 ARM Trusted firmware is a reference implementation of secure world
19 software for ARMv8-A including Exception Level 3 (EL3) software. It
20 provides a number of standard ARM interfaces like Power State
21 Coordination (PSCI), Trusted Board Boot Requirements (TBBR) and Secure
22 Monitor.
23
24 Note: the contents of this package are generally just consumed by
25 bootloaders such as u-boot. As such the binaries aren't of general
26 interest to users.
27
28 %package -n arm-trusted-firmware-armv8
29 Summary:        ARM Trusted Firmware for ARMv8-A
30
31 %description -n arm-trusted-firmware-armv8
32 ARM Trusted Firmware binaries for various ARMv8-A SoCs.
33
34 Note: the contents of this package are generally just consumed by
35 bootloaders such as u-boot. As such the binaries aren't of general
36 interest to users.
37
38 Note: the contents of this package are generally just consumed by
39 bootloaders such as u-boot. As such the binaries aren't of general
40 interest to users.
41
42 %prep
43 %setup -q -n trusted-firmware-a-%{version}
44
45 %build
46 for soc in rk3399; do
47 %{__make} \
48         V=1 \
49         HOSTCC="%{__cc} %{rpmcflags}" \
50         CROSS_COMPILE="" \
51         M0_CROSS_COMPILE="arm-linux-gnueabi-" \
52         PLAT="$soc" \
53         bl31
54 done
55 %{__make} -C tools/fiptool \
56         V=1 \
57         HOSTCC="%{__cc}" \
58         HOSTCCFLAGS="%{rpmcflags}" \
59         CPPFLAGS="%{rpmcppflags}"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}}
64
65 for soc in rk3399; do
66         install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/$soc
67         for file in bl31/bl31.elf m0/rk3399m0.bin m0/rk3399m0.elf; do
68                 if [ -f build/$soc/release/$file ]; then
69                         cp -p build/$soc/release/$file $RPM_BUILD_ROOT%{_datadir}/%{name}/$soc
70                 fi
71         done
72 done
73
74 cp -p tools/fiptool/fiptool $RPM_BUILD_ROOT%{_bindir}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files -n arm-trusted-firmware-armv8
80 %defattr(644,root,root,755)
81 %doc readme.rst
82 %attr(755,root,root) %{_bindir}/fiptool
83 %{_datadir}/%{name}
This page took 0.135627 seconds and 4 git commands to generate.