]> git.pld-linux.org Git - packages/arj.git/blob - arj.spec
- use proper CC and CFLAGS
[packages/arj.git] / arj.spec
1 Summary:        ARJ archiver for Linux
2 Summary(pl):    Archiwizator ARJ dla Linuksa
3 Name:           arj
4 Version:        3.10b
5 Release:        2
6 License:        GPL
7 Group:          Applications/Archiving
8 Source0:        http://testcase.newmail.ru/files/%{name}-%{version}.tar.gz
9 BuildRequires:  autoconf
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %define         no_install_post_strip 1
13
14 %description
15 This product is an implementation of ARJ v 2.7x for DOS on UNIX and
16 UNIX-like systems. It is assumed that the user is familiar with ARJ
17 operation on DOS before using this package.
18
19 %description -l pl
20 Jest to implementacja programu ARJ v 2.7x dla DOS na platformê UNIX i
21 systemy uniksopodobne. Zak³ada siê, ¿e u¿ytkownik korzystaj±cy z tego
22 pakietu zna sposób funkcjonowania programu ARJ pod DOS-em.
23
24 %prep
25 %setup -q
26
27 %build
28 cd gnu
29 %{__autoconf}
30 %configure
31 cd ..
32 %{__make} -f makefile.gnu prepare
33 %{__make} -f makefile.gnu \
34         CC="%{__cc}" \
35         CFLAGS_DBG="%{rpmcflags}"
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}}
40
41 cd linux-gnu/en/rs
42 install \
43         arj/arj \
44         arjdisp/arjdisp \
45         rearj/rearj \
46         $RPM_BUILD_ROOT%{_bindir}
47 install register/register $RPM_BUILD_ROOT%{_bindir}/register-arj
48
49 install arjcrypt/arjcrypt.so $RPM_BUILD_ROOT%{_libdir}
50
51 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{arjdisp,rearj,register-arj}}
52 %{!?debug:strip --strip-unneeded -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/*.so}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc ChangeLog doc/rev_hist.txt resource/en/arjl.txt resource/en/readme.txt resource/en/unix.txt
60 %attr(755,root,root) %{_bindir}/*
61 %attr(755,root,root) %{_libdir}/*
This page took 0.048876 seconds and 4 git commands to generate.