]> git.pld-linux.org Git - packages/apache1-mod_auth_checkpasswd.git/blob - apache1-mod_auth_checkpasswd.spec
- mv apache{,1}-*, release 1
[packages/apache1-mod_auth_checkpasswd.git] / apache1-mod_auth_checkpasswd.spec
1 %define         mod_name        auth_checkpasswd
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        This is the CHECKPASSWD authentication module for Apache
4 Summary(pl):    To jest modu³ Apache uwierzytelniaj±cy przez CHECKPASSWD
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.0
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  7f699981ada026656affe2e35409bdf2
12 Patch0:         %{name}-aplog.patch
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache1-devel
15 Requires(post,preun):   %{apxs}
16 Requires:       apache1
17 Obsoletes:      apache-mod_%{mod_name} <= %{version}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21
22 %description
23 This is an authentication module for Apache that uses an external
24 application compatible with DJB's "checkpasswd". The application may
25 be setuid, which gives you a possibility to verify passwords using
26 regular /etc/shadow.
27
28 %description -l pl
29 To jest modu³ uwierzytelniaj±cy dla Apache który wykorzystuje
30 zewnêtrzn± aplikacjê kompatybiln± z "checkpasswd" DJB. Aplikacja mo¿e
31 byæ suidowana, co daje mo¿liwo¶æ weryfikowania hase³ wykorzystuj±c
32 zwyk³y plik /etc/shadow.
33
34 %prep
35 %setup -q -c -n "mod_%{mod_name}-%{version}"
36 %patch -p1
37
38 %build
39 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_pkglibdir}
44
45 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52 if [ -f /var/lock/subsys/apache ]; then
53         /etc/rc.d/init.d/apache restart 1>&2
54 fi
55
56 %preun
57 if [ "$1" = "0" ]; then
58         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
59         if [ -f /var/lock/subsys/apache ]; then
60                 /etc/rc.d/init.d/apache restart 1>&2
61         fi
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.063297 seconds and 3 git commands to generate.