]> git.pld-linux.org Git - packages/apache-mod_xslt2.git/blob - apache-mod_xslt2.spec
- fix requires and buildrequires
[packages/apache-mod_xslt2.git] / apache-mod_xslt2.spec
1 %define         mod_name        xslt
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl):    Modu³ do udostêpniania dokumentów XML
5 Name:           apache-mod_%{mod_name}2
6 Version:        1.3.5
7 Release:        1
8 %define snapdate 2004080100
9 License:        GPL
10 Group:          Networking/Daemons
11 Source0:        http://www.mod-xslt2.com/software/archive/%{snapdate}/modxslt-%{snapdate}.tar.gz
12 # Source0-md5:  5d7f607679a1ffb5dad48a93e655e8ff
13 Source1:        %{name}.conf
14 Patch0:         %{name}-makefile.patch
15 URL:            http://www.mod-xslt2.com/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel
18 BuildRequires:  pcre-devel
19 BuildRequires:  libxslt-devel
20 Requires(post,preun):   %{apxs}
21 Conflicts:      apache-mod_xslt
22 Obsoletes:      apache-mod_xslt
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
26 %define         _sysconfdir     /etc/httpd
27
28 %description
29 mod_xslt is a simple Apache module to serve XML based content. Data is
30 stored in XML files on the server. The user requests the XML file and
31 the translation method via a url such as this:
32 http://localhost/sourcefile.html. The module will parse this URL into
33 a XML source file and an XSL source file. In the example above, the
34 XML file will be sourcefile.xml. The module will open sourcefile.xml
35 and determine its DOCTYPE. Based on the DOCTYPE, the XSL file will be
36 opened. Should the DOCTYPE be "tutorial", the XSL file opened would be
37 tutorial_html.xsl. The content-type returned to the browser is
38 text/html. The translation occurs transparently to the user.
39
40 %description -l pl
41 mod_xslt jest prostym modu³em Apache do udostêpniania dokumentów XML.
42 Dane s± zapisane w plikach XML na serwerze. U¿ytkownik ¿±da pliku XML
43 i t³maczenia poprzez URL w stylu http://localhost/sourcefile.html.
44 Modu³ zamienia ten URL na pliki ¼ród³owe XML i XSL. W tym przyk³adzie
45 plikiem XML bêdzie sourcefile.xml. Modu³ otworzy plik sourcefile.xml i
46 okre¶li DOCTYPE, na podstawie którego otworzy odpowiedni plik XSL.
47 Je¿eli DOCTYPE jest "tutorial", plikiem XSL bêdzie tutorial_html.xsl.
48 Nastêpnie modu³ dokona przetwarzania pliku XML za pomoc± arkusza XSLT
49 i zwróci przegl±darce powsta³y w ten sposób text/html. Ca³y proces
50 odbywa siê w sposób niewidoczny dla u¿ytkownika.
51
52 %package devel
53 Summary:        development headers for mod_xslt2
54 Group:  Development/Libraries
55
56 %description devel
57 development headers for mod_xslt2.
58
59 %package static
60 Summary:        static libraries for mod_xslt2
61 Group:  Development/Libraries
62
63 %description static
64 static libraries for mod_xslt2.
65
66 %prep
67 %setup -q -n mod%{mod_name}-%{snapdate}
68 %patch0 -p1
69
70 %build
71 %configure
72 %{__make} APXS=%{apxs}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
77
78 %{__make} install DESTDIR=$RPM_BUILD_ROOT
79
80 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_xslt2.conf
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post
86 ldconfig
87 if [ -f /var/lock/subsys/httpd ]; then
88         /etc/rc.d/init.d/httpd restart 1>&2
89 fi
90
91 %preun
92 if [ "$1" = "0" ]; then
93         if [ -f /var/lock/subsys/httpd ]; then
94                 /etc/rc.d/init.d/httpd restart 1>&2
95         fi
96 fi
97 ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*
102 %attr(755,root,root) %{_pkglibdir}/*
103 %{_libdir}/libmodxslt0.so.0.0.0
104
105 %files devel
106 %{_bindir}/*
107 %{_includedir}/modxslt0/*.h
108 %{_libdir}/*.la
109
110 %files static
111 %{_libdir}/*.a
This page took 0.03379 seconds and 3 git commands to generate.